Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > ICON & C|24

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-20-2009, 11:24 PM
dvodesilva dvodesilva is offline
Member
 
Join Date: Oct 2009
Posts: 13
Default Control 24 speaker noise problem

Hi, I've just acquired a Control 24 from a friend and have a few issues i was hoping you guys can help me with.
First of all this is a control 24, not a c24. The first thing is my main speaker output seems to make a loud pop noise when i shut down the board, also it seems at times that my speakers are dropping to a lower volume randomly and the only way to remedy this is to turn the main speaker knob all the way up, then it seems that the speaker are at the volume they should be, then i can turn it down and with the speakers giving an accurate volume. i've seen an old post of cleaning the boards speaker contacts, but couldn't find any directions on how to do this.
the second issue is that my talk back switch intermittently goes out. The light doesn't work and i have to keep pushing the button to make it work, but somedays it would work just fine.
The last thing is some of my faders wouldn't go all the way down when shutting down the board.
sorry for all the questions and lengthy post, but i already had two tweeters blow out on my ex66 monitors because of this and im worried it could cause more potential problems.
i'm pretty technical and would prefer to try to fix it myself before i head to a repair shop.

Thank you all so much in advance for any help and suggestions that you might have.
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1kHz PC & Speaker Noise - HELP!!! dbooth Windows 17 09-14-2014 09:50 PM
Speaker Noise only when PT launches Mdubbs818 macOS 1 08-11-2013 05:29 AM
Weird Noise Through Speaker... VTI Pro Tools M-Powered (Win) 2 08-31-2011 04:43 PM
weird (not white noise) in right speaker in any app paul5mq 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 08-12-2009 03:13 PM
Digi 002 Speaker Noise tubestudio 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 6 04-09-2004 12:28 PM


All times are GMT -7. The time now is 04:16 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com