Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 02-27-2004, 03:49 PM
Laurence w schuberth Laurence w schuberth is offline
Member
 
Join Date: Dec 2000
Location: Newcastle NSW Australia
Posts: 91
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

bump
Reply With Quote
  #12  
Old 02-27-2004, 05:37 PM
Digi Engineering Digi Engineering is offline
Member
 
Join Date: Dec 1969
Location: Berkeley, CA USA
Posts: 1,406
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

Hi guys,

I have a fix for this (in our driver). I'll see about getting it out to those who need it.

Thanks,
-Ted

DAE Group
Digi Engineering
Reply With Quote
  #13  
Old 02-27-2004, 11:01 PM
BHeller BHeller is offline
Member
 
Join Date: Jun 1999
Location: Minneapolis, MN 55105
Posts: 292
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

Wow, that would be fantastic! It's important to know that at least this is being worked on and addressed. Knowing it is in the works is often the difference between dumping a product and continuing to make it the center of a platform at a facility.

By all means, I would like to try a copy. I hope it is finalized and rolled into an official release as well.

Thanks very much for seeking us out, Ted...

-Brian
brian@whattheheller.com
__________________
Brian Heller,
composer & engineer
brian@whattheheller.com
http://www.WhatTheHeller.com
Reply With Quote
  #14  
Old 02-28-2004, 05:53 PM
Laurence w schuberth Laurence w schuberth is offline
Member
 
Join Date: Dec 2000
Location: Newcastle NSW Australia
Posts: 91
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

Thanks Digi
I would also lov to be kept updated
Laurence@one80digitalpost.com.au

Cheers
LASWELL
Reply With Quote
  #15  
Old 02-29-2004, 04:32 AM
JFreak's Avatar
JFreak JFreak is online now
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 21,468
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

Quote:
I would love it if Digi took a little more intrest in the core driver.
me too, and i'd love if digi would implement AU support into protools. coreaudio is a good start but the driver will need to be perfected before digi gear will begin gaining more respect in the field that praises motu gear and logic. granted, those people are not the sharpest end of all audio engineers in the mac platform, but the osx native technologies will need to be supported anyway. DIGI are you listening? are you aware that people who have bought digi gear wish to be able to use the gear in other software than protools, too? like peak for example. please perfect that driver, it's a must because you have stated to support coreaudio. the current coreaudio driver is below your standards.

the AU support in protools would be nice thing, but i doubt that will happen...
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #16  
Old 02-29-2004, 05:22 AM
nashvegas nashvegas is offline
Member
 
Join Date: Jun 2002
Location: Nashville
Posts: 7
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

Hey Ted, I would also like a solution to this problem. I've got a project that I was trying to use Peak on with my digi002 as the sound source and ran into the same problems everyone here has had... also including crashing with digi002 as a sound source.

Thanks,
John
Reply With Quote
  #17  
Old 03-08-2004, 11:30 AM
nashvegas nashvegas is offline
Member
 
Join Date: Jun 2002
Location: Nashville
Posts: 7
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

Hey,

Did anyone hear anything about this fix for coreaudio?

Thanks,
John
Reply With Quote
  #18  
Old 03-09-2004, 10:04 PM
bassntreble bassntreble is offline
Member
 
Join Date: Oct 2002
Location: NYC
Posts: 449
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

I'm not sure if my problems are related to difficulties you are experiencing in peak, however this does boil down to digidesign's core audio driver so I felt it would fit into this thread.

I have a fresh install of Panther 10.3.2 on a Tibook 667. I am running PTLE 6.2.3 on an MBox with more stability in terms of playback/record facility and overall robustness of the app than in previous versions. When I am running other apps, namely Reason and Logic, with the Digidesign Core Audio driver as the preferred driver they crash. Below are exerpts of the crash logs, 3 instances for Reason and one for Logic

REASON:
------------------------------instance #1-------------------------
Thread 12 Crashed:
0 <<00000000>> 0x00000000 0 + 0
1 ...idesign.DigiCoreAudioPlugIn 0x0525eafc _ZN19DigiCoreAudioDevice16DirectIOCallbackEP15IODr iverAudioPB + 0x74 (DigiCoreAudioDevice.cpp:136)
2 ...idesign.DigiCoreAudioPlugIn 0x0525e91c _ZN19DigiCoreAudioDevice22StaticDirectIOCallbackEP 15IODriverAudioPB + 0x30 (DigiCoreAudioDevice.cpp:58)
3 DirectIO 0x05688a20 0x567e000 + 0xaa20
4 DirectIO 0x05684de4 0x567e000 + 0x6de4
5 DirectIO 0x0568a7d0 0x567e000 + 0xc7d0
6 DirectIO 0x056898d0 0x567e000 + 0xb8d0
7 DirectIO 0x05689a28 0x567e000 + 0xba28
8 DirectIO 0x056aead8 0x567e000 + 0x30ad8
9 ??? 0x05855c30 _ZN12CLowIODevice14StreamCompleteEP7CStream + 0x208
10 ??? 0x0585c144 _ZN9RTRunLoop8TaskMainEPv + 0x15c
11 ...ple.CoreServices.CarbonCore 0x902c6f3c PrivateMPEntryPoint + 0x4c
12 libSystem.B.dylib 0x900247e8 _pthread_body + 0x28


-------------------------------instance #2------------------------
Thread 12 Crashed:
0 <<00000000>> 0x00000000 0 + 0
1 ...idesign.DigiCoreAudioPlugIn 0x0525eafc _ZN19DigiCoreAudioDevice16DirectIOCallbackEP15IODr iverAudioPB + 0x74 (DigiCoreAudioDevice.cpp:136)
2 ...idesign.DigiCoreAudioPlugIn 0x0525e91c _ZN19DigiCoreAudioDevice22StaticDirectIOCallbackEP 15IODriverAudioPB + 0x30 (DigiCoreAudioDevice.cpp:58)
3 DirectIO 0x05688a20 0x567e000 + 0xaa20
4 DirectIO 0x05684de4 0x567e000 + 0x6de4
5 DirectIO 0x0568a7d0 0x567e000 + 0xc7d0
6 DirectIO 0x056898d0 0x567e000 + 0xb8d0
7 DirectIO 0x05689a28 0x567e000 + 0xba28
8 DirectIO 0x056aead8 0x567e000 + 0x30ad8
9 ??? 0x05855c30 _ZN12CLowIODevice14StreamCompleteEP7CStream + 0x208
10 ??? 0x0585c144 _ZN9RTRunLoop8TaskMainEPv + 0x15c
11 ...ple.CoreServices.CarbonCore 0x902c6f3c PrivateMPEntryPoint + 0x4c
12 libSystem.B.dylib 0x900247e8 _pthread_body + 0x28


-------------------------------instance #3----------------------------
Thread 0 Crashed:
0 com.apple.audio.CoreAudio 0x907221c0 _ZltRK17HPPropertyAddressS1_ + 0
1 com.apple.audio.CoreAudio 0x9077703c 0x90720000 + 0x5703c
2 com.apple.audio.CoreAudio 0x90725f70 _ZNK16HPPropertyObject11HasPropertyERK17HPProperty Address + 0x28
3 com.apple.audio.CoreAudio 0x90727fa8 _ZNK8HPDevice11HasPropertyERK17HPPropertyAddress + 0x294
4 com.apple.audio.CoreAudio 0x90725968 _ZNK9IOADevice11HasPropertyERK17HPPropertyAddress + 0x16c
5 com.apple.audio.CoreAudio 0x9072c32c _Z39HPDeviceSettings_SaveControlsFromObjectRK16HPP ropertyObjectbmR14CACFDictionarybPKN16HPDeviceSett ings11ControlInfoEm + 0x74
6 com.apple.audio.CoreAudio 0x90745a70 _ZN16HPDeviceSettings16SaveToDictionaryERK8HPDevic ePKNS_11ControlInfoEm + 0x70
7 com.apple.audio.CoreAudio 0x907458b4 _ZN16HPDeviceSettings11SaveToPrefsERK8HPDevicePKNS _11ControlInfoEm + 0x20
8 com.apple.audio.CoreAudio 0x90745708 _ZN9IOAPlugIn12DeviceIsDeadEP9IOADevice + 0x134
9 com.apple.audio.CoreAudio 0x907454f4 _ZN9IOAPlugIn8TeardownEv + 0x3c
10 com.apple.audio.CoreAudio 0x90745478 _Z16HPPlugInTeardownPP28AudioHardwarePlugInInterfa ce + 0x28
11 com.apple.audio.CoreAudio 0x907453b4 _ZN22HALPlugInDeviceFactory8TeardownEv + 0x30
12 com.apple.audio.CoreAudio 0x9074534c _ZN9HALSystem15TeardownDevicesEv + 0x28
13 com.apple.audio.CoreAudio 0x907452d0 _ZN9HALSystem13AtExitHandlerEv + 0xa8
14 com.apple.audio.CoreAudio 0x907451c8 _ZN9HALAtExit13AtExitHandlerEv + 0x6c
15 libSystem.B.dylib 0x9002c8b8 exit + 0x58
16 com.apple.HIServices 0x92d46f28 _ZN16OpaqueICInstanceC1Ev + 0
17 Reason 0x01355508 0x1008000 + 0x34d508
18 Reason 0x01355478 0x1008000 + 0x34d478


LOGIC:
Thread 13 Crashed:
0 <<00000000>> 0x39473abc 0 + 0x39473abc
1 ...ple.CoreServices.CarbonCore 0x902c6f3c PrivateMPEntryPoint + 0x4c
2 libSystem.B.dylib 0x900247e8 _pthread_body + 0x28


Now, I'm no expert at reading crash logs, nor do I code. But from looking at the logs, I can see the words "Direct I/O" amd "digicoreaduiodevice", indicating the Digi core audio driver is involved in the instability of the apps in some way. I am, or at least try to be for the most part, an end user that simply wants my hardware and software to work. It is my understanding that Apple developed core audio in conjunction with the other major audio developers (Steiny, Emagic, Digi, Yamaha to name a few) in order to bring a standard to the platform. Being that TDM/HD systems have their own subsystems for handling audio, bypassing Mac's core audio and effectively becoming their own platform, I would imagine the previously mentioned phenomenon to be quite acceptable. But LE being host based should, by all accounts, follow the rules set by the host.

I really hope digidesign takes this core audio problem seriously, even if we didn't drop 7k on an HD core+I/O. I am awaiting delivery of a G5 and was planning on buying a Digi002 to complement the new computer. Maybe I should rethink that and keep the mbox around with the Tibook dedicated to protools, since it really is the best tool for editing audio, while running the G5 with another interface. Unfortunately, most users don't have the luxury to really do that and I would rather see working drivers myself.

In any case, I hope someone reads this and can offer some kind of help.

thanks

konrad



__________________
G5 1.8X2/3gigRAM/Mbox/7.4 (retired)
MBP C2D 2.4/4GigRAM/Mbox/8.0.1
iMac i7 3.4/16GigRAM/10.0.1
Reply With Quote
  #19  
Old 03-10-2004, 02:25 PM
orage orage is offline
Member
 
Join Date: May 2002
Location: San Diego
Posts: 671
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

I've been unable to use Live in conjunction with Core Audio and my MBox. Nice little kernel panic hits my Tibook after a minute or so...

Routing through Rewire works though....anyone else having problems with Live and Core Audio??
__________________
Paul Peterson
Sound Director
The Old Globe
San Diego, CA
Reply With Quote
  #20  
Old 03-10-2004, 03:20 PM
T.. T.. is offline
Member
 
Join Date: Mar 2004
Posts: 13
Default Re: DIGI: PLEASE FIX COREAUDIO DRIVER + PEAK!

I am also having problems with the core audio card and my DIGI001. I'm having problems with Peak, Garageband and Sountrack. I'm pretty sure that if in the audioMIDI utilities my card read 8ch -16bit it'd be fine, but my DIGI reads 2ch - 32bit: this sountrack does'nt understand.
Any fixes on the DIGi core audio driver would be much appreciated. It would save having to buy a whole new soundcard.
Thanks
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
digi CoreAudio driver still supports 8 i/o only. Why? Tobias Eichelberg Pro Tools TDM Systems (Mac) 2 01-03-2009 02:03 PM
Uninstall Digi CoreAudio driver? rockridge98 Pro Tools TDM Systems (Mac) 5 12-07-2006 09:40 PM
Digi CoreAudio driver for MacBook Dany 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 1 06-02-2006 09:10 PM
Digi: What Benifit's are to Coreaudio Driver 6.7 ? SoundEng1 Pro Tools TDM Systems (Mac) 1 11-15-2004 07:59 PM
Digi: CoreAudio Driver loud pop Mauro371 Pro Tools TDM Systems (Mac) 2 05-01-2003 09:18 AM


All times are GMT -7. The time now is 09:02 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com