Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac)

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 04-10-2021, 09:55 AM
sleeplessoasis sleeplessoasis is offline
Member
 
Join Date: Jul 2009
Posts: 15
Default New Pro-tools setup advice needed!

Hi All,
Thanks very much in advance to anyone who attempts to help me by replying with advice, much appreciated.

So the situation is this... my Dad and I have a Pro-tools home studio setup that's essentially 10 years old. Essentially the studio is these things...
* iMac - 21.5 inch late 2009 / 3.06 Intel Core 2 Duo / 8GB RAM / OS Mavericks
* Pro-tools LE 8
* Digidesign 003 Factory

We've been using it like this for over 10 years - we just mess around, nothing serious. We love it, it generally speaking still works fine, but we are well aware that it is becoming very outdated and we also can't risk updating the iMac OS anymore either in case PT LE 8 isn't supported! So we just need to update the entire setup, but would like to do it cost effectively.

So, with that in mind we were thinking a new up to date iMac (or Mac Mini perhaps instead) and new Pro-tools software are the initial things we need. So the 3 questions are...

1. Do we need to buy Pro-tools Perpetual (£500 approx) to put on the new iMac or is there a more affordable "upgrade" option that enable us to go from PT LE 8 to the latest version (PT 2020 I'm guessing...)?

2. Assuming we buy a new iMac with Thunderbolt 3 (USB-C) ports, can I just buy a USB-C to Firewire adaptor and carry on using the Digidesign 003 Factory mixing desk? Will it work with the latest version of Pro-tools? We love using it and don't want to have to invest in a new desk if we don't have to!

3. Will our older PT LE 8 projects all open up on the new version of Pro-tools ok? Obviously we don't want 10 years worth of projects not accessible... We have one 3rd party plug-in, which is EZ Drummer, it's used on most projects. From some quick googling and other forum posts, I've discovered our EZ Drummer plug in is "RTAS"? And that newer plugins for Pro-tools need to be "AAX"? I've no idea what this means, but essentially just need to know can this issue be overcome? Will we need to buy EZ Drummer again?

Open to all thoughts and advice!

Kind regards,
Phil

DISCLAIMER - I'm really really really not a very technical person, so it would be greatly appreciated if answers could be kept extremely basic! If you're replying and thinking you may have gotten too technical for me, you probably have...! lol
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Advice needed to upgrade older setup. needtopractice 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 12 08-21-2011 06:05 PM
Advice needed on HD3 rig setup audiogeekzine Pro Tools TDM Systems (Mac) 25 10-13-2009 08:28 PM
Advice needed for a new music setup with HD3 lionel payet Pro Tools TDM Systems (Mac) 4 05-23-2005 04:13 AM
Studio Setup Advice Needed cc1 Pro Tools TDM Systems (Mac) 3 11-04-2004 07:37 PM
Help...Advice needed re ATTO Setup tomhartman Pro Tools TDM Systems (Mac) 2 04-22-2001 12:08 AM


All times are GMT -7. The time now is 01:23 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com