Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools 2018

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-08-2018, 03:49 PM
aidyhall aidyhall is offline
Member
 
Join Date: Sep 2008
Location: London
Posts: 37
Default Offline bounce timing issues with some plugins and parallel processing busses

I have upgraded to PT 2018.1, and it is great, but there seems to be an offline bounce bug, with certain plugins. I was trying to print a drum stem, which sounds totally fine in real time, and a real-time bounce, either printing to a track or using the bounce feature, is totally fine. But if you try and do it offline, then some tracks get delayed weirdly. Everything is fine, until I try and put UAD on, or Sound Radix Drum Leveller, then it all goes badly wrong. Haven't been able to chase down exactly what the issue is, but either plugin throws out the delay comp. All other plugins seem to work fine at this point. Now, I am using a drum parallel subgroup on sends from some drum mic's, and there is a drum reverb as well, so it could be some combination of UAD/Sound Radix and buss parallels that ProTools is struggling with. The kicker is that UAD or Drum Leveller on other audio tracks in the mix like bass/guitars/perc that go straight to the mix buss all sound fine and bounce correctly in time, so it's some combination of subgroup bussing and parallels with those plugins.

I should mention that these are older PT12 sessions that I'm opening up to do stem bounces from. Don't know if the behaviour is the same with a fresh session. I will need to investigate more when I'm not trying to bounce stems for a client! If anybody else has had timing issues with offline bounces and has any idea what the problem might be, I'd love to hear about it!

Last edited by aidyhall; 02-08-2018 at 03:59 PM.
Reply With Quote
  #2  
Old 02-09-2018, 09:13 AM
john1192 john1192 is offline
Member
 
Join Date: Nov 2001
Location: Woodland Hills
Posts: 5,780
Default Re: Offline bounce timing issues with some plugins and parallel processing busses

Quote:
Originally Posted by aidyhall View Post
I have upgraded to PT 2018.1, and it is great, but there seems to be an offline bounce bug, with certain plugins. I was trying to print a drum stem, which sounds totally fine in real time, and a real-time bounce, either printing to a track or using the bounce feature, is totally fine. But if you try and do it offline, then some tracks get delayed weirdly. Everything is fine, until I try and put UAD on, or Sound Radix Drum Leveller, then it all goes badly wrong. Haven't been able to chase down exactly what the issue is, but either plugin throws out the delay comp. All other plugins seem to work fine at this point. Now, I am using a drum parallel subgroup on sends from some drum mic's, and there is a drum reverb as well, so it could be some combination of UAD/Sound Radix and buss parallels that ProTools is struggling with. The kicker is that UAD or Drum Leveller on other audio tracks in the mix like bass/guitars/perc that go straight to the mix buss all sound fine and bounce correctly in time, so it's some combination of subgroup bussing and parallels with those plugins.

I should mention that these are older PT12 sessions that I'm opening up to do stem bounces from. Don't know if the behaviour is the same with a fresh session. I will need to investigate more when I'm not trying to bounce stems for a client! If anybody else has had timing issues with offline bounces and has any idea what the problem might be, I'd love to hear about it!
good info .. but can you please tell us what MacOS or PC version you are using ??? as much info as you can tell us !!!
__________________
Macmini M1 8/512 -OS 12.3.1 and PT2022.4
Logic Pro X 10.7.4
RME BabyFace Pro

Macbook Pro july 2014 2.5ghz 16gb ram 512gb SSD - OS11.6.5 - PT 2021.3
Logic Pro X 10.7.4
RME BabyFace Pro
Reply With Quote
  #3  
Old 02-09-2018, 02:27 PM
aidyhall aidyhall is offline
Member
 
Join Date: Sep 2008
Location: London
Posts: 37
Default Re: Offline bounce timing issues with some plugins and parallel processing busses

Hi, yes, not sure why my signature is not showing, the box is ticked in my preferences. Anyway, system is as follows :

Intel Mac Pro 5,1 12-core 2.66Ghz, 48GB RAM, OS-X 10.13.2
ProTools HDX 2018.1
Avid HD16 i/o, Blue 96i/o
UAD Octo PCIe, UAD Quad Firewire Satellite
__________________
Mac Pro 2019 7,1 12-core 3.3Ghz, 96GB RAM, OS-X Big Sur 11.6.2
ProTools HDX Ultimate 2022.9
Avid HD16 i/o, Digidesign Blue 96i/o
UAD Octo PCIe, UAD Octo Thunderbolt 3 Satellite

www.adrian-hall.com
Reply With Quote
  #4  
Old 02-09-2018, 04:34 PM
TNM TNM is offline
Member
 
Join Date: Dec 2001
Location: Melbourne, Australia
Posts: 1,528
Default Re: Offline bounce timing issues with some plugins and parallel processing busses

this really does sound like an ADC issue, as you are only having problems with offline bouncing when the audio is using plugins that have latency. You have a firewire satellite in your system, which has the most latency of all UAD accelerators, and UAD once explained to me that all the devices on the system will only operate as fast as the one with the slowest latency. This is why I ditched my firewire one myself.

I'm going to do some tests for you to see if i can duplicate it. I have drum leveller as well, and around 75 uad plugins.

Just to be thorough, can you tell me which UAD plugins you really notice the issue with? I'll use the same ones. I have a demo period i can re activate in case i don't have that plugin.

Edit, i have just been thinking about it.. are you sure you are not using sidechain with *any* of these plugins? pro tools does not compensate for delay on sidechains, which is a big bugbear for many of us.

I have done some adc tests with pro tools on auxes/sends, and it passed, so perhaps something broke in the newest version.
Now that i re read your post, you are using these plugins on sends to create your own parallel effects mix?

The other thing that has me confused is that you say it works in a realtime bounce or when you are playing back the project. This instantly makes my brain want to think that it's an offline processing bug in pro tools itself, but I just want to be thorough and try reproduce the exact same problem here.

It could also be, that the effects themselves have a bug when being processed offline.
Have you tried other effects with latency in their place.. NOT from uad or sound radix? You should try all these things just as process of elimination.

for example, say you use another latent plugin in the same spot, and it bounces perfectly.. your course of action would then be to actually let uad know about it before avid, as it would likely be their fault.

I guess my mixing is simpler and why i haven't had the issue. I only use delays or verbs on aux sends.. that's it. And maybe about 8 sub groups per project with their own effects, usually all UAD, but haven't had an issue. I freeze as i go along to save resources and i always bounce offline.
__________________
-Lenovo Legion 7i, Intel 11800H, 64GB ram, Nvidia 3070, Win 11, ProTools 2022/Nuendo 12
Reply With Quote
  #5  
Old 02-09-2018, 06:26 PM
aidyhall aidyhall is offline
Member
 
Join Date: Sep 2008
Location: London
Posts: 37
Default Re: Offline bounce timing issues with some plugins and parallel processing busses

Yes, I do need to do more investigation as to other possible plugins that may cause the problem, but at the moment, it seems to be only the UAD and Sound Radix plugins that are causing the issue, when in combination with the parallel processing on the drum buss. Both the UAD and Sound Radix plugins seem to be fine on single channels that are either just subgrouped once, or routed straight into the mix buss. I have other plugins on the drums including Phoenix, SSL Native, MDW, Waves, bx console, Massey, Softube, and they all seem to be fine.

The drum buss setup is not that complicated, and I have not had any problems in the past with ADC. The individual kick and snare mic's are routed to kick and snare busses. The kick and snare buss feed the main drum subgroup, and also a parallel chain via an aux. Both the main drum buss and the parallel drum buss go straight to the mix buss.

Once again, I must state that the ADC issue only happens with an offline bounce. While mixing, and either bouncing to disk in real time or printing the mix to a new audio track, everything is perfect, so all plugins would appear to be correctly reporting the latency. I haven't encountered any offline bounce issues in the past when creating stems for clients, it is definitely a recent issue. At first, I thought it was the old "offline bounce with HEAT on" issue, that I have had previously which Avid fixed with an update (I can't remember the version numbers, it was about a year ago). But I have globally disabled HEAT, as you had to do when the old bug happened, and the error is still there.

I will do some more tests on Monday, with a fresh session, and see if I can recreate the bug. It may be because I am opening old sessions (only from PT12, so not that old!). In the meantime, if anybody else is having issues with using parallel processing and offline bounces, please let me know!
__________________
Mac Pro 2019 7,1 12-core 3.3Ghz, 96GB RAM, OS-X Big Sur 11.6.2
ProTools HDX Ultimate 2022.9
Avid HD16 i/o, Digidesign Blue 96i/o
UAD Octo PCIe, UAD Octo Thunderbolt 3 Satellite

www.adrian-hall.com
Reply With Quote
  #6  
Old 02-09-2018, 06:35 PM
TNM TNM is offline
Member
 
Join Date: Dec 2001
Location: Melbourne, Australia
Posts: 1,528
Default Re: Offline bounce timing issues with some plugins and parallel processing busses

sounds like the plugins themselves have an issue with the offline bounce, if other plugins work fine. My guess is that if it was a PT offline processing issue generally with plugins that need ADC, it would happen on all of them.

i'll try reproduce.. but can you please just give me an example of a couple of the uad plugins causing it?
__________________
-Lenovo Legion 7i, Intel 11800H, 64GB ram, Nvidia 3070, Win 11, ProTools 2022/Nuendo 12
Reply With Quote
  #7  
Old 02-09-2018, 06:47 PM
aidyhall aidyhall is offline
Member
 
Join Date: Sep 2008
Location: London
Posts: 37
Default Re: Offline bounce timing issues with some plugins and parallel processing busses

Yep, Neve 1073 (the new one) and FATSO are definitely on the drums, and causing issues.

I also had Ocean Way Room and Zener Limiter on the room mic's, and the first thing that I did was disable (not just bypass) those plugins as I know they have a high latency, but that did not change the issue.

Crazy, because they sound absolutely perfect when monitoring, or doing a real time bounce.
__________________
Mac Pro 2019 7,1 12-core 3.3Ghz, 96GB RAM, OS-X Big Sur 11.6.2
ProTools HDX Ultimate 2022.9
Avid HD16 i/o, Digidesign Blue 96i/o
UAD Octo PCIe, UAD Octo Thunderbolt 3 Satellite

www.adrian-hall.com
Reply With Quote
  #8  
Old 02-10-2018, 02:27 AM
TNM TNM is offline
Member
 
Join Date: Dec 2001
Location: Melbourne, Australia
Posts: 1,528
Default Re: Offline bounce timing issues with some plugins and parallel processing busses

bypassing doesn't make a difference with most aax plugins as they report the same latency bypassed/adc remains active.

I have the fatso, so will check with that
__________________
-Lenovo Legion 7i, Intel 11800H, 64GB ram, Nvidia 3070, Win 11, ProTools 2022/Nuendo 12
Reply With Quote
  #9  
Old 02-10-2018, 08:14 AM
Sardi Sardi is offline
Member
 
Join Date: Aug 2002
Location: Perth
Posts: 2,809
Default Re: Offline bounce timing issues with some plugins and parallel processing busses

Quote:
Originally Posted by TNM View Post
bypassing doesn't make a difference with most aax plugins as they report the same latency bypassed/adc remains active.

He didn’t bypass, he disabled the inserts.

Disabling them removes any delay incurred.


Sent from my iPhone using Tapatalk
Reply With Quote
  #10  
Old 02-10-2018, 11:28 AM
TNM TNM is offline
Member
 
Join Date: Dec 2001
Location: Melbourne, Australia
Posts: 1,528
Default Re: Offline bounce timing issues with some plugins and parallel processing busses

Quote:
Originally Posted by Sardi View Post
He didn’t bypass, he disabled the inserts.

Disabling them removes any delay incurred.


Sent from my iPhone using Tapatalk
you mean disabling a track completely?

Or is there another way to disable inserts? The only way i know is to command click.. i would love to know if there is something else i missed, please kind sir :)


The two ways i know are to disable a track completely which then of course releases all resources and latency, or to command click and they change their look to bypassed in the mixer (or right click and bypass them from the menu).

So which way am i missing?

One thing that has always bugged me with aax, is that it's 50/50 on which plugins still have latency when bypassed or not. Some stuff actually goes out of phase with bypassed plugins as they are not reporting their state correctly (it only happens with specific brands).

so yeah, a way to disable them so they go back to zero latency , but not lose anything else in the signal path, would be magic.. please let me know what I am missing. if it is too off topic for this, please if you wouldn't mind a quick pm.
__________________
-Lenovo Legion 7i, Intel 11800H, 64GB ram, Nvidia 3070, Win 11, ProTools 2022/Nuendo 12
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Offline bounce to disk issues noiseboyuk Pro Tools 12 9 01-13-2016 06:47 PM
Realtime Bounce Timing Issues redhotnate Pro Tools 11 0 04-19-2015 08:29 PM
Offline bounce crash, probably Waves-related, and offline bounce not 100% correct Skwaidu Pro Tools HDX & HD Native Systems (Mac) 3 03-23-2015 04:55 PM
Offline Bounce Pro Tools 11 delay issues dizzydiscs Pro Tools 11 4 11-09-2013 06:48 AM
Parallel processing, please help Finnish 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 7 01-05-2006 08:14 PM


All times are GMT -7. The time now is 02:59 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com