Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > General Discussion & Off Topic > General Discussion

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old Today, 09:02 AM
connorhawke connorhawke is offline
Member
 
Join Date: Apr 2013
Location: New York, NY
Posts: 57
Default Re: Feature request section here vs AVID Link

Quote:
Originally Posted by ChrisBové View Post
Hi Connorhawke, and thanks for asking.

I know that most people use Link for updating and installing, but I personally have been doing so from the Download Center for years and years now. No shade to Link, it's just my muscle memory.

Try downloading and installing from there. Go to your MyAvid account, login, and find the My Products page. On it is the link to the Download Center, followed by the link to Avid Link.

If that doesn't work, and you still see issues, hit me with a quick email at chris.bove@avid.com and I'll get a support case created for you. There might be something on your system - like a remnant of a crash or a cache issue - that we could remote-in and clean up for you.

Thanks!
Hi Chris, as noted above, I already tried the downloadable installer:

Quote:
If I instead try to upgrade via the downloadable installer (AvidLink_22.7.1_win), a seemingly similar phenomenon occurs. When I double-tap on AvidLinkSetup.exe, it hangs for a bit (i.e. cursor has the loading circle icon next to it), goes to the User Account Control dialogue, which I press Yes on, then hangs some more, before the cursor returns to normal, and apparently nothing has happened. Avid Link is still on 2022.7.
Before I consider a remote-in, (1) would it be worth it to uninstall Avid Link entirely and then reinstall from scratch, or (2) are there specific instructions I can follow to try a cleanup myself? (I think either of these would be faster than waiting for a remote-in if it happens again.) Thanks.

Last edited by connorhawke; Today at 04:05 PM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Feature Request for Avid Dock push encoders Unoute Avid S1, S3, Dock and Control App 3 07-08-2022 07:40 AM
The Avid link Lounges feature request system Skwaidu Pro Tools 2020 0 06-10-2020 11:27 AM
Feature request: Video slave w/o Avid hardware Mark Ziebarth Post - Surround - Video 13 02-11-2020 04:51 AM
Avid S3 flip faders - very simple feature request alexthemusicbloke Avid S1, S3, Dock and Control App 2 07-29-2019 07:40 AM
Avid Link - Pro Tools Feature Requests - Lounge simonchase Pro Tools 2018 4 01-18-2019 04:13 AM


All times are GMT -7. The time now is 06:29 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com