Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > ICON & C|24

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-09-2012, 01:38 AM
Fix Fix is offline
Member
 
Join Date: Sep 2008
Location: Colorado
Posts: 78
Unhappy Control 24 dead fader bank

Ok, so I have been running my Control 24 heavy for about 6 years now and it's run perfectly until the last week or so. I was in the middle of a mix session with a client and all of the sudden the fader on channel 17 locked. It wouldn't move at all. I closed the session and shut down the system and now the entire section for fader bank 17-24 is completely dead. When I shut the power off fader 17 finally released.

I read up on as many posts on here as I could about possible solutions. I tried pulling the bottom of the console off to check for loose connections on the fader panel and PSU. I also checked and cleaned connections...to no avail. I might be looking at needing to replace that fader bank or have it repaired, so....

1. I was looking for any additional things to check or try...or,

2. If I do need to have it repaired, I was hoping to get some input from someone else who has dealt with this. It is very important that I don't have this down for too long as even with the faders not working it's my primary source for monitoring (I know, I know, it's not the best monitoring source...but it's worked well for me for years!) Luckily, Avid's website lists a certified repair location not too far from me where I can drive it there myself.

3. Lastly, in the meantime will it be bad for me to run the Control 24 as a control source with the dead faders? For the last week I've just been using the monitoring section and I disabled ProTools from seeing it in the preferences so I wouldn't damage it further.

Any advice at all would be appreciated! Thanks in advance.
Reply With Quote
  #2  
Old 10-12-2012, 08:11 PM
phatbeatstudio phatbeatstudio is offline
Member
 
Join Date: May 2011
Location: canada
Posts: 566
Default Re: Control 24 dead fader bank

That actually happened to me minus the whole bank on the same fader.
So I opened up the Control24 and removed the fader checked to see what was happening then plugged it back in . IT WORKED .
BUT
I put it all back together and it didnt . then it did then it didnt .
So it was obviously a intermittent problem. It actually always worked for everything other that moving faders. So
I took it apart again because I thought if it didnt work I would swap it with 24 .
But then 24 didnt work ? so I through great its not the fader but something else in the C24. So
I put everything back agian then it worked. Then it didnt .
Then I finally decided to order some new faders !!!! good thing they still made or stocked them.

While waiting for my new faders I swapped the wonky fader into the first one it worked in the first slot and the first one worked in the problem slot.

I didn't give it much hope I fully expected it to not work again when I turned it on the next day. WELL IT DID

Long story short it still works almost 1 year later and I have 2 brand new faders I have never even installed!!!!!
Total piss off at first but hey at least it works even if I did waist $250 for nothing . The saying it just needs some TLC was true for me .
I think it just wanted to have its underbelly tickled .
Now I feel cheap and used and I want a shower
Reply With Quote
  #3  
Old 10-13-2012, 10:08 PM
Fix Fix is offline
Member
 
Join Date: Sep 2008
Location: Colorado
Posts: 78
Default Re: Control 24 dead fader bank

Thanks for the reply PhatBeats. It definitely sounds like you had something similar...but a little different happen. I'm jealous that yours seemed to work itself out though! I'm pretty sure that I have a completely dead bank. I'm not seeing anything with faders working and going out intermittently. 17-24 are just completely dead now. I actually just got a quote from the Avid certified repair center here and it was pretty reasonable (like between $200-500.) Looks like once I wrap up some important projects...I'll probably just let them fix it. I'm at the point where I think that'll probably just be best. The major downside is I'll need to find a different monitoring solution for a week or so.

In the meantime, does any one have any advice as to whether it is problematic to run it even with the dead bank? It's driving me nuts not to have my console.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sluggish Fader Bank tekis ProControl, Control|24, Command|8 0 11-21-2012 08:08 AM
Max Custom Fader Bank JKD99 ICON & C|24 6 11-23-2009 09:27 AM
> Fader Bank switching Howardk VENUE Live Sound Systems 12 09-22-2009 04:27 PM
Dead Fader ---- On my Control 23 Lizardpoint ICON & C|24 5 02-20-2006 03:58 PM
PRO CONTROL FADER DEAD sound dog General Discussion 1 08-07-2000 03:41 PM


All times are GMT -7. The time now is 01:30 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com