Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  ē  Community Terms of Use  ē  Help Us Help You

Knowledge Base Search  ē  Community Search  ē  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire & USB Audio Interfaces (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-01-2022, 05:33 PM
madlove madlove is offline
Member
 
Join Date: Dec 2005
Posts: 20
Default M-Audio Fast Track Ultra Troubleshoot

Hi,
I’ve been running PT MP9 with the Fast Track Ultra for years until my laptop died.
I now have a late 2013 iMac that I was able to load PT MP9 on, running Mountain Lion 10.8.5. I downloaded the maudio drivers from the CD. but PT can’t find the maudio hardware when it’s opening. Does anyone have any ideas what I can do? Could it be I need to download new drivers? I can’t find any on the maudio site that work and I’m at a loss. Any suggestions or ideas would be great. Thanks Chris

Last edited by madlove; 08-01-2022 at 05:33 PM. Reason: Spelling
Reply With Quote
  #2  
Old 08-01-2022, 06:23 PM
madlove madlove is offline
Member
 
Join Date: Dec 2005
Posts: 20
Default M-Audio Fast Track Ultra Troubleshoot

Hi,
Iíve been running PT MP9 with the Fast Track Ultra for years until my laptop died.
I now have a late 2013 iMac that I was able to load PT MP9 on, running Mountain Lion 10.8.5. I downloaded the maudio drivers from the CD. but PT canít find the maudio hardware when itís opening. Does anyone have any ideas what I can do? Could it be I need to download new drivers? I canít find any on the maudio site that work and Iím at a loss. The Fast Track Ultra control panel says the ďpanel could not establish contact with the driver.Ē Any suggestions or ideas would be great. Thanks Chris
Reply With Quote
  #3  
Old 08-01-2022, 06:32 PM
Darryl Ramm Darryl Ramm is online now
Member
 
Join Date: Nov 2010
Location: USA
Posts: 16,711
Default Re: M-Audio Fast Track Ultra Troubleshoot

What macOS versions does the driver you are installing claim to support?

Does the M-Audio device show up in Audio/MIDI settings audio devices?

Avid info for old M-Audio drivers is supposed to be here: https://avid.secure.force.com/pkb/ar...t-Track-Family

But that's all screwed up and the link for the Fast Track Ultra is missing.

Avid dumped M-Audio, it was a business failure and support disaster for them. It's now a seperate company making low end stuff. I don't think the new company took over the Ultra product line so they are not responsible for updates.

Maybe somebody from Avid can at least fix the broken link issue.

The best advice you are going to get is to throw that interface out and buy something from a vendor who provides good product support. Focusrite being the canonical low end interface vendor many of us recommend (Focusrite also make lots of higher end interfaces) but you are going to need to make sure any interface you buy now has drivers that are supported on Mountain Lion. There are no end of nice interfaces spanning a large feature/price range, from vendors such as UAD, RME, Focusrite, Presonus, Apogee, Motu, ... and a bunch of other vendors I'd not touch with a ten foot pole.
Reply With Quote
  #4  
Old 08-01-2022, 06:35 PM
Darryl Ramm Darryl Ramm is online now
Member
 
Join Date: Nov 2010
Location: USA
Posts: 16,711
Default Re: M-Audio Fast Track Ultra Troubleshoot

A duplicate of https://duc.avid.com/showthread.php?t=421141

Could you please follow the DUC guidelines and not cross post stuff to multiple threads, you will end up with two separate conversations going with folks, largely repeating themselves and wasting other people's time when you do this.
Reply With Quote
  #5  
Old 08-01-2022, 07:09 PM
madlove madlove is offline
Member
 
Join Date: Dec 2005
Posts: 20
Default Re: M-Audio Fast Track Ultra Troubleshoot

Sorry Darryl, I wasnít sure which forum was the best choice.
Reply With Quote
  #6  
Old 08-01-2022, 07:15 PM
madlove madlove is offline
Member
 
Join Date: Dec 2005
Posts: 20
Default Re: M-Audio Fast Track Ultra Troubleshoot

Thanks so much for the reply. I believe the driver should support 10.3 and above but Iím not sure. I didnít check the audio/midi but will try to.
Yeah, when I bought PTMP9 maudio seemed like the catís pajamas but now itís something else entirely. Iíll check out your vendor suggestions. C
Reply With Quote
  #7  
Old 08-01-2022, 07:40 PM
Darryl Ramm Darryl Ramm is online now
Member
 
Join Date: Nov 2010
Location: USA
Posts: 16,711
Default Re: M-Audio Fast Track Ultra Troubleshoot

Quote:
Originally Posted by madlove View Post
Sorry Darryl, I wasnít sure which forum was the best choice.
Yep, it's often an unclear choice, but it really does not matter, a threat typically gets seen and replied to. And its' it's really an issue a mod will often move it.
Reply With Quote
  #8  
Old 09-21-2022, 01:47 AM
Pibu Pibu is offline
Member
 
Join Date: Sep 2022
Location: Italy
Posts: 2
Default Re: M-Audio Fast Track Ultra Troubleshoot

Dear all, i got a an okd fast track ultra and ultra 8r but they donít work with my mac with osx11 big sur. Please tell me thereís a way to make it works! Have a nice day!
Reply With Quote
  #9  
Old 09-21-2022, 04:53 AM
JoelG's Avatar
JoelG JoelG is offline
Moderator
 
Join Date: Mar 2010
Location: Canada
Posts: 2,059
Default Re: M-Audio Fast Track Ultra Troubleshoot

The last Mac OS that had drivers for those was 10.10. Someone may have a workaround to get them working, but not officially supported.

https://avid.secure.force.com/pkb/ar...tra-8R-Drivers

"Qualified with Mac OS X 10.8.5, 10.9.5, 10.10, 10.10.1
Note that Mac OS X 10.11 El Capitan (or later) is not compatible and will not be qualified"

If you were using Windows, the old Win 8 drivers would likely work on Win 10/11.

Joel
__________________
Jam Space:
HP Elite 6300 / Core i5 3770 / 24GB RAM / Win 10 Pro
Pro Tools 2021 HD / Focusrite 18i20 + M-Audio ProFire 2626

Home:
Asus B450 Pro4 / Ryzen 5 2600 / 32GB RAM / Win 11 Pro
Pro Tools 2021 HD / Focusrite 18i20 + M-Audio ProFire 2626

Rig:
Eleven Rack / ART SLA1 / Two 2x10 Passive Monitors / FCB1010 w/ EurekaPROM
Reply With Quote
  #10  
Old 09-21-2022, 11:26 PM
Pibu Pibu is offline
Member
 
Join Date: Sep 2022
Location: Italy
Posts: 2
Default Re: M-Audio Fast Track Ultra Troubleshoot

Many thanks, do you think that i can find the way searching in these threads?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PT 10.3.10 with M-Audio Fast Track Ultra 8R interface jglunt2112 Pro Tools 10 4 06-14-2015 06:59 PM
M-Audio Fast Track Ultra Help! Szenasi FireWire & USB Audio Interfaces (Win) 2 05-26-2013 11:55 AM
5.1 with M-Audio Fast Track Ultra 8R Elby Post - Surround - Video 3 05-25-2012 08:43 AM
PT Can't Find M-Audio Fast Track Ultra. 2000ContourSVT Pro Tools M-Powered (Mac) 2 03-10-2009 08:44 AM


All times are GMT -7. The time now is 03:10 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com