Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools 12

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 07-05-2016, 12:54 PM
zillmer zillmer is offline
Member
 
Join Date: Jan 2010
Posts: 6
Default Strange and annoying tab key behaviour PT12 Windows

I have a strange issue with PT12 and Windows 10, although the behaviour also occurred on windows 8/8.1

When running PT with the focus on the PT window, if I press the Tab key it brings up the application switching that would normally be accessed by pressing Alt-Tab. The difference is that unlike alt-tab the open application windows remain on screen and can be selected using a further press of the tab key.

Pressing enter then switches to the highlighted application.

As a result of this behaviour I can't use tab to transient at all.

I have reinstalled PT, trashed preferences, changed keyboard, tried both a wired and wireless keyboard, all to no avail.

Has anyone experienced a similar issue or have any suggestions on how to fix this?
Reply With Quote
  #2  
Old 07-05-2016, 01:23 PM
JoelG's Avatar
JoelG JoelG is offline
Moderator
 
Join Date: Mar 2010
Location: Canada
Posts: 2,115
Default Re: Strange and annoying tab key behaviour PT12 Windows

It wouldnt be "sticky keys" would it? https://en.wikipedia.org/wiki/Sticky_keys

I've accidently turned it on before, its a pain!

Joel
__________________
Jam Space:
HP Elite 6300 / Core i5 3770 / 24GB RAM / Win 11 Pro
Pro Tools HD / Focusrite 18i20 + M-Audio ProFire 2626

Home:
Asus B450 Pro4 / Ryzen 5 2600 / 32GB RAM / Win 11 Pro
Pro Tools HD / Focusrite 18i20 + M-Audio ProFire 2626

Rig:
Eleven Rack / ART SLA1 / Two 2x10 Passive Monitors / FCB1010 w/ EurekaPROM
Reply With Quote
  #3  
Old 07-05-2016, 01:38 PM
zillmer zillmer is offline
Member
 
Join Date: Jan 2010
Posts: 6
Default Re: Strange and annoying tab key behaviour PT12 Windows

No, I've checked sticky keys and it's not enabled.

I have however managed to narrow down the issue, so would appreciate if others could try this.

If I start PT and load a session and keep focused on the PT window everything works as per normal.

If I then switch away from Pro Tools using Alt+Tab to another program, and then Alt+Tab back to PT, the problem occurs.

What I notice is that on Alt+Tabbing back to Pro Tools the Menu Bar items are Underlined, but no Menu Bar option is highlighted.

In this state Tab will exhibit the behaviour described in the OP.

To get around this I have to press Alt twice more. The first time causes the File menu item to be highlighted in blue, and the second time returns PT back to a normal state.
Reply With Quote
  #4  
Old 07-06-2016, 06:00 AM
yoerik roevens yoerik roevens is offline
Member
 
Join Date: Nov 2010
Location: Lochristi
Posts: 107
Default Re: Strange and annoying tab key behaviour PT12 Windows

Yup,

I have exactly the same thing. Extremely annoying. It affects lots of shortcuts, not just tab to transients. As said, the only way to fix it I could find is double-tapping ALT.
Reply With Quote
  #5  
Old 07-12-2016, 02:56 PM
DAWgEAR's Avatar
DAWgEAR DAWgEAR is offline
Member
 
Join Date: Oct 2012
Location: California, USA
Posts: 347
Default Re: Strange and annoying tab key behaviour PT12 Windows

Thanks, zillmer!

I was experiencing the same thing, but backwards: I use a DNA Hotkey Matrix and several of the commands involve using the Alt key to access the menus for shortcuts not already provided by Pro Tools (e.g. Alt+V+o+t to assign a key command to toggle track list). I was unable to get the Alt key to access the menus from the keyboard, independent of the Hotkey Matrix. Alt+Tab and pressing the Alt key twice seems to toggle this behavior. Inconvenient, but at least I now know how it works.

Thanks Joel G!

Unrelated to Pro Tools, my non-DAW PC has been beeping at me for weeks. The sticky keys tip was the solution. I must have inadvertently turned it on at some point. Stumbling upon your post while searching for a solution to a Pro Tools issue was a serendipitous event!
__________________
Pro Tools HD Native 2023.12 | HD Omni | iMac Pro 10-Core 3.0 GHZ - 64 GB - 2 TB - Vega 56 | Ventura 13.5 | Sonnet Echo Express SE II for PT HD Native PCIe and UAD 2 Quad PCIe card | Avid Dock and S1
Reply With Quote
  #6  
Old 07-14-2016, 01:57 PM
JoelG's Avatar
JoelG JoelG is offline
Moderator
 
Join Date: Mar 2010
Location: Canada
Posts: 2,115
Default Re: Strange and annoying tab key behaviour PT12 Windows

Well, glad it helped someone out, even if it was completely off topic

Joel
__________________
Jam Space:
HP Elite 6300 / Core i5 3770 / 24GB RAM / Win 11 Pro
Pro Tools HD / Focusrite 18i20 + M-Audio ProFire 2626

Home:
Asus B450 Pro4 / Ryzen 5 2600 / 32GB RAM / Win 11 Pro
Pro Tools HD / Focusrite 18i20 + M-Audio ProFire 2626

Rig:
Eleven Rack / ART SLA1 / Two 2x10 Passive Monitors / FCB1010 w/ EurekaPROM
Reply With Quote
  #7  
Old 07-19-2016, 08:47 PM
VisionsMusicGroup VisionsMusicGroup is offline
Member
 
Join Date: Jun 2013
Location: Phoenix, AZ
Posts: 27
Default Re: Strange and annoying tab key behaviour PT12 Windows

zillmer, are a god among men. Thank you for your "off topic" (cough) post. Because of this, you solved an issue I've had since PT 11.3, and some version thereafter that caused the Windows-Ding-of-Death whenever I foolishly minimized Pro Tools for a second.

I hadn't even considered it was an errant ALT key, but sure enough when I hold ALT-TAB long enough and PT pops up, I [now] clearly see the File underline as you described. Hitting ALT once more (for me) allows me to access PT again. THANK YOU.

I shouldn't even tell you how I had to get around this, with unsaved sessions... unplugging or turning off my audio interface so PT pops up asking me to save and quit :) quite embarrassing. But, no more.

Did I say thank you? Thank you.
Jc
__________________
iMac (Retina 5K, 27-inch, Late 2015)/32GB RAM/MacOS 12.6/PT2022.9 - Hardware: Mackie DL32R, MOTU Express 128, S3+Dock
Reply With Quote
  #8  
Old 07-20-2016, 07:30 AM
onosendai onosendai is offline
Member
 
Join Date: Oct 2009
Location: Denmark
Posts: 93
Default Re: Strange and annoying tab key behaviour PT12 Windows

I have just recently switched to using pro tools on a windows machine and I have the exact same behaviour and it's been drivning me absolutely nuts. I have disabled everything possible OS-wise and the only way to get out of it, is by double tapping "alt". I hoped it was a bug, because I simply can't comprehend how this can be part of a normal workflow. I use "alt" and "alt+tab" a lot.
There seems to be a lot conflicts with the pro tools hotkeys and windows. This is a non-issue in OSX and it seems windows is less flexible in terms disabling certain keys to alleviate these conflicts.

Maybe I'm just not getting it due to being a OSX-user for a decade. If anybody longterm PT-windows users have any workarounds do share.

It would make me very happy
__________________
i7 5820K, 32GB | Windows 10 Pro, PT 2021.10 Ultimate | RME FF802
Reply With Quote
  #9  
Old 07-26-2016, 09:16 AM
taylor4814 taylor4814 is offline
Member
 
Join Date: Jan 2002
Location: Fairfax, VA
Posts: 492
Default Re: Strange and annoying tab key behaviour PT12 Windows

So how are the Menu Bar (File, Edit, etc.) keyboard shortcuts supposed to work in PT 12? Are the menu names supposed to display the underline all the time?
As in: File Edit (etc...)
Reply With Quote
  #10  
Old 02-21-2017, 10:18 PM
tmc3p tmc3p is offline
Member
 
Join Date: Sep 2008
Posts: 10
Default Re: Strange and annoying tab key behaviour PT12 Windows

Anyone found a solution? i have the same problem, and it's no annoying!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Input Monitoring behaviour with MBox Pro in PT12 Houdimoudi Pro Tools 12 2 03-15-2016 06:33 AM
PT 10 Strange Behaviour martinaston Windows 0 12-09-2011 11:22 AM
Annoying playback behaviour m4tune Pro Tools TDM Systems (Mac) 2 06-30-2011 05:29 AM
"save as" and other dialogues - annoying behaviour fm_xtk 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 6 06-23-2010 12:49 PM
Strange behaviour eledu 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 11-12-2001 11:08 AM


All times are GMT -7. The time now is 03:30 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com