Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Pro Tools 2021

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-28-2021, 07:15 PM
massivekerry massivekerry is offline
Member
 
Join Date: Jul 2005
Location: Portland, OR
Posts: 238
Default PT 2021.10 Bug Thread

Maybe it's good if we have one thread about things that aren't quite working as expected? I have 2 small issues with the latest release, and neither really feel worth opening a Support ticket for, since they don't seem likely to be solved easily, and neither disturb my normal workflow.
__________________
Kerry Smith
http://apothekerry.com

12-core 3.46GHz Cheese Grater, 64GB RAM, HD | Native, HD I/O
Reply With Quote
  #2  
Old 10-28-2021, 07:19 PM
massivekerry massivekerry is offline
Member
 
Join Date: Jul 2005
Location: Portland, OR
Posts: 238
Default Re: PT 2021.10 Bug Thread

Bug 1: The "fixed" Bug noted in the 2021.10 release:

The visibility of the background pattern denoting black and white keys on MIDI and Instrument tracks when using the Dark theme has been improved (PT-276994)

This does seem better, but there is still a section of the bright and mid-tone Yellows, Greens and Blues that inverts the dark/light keys if you only have a selection of one MIDI/Instrument Track opened in the MIDI Editor window.

I applaud the changes made so far to the UI and Color Palettes with regard to customization. I have some visually impaired friends who will benefit from the Hi-Viz additions. But I still maintain that there should be separate color controls for the MIDI Editor Window, and that the behavior of these dark key/light key inconsistencies need to be hammered out completely.
__________________
Kerry Smith
http://apothekerry.com

12-core 3.46GHz Cheese Grater, 64GB RAM, HD | Native, HD I/O

Last edited by massivekerry; 10-28-2021 at 07:32 PM.
Reply With Quote
  #3  
Old 10-28-2021, 07:30 PM
massivekerry massivekerry is offline
Member
 
Join Date: Jul 2005
Location: Portland, OR
Posts: 238
Default Re: PT 2021.10 Bug Thread

Bug 2: Komplete Kontrol functionality for the original Mk1 S-series keyboards does not seem to work.

I have an original (Mk1) NI Komplete Kontrol S-61, and although I have added it as a device in the MIDI Controllers pane of the Peripherals Window, I don't have the added functionality that is indicated in the updated Reference Guide, the What's New document, or the video they released showing the functions.

I don't expect some of the things to work (like the mixer controls), as the original keyboards don't have all of the bells and whistles of the Mk2 and later models. But they does have a set of Transport controls that I would love to be able to use, as to keep my hands and arms at one level when I'm doing a bunch of MIDI recording. The keyboard has the latest firmware, the latest KK drivers are installed, and the Transport controls continue to work in both Logic and Cubase, as they always have.

If the Mk1 keyboards aren't supported, that should be documented clearly somewhere that is easily found. If they were just never tested, and this is an oversight, let it be known.
__________________
Kerry Smith
http://apothekerry.com

12-core 3.46GHz Cheese Grater, 64GB RAM, HD | Native, HD I/O
Reply With Quote
  #4  
Old 10-28-2021, 08:16 PM
Eric Lambert's Avatar
Eric Lambert Eric Lambert is offline
Member
 
Join Date: Dec 1969
Location: Los Angeles
Posts: 3,143
Default Re: PT 2021.10 Bug Thread

As an original S-88 controller owner I feel your pain. I've watched so many cool features in MkII, supported by DAWs and libraries and such, that I can't have. I'd settle for Play/Stop.
Reply With Quote
  #5  
Old 10-28-2021, 09:19 PM
bluemoa bluemoa is offline
Member
 
Join Date: Jan 2011
Location: Cali-forni-ca
Posts: 27
Default VCA Meters Misaligned in PT 2021.10 on Big Sur

https://duc.avid.com/showthread.php?t=417550
Reply With Quote
  #6  
Old 10-29-2021, 12:31 AM
Marsdy Marsdy is offline
Member
 
Join Date: Oct 2009
Location: England
Posts: 2,028
Default Re: PT 2021.10 Bug Thread

Quote:
Originally Posted by massivekerry View Post
Bug 1: The "fixed" Bug noted in the 2021.10 release:

The visibility of the background pattern denoting black and white keys on MIDI and Instrument tracks when using the Dark theme has been improved (PT-276994)

This does seem better, but there is still a section of the bright and mid-tone Yellows, Greens and Blues that inverts the dark/light keys if you only have a selection of one MIDI/Instrument Track opened in the MIDI Editor window.

I applaud the changes made so far to the UI and Color Palettes with regard to customization. I have some visually impaired friends who will benefit from the Hi-Viz additions. But I still maintain that there should be separate color controls for the MIDI Editor Window, and that the behavior of these dark key/light key inconsistencies need to be hammered out completely.
Definitely +1 for separate colour control in the MIDI Editor.
__________________
Dave Marsden
UK
Reply With Quote
  #7  
Old 10-29-2021, 04:38 AM
Mookuk Mookuk is offline
Member
 
Join Date: Dec 2016
Location: London
Posts: 9
Default Re: PT 2021.10 Bug Thread

Quote:
Originally Posted by massivekerry View Post
Bug 2: Komplete Kontrol functionality for the original Mk1 S-series keyboards does not seem to work.

I have an original (Mk1) NI Komplete Kontrol S-61, and although I have added it as a device in the MIDI Controllers pane of the Peripherals Window, I don't have the added functionality that is indicated in the updated Reference Guide, the What's New document, or the video they released showing the functions.

I don't expect some of the things to work (like the mixer controls), as the original keyboards don't have all of the bells and whistles of the Mk2 and later models. But they does have a set of Transport controls that I would love to be able to use, as to keep my hands and arms at one level when I'm doing a bunch of MIDI recording. The keyboard has the latest firmware, the latest KK drivers are installed, and the Transport controls continue to work in both Logic and Cubase, as they always have.

If the Mk1 keyboards aren't supported, that should be documented clearly somewhere that is easily found. If they were just never tested, and this is an oversight, let it be known.
I have exactly the same problem. It works with my M32 though. A video from Avid on YouTube says that it works with any Komplete Kontrol keyboard (not should work) so I find this seriously misleading.
Reply With Quote
  #8  
Old 10-29-2021, 06:09 AM
Mookuk Mookuk is offline
Member
 
Join Date: Dec 2016
Location: London
Posts: 9
Default Re: PT 2021.10 Bug Thread

Quote:
Originally Posted by Eric Lambert View Post
As an original S-88 controller owner I feel your pain. I've watched so many cool features in MkII, supported by DAWs and libraries and such, that I can't have. I'd settle for Play/Stop.
I have an S61 and an M32. Works fine on the M32, not on the S61 though.

This reminds of when NI released Massive X to great fanfare. Trouble was that it didn't work on a large amount of users Macs because the processors in them didn't have the correct SSE instruction set (mainly cheese grater Xeon equipped machines). NI did mention it but it wasn't exactly made clear when downloading the plug-in, it was "hidden" amongst a few pages after it was downloaded.

There's probably a page somewhere that says this won't work on 1st generation KK keyboards, but I'll bet Avid will say its NIs' problem and vice versa.
Reply With Quote
  #9  
Old 10-29-2021, 08:12 AM
devinemke's Avatar
devinemke devinemke is offline
Member
 
Join Date: Sep 2018
Location: NYC
Posts: 71
Default Re: PT 2021.10 Bug Thread

bugs in 2021.10? ok, i'll play.

starting with 2021.10 there is the new "Flexible Track Routing" with "Routing Coefficients" in /Preferences/Mixing/.
on my MacBook Pro 13" (native screen resolution 2560 x 1600) the bottom of the Preferences window is cut off, and there is no way to scroll down to the see/edit the full parameters.
see attached screen shot:
Attached Images
File Type: jpg Screen Shot 2021-10-29 at 10.03.03 AM.jpg (14.2 KB, 0 views)
__________________
Devin Emke
Audio Post Production Engineer
Saturday Night Live, NBC
Reply With Quote
  #10  
Old 10-29-2021, 01:40 PM
PhiBee's Avatar
PhiBee PhiBee is offline
Member
 
Join Date: Sep 2011
Location: Strasbourg - FRANCE
Posts: 157
Default PT 2021.10 Bug Thread

Same issu with my Komplete Kontrol A61, those new features doesn’t work !
Something messing !
__________________
WIP house Prod - home studio
iMAC 4K i7 - 11.6.1- Pro Tools Ultimate 2021.12 - RME Digiface USB - Audient iD22 - Behringer ADA8200 - Digidesign C|8 / Presonus Faderport. NI KK A61. LNA Video Slave 4.
STUDIO PRO Post-prod
MAC Pro "Trash can" - 10.14.6 - Pro Tools HDX + Ultimate 2019.12 /Avid C|24/S3/ProTools|Dock. Blackmagic.

Last edited by PhiBee; 11-01-2021 at 05:43 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2021.6 and 2021.7 restart after exit NJsound.com Pro Tools 2021 12 08-11-2021 02:45 PM
Downgrading from 2021.6 t0 2021.3 Mac M1 Leon77 Pro Tools 2021 2 07-21-2021 10:43 AM
bus error in thread main thread at address 0xbfffd010 abayman65 Post - Surround - Video 2 01-28-2010 08:17 AM
Hey, where is todays..'Everyones sick of the XP issue,heres another thread' thread? greenroom 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 6 05-10-2002 12:59 PM


All times are GMT -7. The time now is 03:52 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com