Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools 2020

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 07-14-2020, 02:27 PM
therezablade therezablade is offline
Member
 
Join Date: Jul 2020
Location: Boston, MA
Posts: 5
Default Overall slow performance after PT 2020.5 and OS 10.15 update

Hello!

I've been a PT user for the last 10 years. I've gone through every major version since PT 9.

I updated to PT 2020.5 and OS 10.15 about a month ago. Two separate computers exhibit performance issues that were either a) not present or b) not as bad in PT 12.8.

Computer #1 = iMac 2013, 27 inch, Late 2013, 3.4 GHz CPU, 16 GB RAM

Computer #2 = MacBook Pro 2013, 13 inch, Late 2013, 2.5 GHz CPU, 8 GB RAM

Computer #1 was last on OS 10.12 Sierra and Computer #2 was last on OS 10.14, both running PT 12.8.

After upgrading to PT 2020.5 and OS 10.15, I get:

- Constant CPU overload errors when using half of the plugins I used to use

- Distorted audio after CPU overload, resulting in me having to toggle buffer size to reload audio system

- Project load times multiplied significantly

- Plugin load times multiplied significantly

- Antares AutoTune EFX crashes PT upon first load. Works fine afterwards.

Disclaimer: I'm fully aware that OS 10.15 is notoriously slower than other recent Mac operating systems. However, I'm getting the same exact behavior in PT 2020.5 on multiple machines.

If anyone has similar experiences or can shed any insight, I'm all ears.

Thanks!
Reply With Quote
  #2  
Old 07-14-2020, 02:38 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 25,021
Default Re: Overall slow performance after PT 2020.5 and OS 10.15 update

Hi, welcome to the community.

I am pretty sure your problems are due to upgrading your OS, but also your computer two has inadequate memory. Do a clean OS install and try again.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #3  
Old 07-14-2020, 02:41 PM
therezablade therezablade is offline
Member
 
Join Date: Jul 2020
Location: Boston, MA
Posts: 5
Default Re: Overall slow performance after PT 2020.5 and OS 10.15 update

Yes, it's definitely possible. I would imagine this would help to some degree. I'll keep this in my back pocket before pulling the trigger.

I'd like to see if others have any alternate solutions
Reply With Quote
  #4  
Old 07-14-2020, 02:47 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 25,021
Default Re: Overall slow performance after PT 2020.5 and OS 10.15 update

I had an upgraded test system since Catalina release, and once I did the clean install all I can say difference was night and day.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #5  
Old 07-14-2020, 02:59 PM
therezablade therezablade is offline
Member
 
Join Date: Jul 2020
Location: Boston, MA
Posts: 5
Default Re: Overall slow performance after PT 2020.5 and OS 10.15 update

Oh really? Ok good to know.

Are we talking just reinstalling from recovery mode? Or doing a full OS installation, with fresh installs of everything?
Reply With Quote
  #6  
Old 07-14-2020, 03:01 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 25,021
Default Re: Overall slow performance after PT 2020.5 and OS 10.15 update

Backup everything by hand, erase system drive, install OS, restore everything by hand. Do not even think of using Time Machine or Migration Assassin, do everything manually.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Export video is crazy slow on 2020/Mojave melodydetective Pro Tools 2020 1 05-21-2020 11:13 AM
2020.3 Update - All Softkeys gone innenhofstudios Avid S4/S6 7 05-07-2020 06:20 AM
Security Update 2020-002 10.14.6 Muttonhead Getting Started 0 04-09-2020 10:23 AM
slow, stuttering performance banjo71 Pro Tools 10 7 12-21-2015 12:49 PM
PT6 on a Quicksilver 733 G4 - slow performance JBRecording 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 13 02-22-2003 04:19 AM


All times are GMT -7. The time now is 03:59 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com