Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Windows

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-31-2021, 06:36 PM
Wilfriedd Wilfriedd is offline
Member
 
Join Date: Dec 2020
Location: France
Posts: 34
Default " software requires installation of the interlok(r) device drivers " PT10 Win 10 ...

Hello ,

I know we are quite some people to get stuck with this error since 2016 atleast . Now , i'm among these users and can't resolve this . I'm explaining for people that don't know :

I was running Pro tools 10.3.10 on Win 7 x64 and everything was fine .

I just bought a new PC on a Windows 10 x64 .

I've installed pro tools 10.3.10 in this system and having an error when opening it . It says :

" software requires installation of the interlok(r) device drivers ....Reboot your computer or download it ...."

The program doesn't load iles as from BF76 ....... ( BF76 and other AIR plugins ) .

I already saw this issue a lot of time , and i know we had just to go on Ilok folder and found the OLD INSTALLER and run it . Then reboot and all was fine .

But this take doesn't work with Pro tools 10 on win 10 machines ...

When you reboot your computer , it's over . You got a loop BSOD saying that something critical happened . At this point , you're lucky if you had a restore point created before this issue . Otherwise , you will have to ' REPAIR" your computer or Reinstall Windows 10 ...Yes ..

So i succeeded to repair the computer in a state that it was BEFORE running this old installer ... But you can't do nothin about that . Because the latest drivers from Ilok licence drivers you install will not resolve this .


Now , i'm stuck with the New PACE installed , but not allowed to use my old plugins . It's really a PAIN and i dont understand why Avid or Pace doesn't try to resolve this . Maybe because a lot of people don't use PT 10 anymore ( 32 bit interface) . I know there isn't any problem with PT 11 and up .

Did somebody find a solution for this , after all these years ?

Like i said , Pro tools 10 can run without old Ilok drivers , but it will not allow you to use all AIR effects (chorus , lofi etc) , nor BF76 , BF ... plugins .

I found some posts about that in 2017 , 2018 with no answer . I was hoping that some solutions were found since this time .

Thank you really much
Reply With Quote
  #2  
Old 02-02-2021, 04:47 PM
guitardom guitardom is offline
Member
 
Join Date: May 2004
Location: New Mexico
Posts: 6,807
Default Re: " software requires installation of the interlok(r) device drivers " PT10 Win 10

I don't have experience with the problem, but PT10 has been unsupported now for quite a few years. The last maintenance release was over 5 years ago. But do the AIR effects plugins do not require an ilok license, so not sure why they are being broken by a pace install. Are you running the separate installers for the AIR effects?
__________________

pro-tools-pc.com


TRASHER Pro Tools Utility(updated 3-6-18)

HD Native, Avid 16x16, Eleven Rack, Focusrite Clarett 8preX, UA Quad Apollo TB.

Intel I7 9900k
Win 10
Reply With Quote
  #3  
Old 02-11-2021, 11:20 AM
Wilfriedd Wilfriedd is offline
Member
 
Join Date: Dec 2020
Location: France
Posts: 34
Default Re: " software requires installation of the interlok(r) device drivers " PT10 Win 10

I dont really know .


All the AIR effects are involved with this message .


And it seems that a lot of people have this issue , some of them are lucky and have them Pro Tools 10 still running . But i dont know how!!
Reply With Quote
  #4  
Old 09-18-2022, 10:07 PM
hernangil hernangil is offline
Member
 
Join Date: Aug 2022
Location: Cra 70 105-07
Posts: 3
Default Re: " software requires installation of the interlok(r) device drivers " PT10 Win 10

Hi, having the same problem but I cant find the Old Driver folder on the actual and legacy Licence support installers downloaded on ilok.com
Reply With Quote
  #5  
Old 09-19-2022, 02:17 PM
albee1952's Avatar
albee1952 albee1952 is offline
Member
 
Join Date: May 2004
Location: Norwich, CT
Posts: 38,458
Default Re: " software requires installation of the interlok(r) device drivers " PT10 Win 10

You probably need to downgrade the OS to Windows 7. PT12.4 is the lowest version to be compatible with Win10. As for legacy iLok, its likely there, but the site is not very intuitive in that regard. If poking around a bit doesn't turn up the old stuff, either google for the version you need(which might yield a good link), or figure out what you need and ask here as many of us save old installers. As a last ditch attempt, you could try installing the software in compatibility with Win 7. I don't know that it will work, but you have nothing to lose
__________________
Gigabyte X79/intel i7 3930K, 32GB RAM, HD/Native, 192 IO
https://www.facebook.com/search/top/...0sound%20works


The better I drink, the more I mix

BTW, my name is Dave, but most people call me.........................Dave
Reply With Quote
  #6  
Old 09-19-2022, 05:47 PM
EGS's Avatar
EGS EGS is offline
Member
 
Join Date: Nov 2004
Location: Chicago
Posts: 3,482
Default Re: " software requires installation of the interlok(r) device drivers " PT10 Win 10

Here's some legacy iLok installers: https://ilok.com/#!resource/legacy
__________________
Desktop: PT 2020.5 / Win11 / Intel 11th Gen i9 5.1GHz / 64Gb DDR4-3600 / Gigabyte Z590 Vision D / Focusrite LS56
Laptop: PT 2020.5 / Win10 / older HP ProBook with i7 quad / U-PHORIA UMC1820
Legacy (works!): PT 5 & 6 / OS9 & OSX / Mac G4 / DIGI001
Click for audio/video demo
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
This software requires installation of the interlok... realizment Pro Tools 10 2 04-30-2017 03:04 AM
This software requires installation of the interlok(r) device drivers RickD16v Pro Tools 10 3 09-24-2016 06:00 PM
pro tools 10 launching - "this software requires a new version of interLok driver" stopi Pro Tools 10 3 04-21-2016 11:10 AM
DICE chipset+PT10="ASIO device properties have been changed by the device" Funk-O-Meter Windows 5 12-19-2012 06:12 PM
The software requires installation of device driver TPkd and shilshoolon 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 1 01-16-2008 05:20 PM


All times are GMT -7. The time now is 09:51 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com