Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > Artist Series

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-02-2022, 05:24 PM
mcnichols mcnichols is offline
Member
 
Join Date: May 2012
Location: Weston-super-mare UK
Posts: 22
Default Artist Control and Mac Pro 2019 (7.1)

Hi. I am currently upgrading to a Mac Pro 2019, which has 10G ethernet ports. I've read about possible issues with these ports and the Artist series, and sure enough my MC Control 'surface' isn't recognised at all. It's plugged into Ethernet port 1 via a Netgear switcher, just as it was on my old cheesegrater 5.1, with static IP set on the surface (11.0.0.3) and on the Mac (11.0.0.1). Ethernet port 1 shows as 'connected' in System prefs/Network.

The Mac Pro is on Monterey 12.5.1 with PT 2022.7 and latest Eucon, all fresh installs, no system/user migration at all.

Is there a way around this issue, please? Am I missing something obvious?

I think I've seen PCIe cards with Ethernet ports, or possibly a USB-C adaptor/dock - anyone tried these options with success?

Thanks in advance.
__________________
Martin Nichols

PT Ultimate 2021.12 and 2021.3.1, Mac Pro 12-core 5.1, 48Gb RAM, Mojave, HDX card with Avid HD interfaces.
Reply With Quote
  #2  
Old 09-02-2022, 06:34 PM
priorytools priorytools is offline
Member
 
Join Date: Apr 2005
Location: UK
Posts: 1,261
Default Re: Artist Control and Mac Pro 2019 (7.1)

Maybe try resetting the artist, letting it use DHCP.
And lose the switch.
If that works, then maybe try reintroducing the switch.


Sent from my iPhone using Tapatalk
__________________
~ 2019 Rack Mac Pro 3.2 GHz 16 core 384 GB RAM Catalina 10.15.7 / Pro Tools Ultimate 2021.12.0 / HDX 2 + UAD2 PCIe OCTO+QUAD / HD I/O's x 4 + 1 x 96io / Digidesign Pre's x 3 / Avid S6 M10-24 -V21.10.1.29 ~
~ Mac Pro 8 core - clover - 13 GB ram - 10.6.8 / HD5 / Pro Tools 9.0.6 / Magma PE6R4 ~ ARCHIVE RIG

~ Mac Pro (Early 2009) - 2 x 2.26 GHz Quad-Core-32 GB RAM-10.13.6 / Pro Tools Ultimate 2019.10 / Apollo 16 / Avid S3 ~
Reply With Quote
  #3  
Old 09-03-2022, 06:16 AM
mcnichols mcnichols is offline
Member
 
Join Date: May 2012
Location: Weston-super-mare UK
Posts: 22
Default Re: Artist Control and Mac Pro 2019 (7.1)

Thanks for the suggestions, but no concrete solution sadly.

I’ve done a lot of further experimenting, and on just two occasions the Artist display did show what it was supposed to, rather than the Avid logo, but neither repeatable.

The first was with a direct connection via a USB-C to Thunderbolt 2 to Ethernet (two Apple adaptors, as suggested elsewhere on DUC) with Manual IP 11.0.0.1 on the Mac and DHCP set on the Artist. This showed up in EUControl and was selected, but was gone again on next restart.

The second was via direct connection from Ethernet port 1, this time recognising the open Network Prefs window, again with static IP, but it didn’t survive a restart either.

The Network Prefs pane only shows a ‘green’ status when static IP is set either with or without the switch, but looking at ‘Advanced>Hardware’, the connection speed is 1000baseT with the switch in place and 100baseTX when directly attached to the Artist MC Control. When set to DHCP, it only shows ‘amber’.

I need to use the switch as the MC Control is shared between two computers (only one at a time), and I don’t want to have to go fishing for leads. As I said, this all worked perfectly on the old 5.1 two computer set up.

Clearly there is something intermittent or borderline with the settings. Any network engineers out there?
__________________
Martin Nichols

PT Ultimate 2021.12 and 2021.3.1, Mac Pro 12-core 5.1, 48Gb RAM, Mojave, HDX card with Avid HD interfaces.
Reply With Quote
  #4  
Old 09-04-2022, 12:43 PM
EddieJones's Avatar
EddieJones EddieJones is offline
Avid
 
Join Date: Dec 2014
Location: Santa Cruz
Posts: 3,807
Default Re: Artist Control and Mac Pro 2019 (7.1)

Please set everything to DHCP. You can't set a static and a DHCP and expect it to work....also 11.x.x.x is not a valid internal IP range but an Internet one so its looking on the internet for connections.
We have seen issues with the 10G ports on Macs. They don't fully support direct 100Mb connections.
Reply With Quote
  #5  
Old 09-05-2022, 01:44 PM
mcnichols mcnichols is offline
Member
 
Join Date: May 2012
Location: Weston-super-mare UK
Posts: 22
Default Re: Artist Control and Mac Pro 2019 (7.1)

Thanks Eddie.

I had no joy with DHCP, however, you're suspicion about the IP held the key. I'm not sure how it got changed, but I eventually found the original Euphonix advice to use settings 10.0.0.1 for the Mac and 10.0.0.3 for the MC Control, and to connect via a 'switcher', in my case a 'Gigabit' device. This now seems to be working correctly.

Hope this helps anyone else with 10G Ethernet port.
__________________
Martin Nichols

PT Ultimate 2021.12 and 2021.3.1, Mac Pro 12-core 5.1, 48Gb RAM, Mojave, HDX card with Avid HD interfaces.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot setup Artist Control and Artist Mix to work at the same time elchuliver Artist Series 1 06-12-2022 08:20 PM
EuControl 20.6.1.3 not working on Mojave with Artist Control and Artist Mix SvenIsak Avid S1, S3, Dock and Control App 3 10-09-2020 01:59 AM
Artist Control new breaking bugs with Eucontrol 2019.12 Oli_W Artist Series 4 01-06-2020 08:12 AM
2 avid artist mixes and one artist control V2 for sale Brandonx1 Buy & Sell 2 03-21-2016 10:55 PM
Touching Artist Transport Freezes Up Artist Control in Logic sonofmack Artist Series 1 03-13-2013 09:22 PM


All times are GMT -7. The time now is 01:24 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com