Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Licensing & Accounts

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-05-2016, 11:51 AM
Bennett Paster Bennett Paster is offline
Member
 
Join Date: Dec 2002
Location: Brooklyn, NY
Posts: 20
Default Licensing support issue= Can't Load Avid Support Portal! It's blank

Hi folks-

I'm trying to contact Avid about a licensing question for my Pro Tools subscription, but whenever I try to load the Support Portal page by linking from my Master Account page, it just shows up as a blank page (only the Avid Support Header appears, no content or contact info). The other Support pages load fine but I can't seem to contact them since I can't start a case at the portal! I've tried in multiple browsers, all from Mac 10.10.5. Any idea what's up?

(In fact the entire Avid site has been super slow to load and buggy for days!)

Here's my issue- maybe someone can help with this?

On 12/2/16 I renewed my PT Vanilla Annual Subscription from the Avid.com store, but my iLok account still shows that my license plan expires on 12/14/16. It should be extended to 12/14/17- that's what my Avid Master Account says, but doesn't my iLok asset also have to be updated?

I'm still running PT 12.5, so I'm not ever even sure I got the 12.6 asset.

The link in my Avid Store email from my purchase just takes me to the download page- there's no indication of how I get my iLok asset renewed.

Why are they making this so hard? Any help would be most appreciated. Thanks.
__________________
Late 2013 Mac Pro, 3.5 GHz 6-Core Intel Xeon E5, 16 GB 1866 MHz DDR3 ECC, AMD FirePro D300 2048 MB, Startup disk SSD 256. OSX 10.10.5, Pro Tools 12.4
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Avid Support Plan - Support costs Extra mixinthecity General Discussion 6 01-27-2016 01:47 PM
Dear Avid customer support! Would you please answer my both avid support cases Ale Pro Tools HDX & HD Native Systems (Mac) 0 11-24-2011 01:56 PM
AVID SUPPORT-Digi002 Console-"Error Occured while trying to load the Controller Perso claudemorrow 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 04-01-2011 05:37 PM
Support Update: Avid Support Codes - Effective July 31, 2010 Avid General 0 07-31-2010 11:55 AM


All times are GMT -7. The time now is 01:45 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com