Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Tips & Tricks

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-01-2021, 02:31 PM
Rockman413 Rockman413 is offline
Member
 
Join Date: Nov 2009
Posts: 475
Default Why the latency happens for recorded audio from a digital source

Hi there,
Maybe this more related to audio basics, and maybe this doesn't matter as we probably can't hear any difference, but I just want know some basics regarding digital audio how it works.

So I have 2 DAW running, I sync PT and DP via MTC. I play a drum hit sound in DP and have it output via loopback (or ADAT, etc..) and record into PT. Every time the exact position of such hit sound is slightly different.
I can understand there'll be a lantecy for me to hear this sound in PT, as there's roundtrip latency and because it's live record there's no delay compensation. But why the recorded position is also different every time? There's a one trip latency in this "roundtrip latency" ? Shouldn't PT automatically compensate for this delay and put the recorded audio at the correct position every time ?
__________________
Mac Pro 3.0G 8 Cores PT HD use with Ensemble Thunderbolt
Reply With Quote
  #2  
Old 01-01-2021, 11:03 PM
Top Jimmy's Avatar
Top Jimmy Top Jimmy is offline
Moderator
 
Join Date: Oct 2005
Location: Spokane, WA
Posts: 5,487
Default Re: Why the latency happens for recorded audio from a digital source

Quote:
Originally Posted by Rockman413 View Post
So I have 2 DAW running, I sync PT and DP via MTC. I play a drum hit sound in DP and have it output via loopback (or ADAT, etc..) and record into PT. Every time the exact position of such hit sound is slightly different.
MIDI time code is far from sample accurate. While your I/O delay is constant, there’s quite a bit of slop in the timing when syncing with MTC. If both DAWs are clocked to the same sample clock, there won’t be any timing drift, so the random difference you’re seeing has to do with how quickly the chasing DAW locks to the MTC.
__________________
James Cadwallader

Hackintosh - Gigabyte Z77X-UP5TH, Intel Core i7-3770K, 32GB 1600Mhz DDR3, 2x SATA 6Gb/s 240GB SSD, 3x SATA 6Gb/s 1TB HDD, 1x Glyph 2TB USB3 HDD, Mojave 10.14.6.

Pro Tools Ultimate 2021.3, HD Native, Focusrite Red 8Pre (Mac)
Pro Tools 2020.12, Mbox3 (Win)

Presonus Faderport, Pro Tools | Control
Reply With Quote
  #3  
Old 01-02-2021, 09:52 PM
Rockman413 Rockman413 is offline
Member
 
Join Date: Nov 2009
Posts: 475
Default Re: Why the latency happens for recorded audio from a digital source

Quote:
Originally Posted by Top Jimmy View Post
MIDI time code is far from sample accurate. While your I/O delay is constant, there’s quite a bit of slop in the timing when syncing with MTC. If both DAWs are clocked to the same sample clock, there won’t be any timing drift, so the random difference you’re seeing has to do with how quickly the chasing DAW locks to the MTC.
Ok, so MTC caused the problem. BUT:

I tested: DAW Ahas a midi track sends out Midi data to DAW B instrument and record the audio back into DAW A audio track using: sound flower, physical ADAT, loopback2, all end up with different location very slightly. What is the reason for this? There's no MTC involved
__________________
Mac Pro 3.0G 8 Cores PT HD use with Ensemble Thunderbolt
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Latency bug - recorded audio 1ms early RuLemer Pro Tools 12 4 02-07-2018 01:30 PM
Digital Clicks and Pops in Recorded Audio chrsharvick29 Pro Tools 12 14 01-28-2017 07:53 PM
Eleven Rack latency on recorded audio bandol79 Eleven Rack 2 07-17-2014 04:35 PM
massive digital glitchy noise on newly recorded audio? (sample included) awritersparadise Pro Tools 9 4 07-28-2011 05:54 PM
adjusting recorded audio by system latency? Tweakster 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 9 04-05-2009 10:41 AM


All times are GMT -7. The time now is 02:11 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com