Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Virtual Instruments

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-19-2013, 11:02 PM
holyspicoli holyspicoli is offline
Member
 
Join Date: May 2006
Posts: 71
Default midi track record turns off all other midi/instrument tracks delay comp

Hey all I searched for an answer in these forms and couldn't find one so I apologize if the answer's out there and I missed it. I have a session with several audio tracks and numerous instrument tracks and VST plugins (such as Xpand, Massive, etc). I have PT HD 8 and delay comp is set to long. When I put any of the instrument or midi tracks into record it not only turns off delay compensation for that track (so that when you play live you can hear it immediately) but also ALL other midi/instrument tracks. Can this be turned off? In other words whenever I'm recording midi on to any track, all audio tracks stay compensated but all other midi and instrument tracks are playing "immediately", i.e. early. This is a big deal because I have the Virus TI plugin on an instrument track which has a very large delay (about 3700 samples at 44.1K) due to the plugin needing to interface with the hardware and back over a USB cable. So whenever I record any midi or instrument whatsoever, ALL OTHER midi/inst tracks in the session play 3700 samples early from the rest of the audio. What I want is that all other tracks are left the way they are when I'm recording onto a midi/inst track. Can this be done?
Reply With Quote
  #2  
Old 06-22-2013, 10:44 PM
holyspicoli holyspicoli is offline
Member
 
Join Date: May 2006
Posts: 71
Default Re: midi track record turns off all other midi/instrument tracks delay comp

bumperoo, any help here?
Reply With Quote
  #3  
Old 06-25-2013, 06:47 AM
suicune suicune is offline
Member
 
Join Date: Mar 2007
Location: Wolverhampton, UK
Posts: 896
Default Re: midi track record turns off all other midi/instrument tracks delay comp

For future reference you might want to try posting in one of the other forums (like maybe the HD TDM one) as some of them are a little more frequently visited than this one - legacy or no .

Before I try answer your question can I ask what exact version are you using? There was a behaviour change in v8.1.1 which I think which could have some impact on the answer. Also exactly what are the other problem MIDI tracks you have in the session - are they external MIDI, MIDI tracks routed to instrument tracks, instrument tracks only or any combination of the above?
__________________
M2 Studios
Wolverhampton, UK
http://www.madhat.co.uk
Reply With Quote
  #4  
Old 07-17-2013, 07:44 PM
holyspicoli holyspicoli is offline
Member
 
Join Date: May 2006
Posts: 71
Default Re: midi track record turns off all other midi/instrument tracks delay comp

Hey Suicune, thnx for the reply. I'm using PT HD 8.1.1. At the moment I'm not using any external gear, just soft synths. I have the same problem with all MIDI and Instrument tracks regardless of where they are routed. When I put any one track into record, it turns off delay compensation on all midi or instrument tracks, not just the track in record. I get that you want the ONE track you're recording on to to have compensation turned off (so your live playing is immediate), but why on earth would anyone want all instrument/midi tracks to have their compensation turned off during record? With low amounts of plugin delay it's not a big deal, but as soon as I put one high-latency plugin like AutoTune Evo or or I mentioned the Virus TI plugin into the session, and try to record any midi, ALL other instrument tracks are put into "immediate" mode, i.e. no compensation, i.e. playing way ahead of all the audio tracks! It seems like such a goofy feature to me. If you have any idea about this or how to disable it, plz let me know. Driving me nuts and it seems like it makes no sense for this feature to be here.
Tony
Reply With Quote
  #5  
Old 07-18-2013, 06:14 AM
suicune suicune is offline
Member
 
Join Date: Mar 2007
Location: Wolverhampton, UK
Posts: 896
Default Re: midi track record turns off all other midi/instrument tracks delay comp

That's not normal behaviour if I am remembering PT8 correctly, although I may not be as it's been a few years now. Whilst delay compensation recording MIDI was a pain in PT8 the problem you are describing is not what the main issue was.

You don't have all your software synths routed to a single auxiliary do you? Or plugins on a master fader?

If the answer to both of these is no then I would hazard a guess that this is the issue:

Quote:
I have the Virus TI plugin on an instrument track which has a very large delay (about 3700 samples at 44.1K) due to the plugin needing to interface with the hardware and back over a USB cable.
Have you tried removing it and see what happens then?
__________________
M2 Studios
Wolverhampton, UK
http://www.madhat.co.uk
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't record instrument track 2 with MIDI... cf_mono Windows 1 04-06-2013 08:25 PM
Route two instrument tracks to one midi track ? chrisdee Windows 3 12-04-2012 09:37 AM
Record enable instrument tracks in midi editor Intransit Pro Tools TDM Systems (Mac) 8 09-22-2011 02:20 PM
Instrument Track won't record MIDI WRX07 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 08-19-2009 12:20 AM
MIDI to Instrument track record DonaldM MIDI 5 05-07-2008 03:57 PM


All times are GMT -7. The time now is 04:10 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com