Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools 11

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-01-2021, 09:21 AM
kabster1985 kabster1985 is offline
Member
 
Join Date: May 2016
Location: Newcastle upon Tyne, United Kingdom
Posts: 21
Default Digital keyboard / Midi randomly stopped working when using virtual instruments

Hi.
Just recently I came back to work on a track of which I had recorded using virtual instruments, through my digital piano both a piano track (using XLN's Addictive Keys) and an orchestral string section (using VSL Epic Orchestra). Previous to this problem everything was working fine.
I would open an Instrument track, select a virtual instrument, arm the track and I would be able to play and record as normal.
I've spent many hours searching the internet for a fix but so far I've been unsuccessful.
What is confusing is it was working perfectly fine one day and then another day Pro Tools decided stop receiving a signal/MIDI from my digital piano.
If I run the virtual instruments I mentioned as stand alone programs separate of Pro Tools they work fine.

I am using a Zoom UAC 2 external sound card with a Yamaha p-45 digital piano. The Zoom UAC 2 is linked via a USB 3 cable and the Yamaha p-45 is USB 2.

What's baffling is I've used this setup and had little or no problems for a while now and the fact that the stand alone versions work perfectly does not really make much sense.

If anyone has any ideas to what is causing this problem and a fix I would be over the moon!

Thanks
__________________
Windows 10 Pro
I9-10850K, 3.6GHZ
64.0 GB
Reply With Quote
  #2  
Old 11-01-2021, 11:13 AM
The Weed's Avatar
The Weed The Weed is offline
Member
 
Join Date: Jul 2001
Location: Toronto, Ontario, Canada
Posts: 6,926
Default Re: Digital keyboard / Midi randomly stopped working when using virtual instruments

If it's what I think it is, it's a known issue where the Virtual Instrument's assignment is "forgotten" by Pro Tools. Lots of posts about that. If it is the case, reassign the Virtual Instrument.
__________________
Take your projects to the next level with a
non-union national read at reasonable rates
Demos: brucehayward dot com
SonoBus
Source-Connect: brucehayward
Options for Remote Direction
Reply With Quote
  #3  
Old 11-03-2021, 04:39 PM
albee1952's Avatar
albee1952 albee1952 is offline
Member
 
Join Date: May 2004
Location: Norwich, CT
Posts: 38,434
Default Re: Digital keyboard / Midi randomly stopped working when using virtual instruments

And, did you make sure to turn off Power Management on all USB ports(aka USB Root Hub in Device Manager)?

Back to what The Weed is describing, if you are new to this stuff, you can go to(in Pro Tools) the View menu>MIX windows>and check the option to show "Instruments". That adds a row of boxes across the top of the MIX window where you can see(and edit) assignments on Instrument tracks
__________________
Gigabyte X79/intel i7 3930K, 32GB RAM, HD/Native, 192 IO
https://www.facebook.com/search/top/...0sound%20works


The better I drink, the more I mix

BTW, my name is Dave, but most people call me.........................Dave
Reply With Quote
  #4  
Old 05-07-2022, 04:00 AM
kabster1985 kabster1985 is offline
Member
 
Join Date: May 2016
Location: Newcastle upon Tyne, United Kingdom
Posts: 21
Default Re: Digital keyboard / Midi randomly stopped working when using virtual instruments

Hi Albee and The Weed, I just wanted to say thank you for the fast replies at the time and sorry for taking so long to reply. I had somehow fixed the problem and apologize for forgetting to reply with a description of the fix.
The same problem has made an appearance and I've opened a new thread/ post: https://duc.avid.com/showthread.php?t=420120

Will have a look at what you suggested and get back to you, many thanks, your help is hugely appreciated :)

Kind regards

Kab
__________________
Windows 10 Pro
I9-10850K, 3.6GHZ
64.0 GB
Reply With Quote
  #5  
Old 05-07-2022, 05:30 AM
kabster1985 kabster1985 is offline
Member
 
Join Date: May 2016
Location: Newcastle upon Tyne, United Kingdom
Posts: 21
Default Re: Digital keyboard / Midi randomly stopped working when using virtual instruments

Ok so I've tried turning off Power Management on all USB ports in Device Manager which unfortunately did not fix the problem.
I've tried searching for posts on "How to reassign the Virtual Instrument" but can't find any. Also tried looking through the Reference Guide and could not find anything.
Would it be possible if you could forward a link or explain if you have time how reassign a Virtual Instrument?
I've also uploaded a screenshot of my UI showing an instrument track with the Mini Grand VI active in both the editing and mix window just in case you may spot something that looks wrong.
Another thing. By clicking on the VI keyboard you can actually play the piano using your mouse. I think I mentioned it before but when using the digital piano with the stand alone versions of Addictive Keys and VSL there is no problem.

Thanks again for your help :)

Kind regards

Kab
Attached Images
File Type: jpg ptwindows.jpg (24.7 KB, 0 views)
__________________
Windows 10 Pro
I9-10850K, 3.6GHZ
64.0 GB
Reply With Quote
  #6  
Old 05-07-2022, 05:36 AM
kabster1985 kabster1985 is offline
Member
 
Join Date: May 2016
Location: Newcastle upon Tyne, United Kingdom
Posts: 21
Default Re: Digital keyboard / Midi randomly stopped working when using virtual instruments

I've attached 2 images taken from the screenshot showing zoomed in versions of the inserts
Attached Images
File Type: png editing window VI.png (14.6 KB, 0 views)
File Type: png mixing window VI.png (8.7 KB, 0 views)
__________________
Windows 10 Pro
I9-10850K, 3.6GHZ
64.0 GB
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
usb Keyboard motif xs not working with virtual instruments bobleworm MIDI 10 12-07-2016 12:42 PM
MIDI Keyboard stopped working please help! Yarn Pro Tools 12 3 09-05-2016 09:01 PM
How to control Virtual Instruments via external Midi-Keyboard? Sonic-B Virtual Instruments 5 05-23-2011 03:36 AM
Using Virtual Instruments without Midi Keyboard hendrixrocker2 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 3 09-13-2010 04:08 PM
BFD Lite stopped working Randomly d3drocks 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 4 01-01-2009 08:58 PM


All times are GMT -7. The time now is 06:51 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com