Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support

Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac)

Thread Tools Search this Thread Display Modes
Old 03-06-2006, 01:52 PM
Leigh Marble Leigh Marble is offline
Join Date: Jul 2001
Location: Portland, OR
Posts: 253
Default Fixing Clicks and Noise with CHUD and Nap mode off

I started this thread under a Dave C test thread, but I think it deserves its own, consolidated response.

I recently upgraded my G4 (a 733 MHz Digital Audio) with an OWC 1.4 GHz processor. After a successfull install, I launched Pro Tools and was dismayed to find nasty problems with the audio output. The Digi's outputs suffered a heavy, irregular tremolo-like effect, while the same track multed to my external converter (a Lucid ADA8824) had loud crackles and pops over it. Normally, I clock PT off the Lucid (see system spec below), but I tried switching the PT session's sync to internal, and the noises went away. Additionally, when I booted into OS 9, there were no noises there either.

Next day, for reasons totally unrelated, I installed Apple's CHUD utility, a free developer package for analyzing hardware performance. I noticed it had added a System Preferences pane called "Processor." I opened the pane, saw some CPU readouts and controls, including a checkbox labeled Power: Nap. The box was already checked. I unchecked the box (disabling Nap mode) and decided to try Pro Tools again. Bam, the noise was gone. The noise clicks on and off when I click the Nap box.

Now, I know CHUD has been mentioned here before, but I hadn't seen them until after I discovered this issue on my own. In addition, there are issues around it that aren't clear (like, what's it doing, where to get it, will disabling Nap mode hurt my processor) that I think should be discussed all in one place.

So, first, you can download CHUD here: http://developer.apple.com/tools/download/

Second, what's it doing? According to Apple, nap mode will "enable or disable power saving features of the processor". Another guy wrote in an Apple dev forum, nap mode is "where unused parts of the processor are temporarily switched off, but they can be switched on again very quickly as needed." I'm not clear how this relates to the System Preferences/Energy Saver/Processor Performance option that some machines have - mine doesn't have that, so I can't check if it's actually controlling the same thing.

While dynamically controlling processor usage is a great idea for energy conservation and heat reduction, it stinks for maintaining a stable sync between said processor and an external clock. It won't hurt your machine to disable Nap mode, but it will make it run at full throttle all the time, so you have to take care with keeping your system cool... but that's a topic for another time.

Now, some other issues from my experience:

Unfortunately, the Processor preferences pane doesn't remember the "disable nap" setting on reboot. It comes up after every reboot every time with nap enabled. I found a page that shows how to add a simple Applescript to automate this setting on login. (Note that they're actually talking about how to turn nap mode on, for machines that default to nap mode off.) I would need to create a script to run at login with one command:

do shell script "hwprefs cpu_nap=0"

(Note that you won't have the hwprefs command on your machine until you install CHUD.)

Again, unfortunately, this script won't work here, because of some kind of bug that, no matter which setting you try from the command line, it always turns Nap mode on - even when you tell it to turn it off, and it's already off, it turns it on! In detail, I've got Nap mode unchecked in System Prefs. When I use "hwprefs -v cpu_nap=0" in a Terminal window, it says, "* processor nap enabled *", and checking the Processor preferences pane shows that the Nap box is indeed now checked. Then I uncheck the Nap box, and query from the Terminal, ""hwprefs -v cpu_nap". It reports correctly that Nap mode is off, but if I issue any command (whether for values 0, 1, true, or false), it goes ahead and turns it back on! Maddening! I don't know what the System Prefs pane has access to that the command line doesn't. Maybe I'll pull up Console and see if I can find a log of System Prefs activity....

Anyway, I hope this saves some people some hair-pulling, and please share your stories of Nap mode success / failure here!


PT Rig: 6.4cs9 and Digi 001, external clocking via optical from Lucid ADA8824
OS: Mac 10.3.5
CPU: 1x 1.4 GHz OWC Processor Upgrade
Machine: G4 Digital Audio
Front Side Bus: 133 MHz
Memory: 1.25 Gb
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How about fixing the insanely loud noise issue in Strike... The Dubnicks Virtual Instruments 1 08-08-2007 07:40 PM
noise on my 002, where can i download that chud? woodbeatz 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 1 05-07-2006 06:02 AM
Plugin for fixing mouth noise? Dolbydawg 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 9 02-09-2006 02:01 PM
Fixing a few Clicks & Pops on tracks? pribb1 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 1 12-30-2004 02:01 PM
CHUD, fixing ADAT XT sync, and motor noise? Yontz Sucre 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 04-09-2004 04:31 PM

All times are GMT -7. The time now is 02:42 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com