Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > macOS

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-05-2022, 04:26 PM
Ben Jenssen's Avatar
Ben Jenssen Ben Jenssen is online now
Member
 
Join Date: May 2000
Location: Oslo
Posts: 4,664
Default First experience with NVMe M.2 in enclosure - bad.

I thought I'd try to give my little M1 Mini a little 'upgrade' by adding a really fast external 2TB drive to complement the internal 512BG. It would replace the 2TB 2.5" in USB-C enclosure that I have now, which has a r/w speed of just under 400MB/s. True Thunderbolt drive enclosures give transfer speeds up to 1550MB/s. You can find many more SSD enclosures that say "Thunderbolt compatible" but notice they are cheaper, and that's because they are not thunderbolt 3, they are USB.

I bought this:

Kingston NV1 2TB M.2 2280 NVMe PCIe Internal SSD

And this:
ORICO Thunderbolt3 M.2 NVMe SSD kabinett
(Sorry, Norwegian page. I can't find much onfo elsewhere. Might be a clue.)

I'll try to make this short.
The assembly was easy. I plugged it in and immediately mesured the r/w speed to about 1500/1200 MB/s. OK.

So I played around a bit, everything was fine, and I started a copying of a 800GB folder in Finder. It stopped about half-way and gave a error about not being properly unmounted, just like if you pulled the cable.

Since then, I've tried anything I can think of:
Different ports.
Different cables.
Different format (APFS/HFS+).
Different partitioning.
Unplugging everything else.
+++

The drive will always fail in a similar way;
I copy things, at once or in increments, when I reach between 4-600GB it ejects, and I get the unmount warning. Then, it's a struggle to format it again, because if not it will self eject whenever you get it to show.

When I manage to reformat it, it seems to work perfectly, I can partition it in Disk Utilities, copy files, anything. Until that moment when it's about 30% full - then it ejects and is unuseful until reformated.

Must be said also that this is very unusual behavior. Disk Utilities can go into a spinning wheel freeze f.ex. Often, if I have had this breakdown of the drive, restart will take much longer than usual, and I will get a "blip" mac system sound when desktop appears, but without any alert or anything.

I'm guessing this is the enclosure, so I'm returning it. I'll keep the 2TB blade and see if I can put it somewhere else. Would've been nice to have a combined dock/enclosure, but they seem very expensive.

Any recommendations appreciated.
__________________
Life-long audio enthusiast and small studio owner. Retired.
Mac Mini M1, 16GB RAM. 512GBinternal(3000MB/s),2TB(1300MB/s),2TB(350MB/s)
MacOS 11.6.8. PT 2020.12.1 (Reinstatement on hold for M3 macs and AS native PT)
Topping D50 DAC, Dynaudio BM6p, Artist Mix, SSL UC1, EuControl on iPad.

Last edited by Ben Jenssen; 08-09-2022 at 01:44 PM.
Reply With Quote
  #2  
Old 08-06-2022, 05:20 AM
LoudBassTone's Avatar
LoudBassTone LoudBassTone is offline
Member
 
Join Date: Dec 2015
Location: Chicago
Posts: 42
Default Re: First experience with NVMe M.2 in enclosure - bad.

Amazon reviews in USA are 37% 1 star, claiming random dismounting and overheating for Orico case. In the US I usually look to OWC.
__________________
PT 2022.5 studio, 12 Core Mac Pro 6,1 96GB, Mac Mini i7 QC 16GB, Digico Soundgrid DLI, Revive Audio 96IO & 192 DBox & 2BussLT for summing, Waves, SoundToys and a pile of other plugins. NI Maschine/Komplete Ultimate 12 and many many, too many Kontakt Libraries.

https://www.youtube.com/channel/UCmT..._as=subscriber
Reply With Quote
  #3  
Old 08-06-2022, 10:49 AM
Ben Jenssen's Avatar
Ben Jenssen Ben Jenssen is online now
Member
 
Join Date: May 2000
Location: Oslo
Posts: 4,664
Default Re: First experience with NVMe M.2 in enclosure - bad.

Quote:
Originally Posted by LoudBassTone View Post
Amazon reviews in USA are 37% 1 star, claiming random dismounting and overheating for Orico case. In the US I usually look to OWC.
Thanks. I didn't catch that.
I ordered this last night:
OWC Envoy Express
__________________
Life-long audio enthusiast and small studio owner. Retired.
Mac Mini M1, 16GB RAM. 512GBinternal(3000MB/s),2TB(1300MB/s),2TB(350MB/s)
MacOS 11.6.8. PT 2020.12.1 (Reinstatement on hold for M3 macs and AS native PT)
Topping D50 DAC, Dynaudio BM6p, Artist Mix, SSL UC1, EuControl on iPad.
Reply With Quote
  #4  
Old 08-06-2022, 11:40 AM
Ben Jenssen's Avatar
Ben Jenssen Ben Jenssen is online now
Member
 
Join Date: May 2000
Location: Oslo
Posts: 4,664
Default Re: First experience with NVMe M.2 in enclosure - bad.

Another thing; the way this Orico enclosure fails, I think of those poor people who will use it and add data to it much more slowly than I did. They will not see the problem until maybe months later, and in a second - drive is a brick, and all data gone.
__________________
Life-long audio enthusiast and small studio owner. Retired.
Mac Mini M1, 16GB RAM. 512GBinternal(3000MB/s),2TB(1300MB/s),2TB(350MB/s)
MacOS 11.6.8. PT 2020.12.1 (Reinstatement on hold for M3 macs and AS native PT)
Topping D50 DAC, Dynaudio BM6p, Artist Mix, SSL UC1, EuControl on iPad.
Reply With Quote
  #5  
Old 08-06-2022, 08:51 PM
Sugarnutz Sugarnutz is offline
Member
 
Join Date: Sep 2002
Location: Great State of Mississippi
Posts: 863
Default Re: First experience with NVMe M.2 in enclosure - bad.

I have one of these that works well on my 2015 rMBP and even better on my i9 PC with Thunderbolt 3, comes with both cables.

SSK Aluminum M.2 NVME SSD Enclosure

Ordered this on today for my sample libraries on the rMBP that I just got PT 2022.7 on along with a new WD 1TB NVMe drive.

SSK Aluminum USB C to M.2 NVMe SSD Tool-Free Enclosure Reader

I’ve got another one of the SSK enclosures for a 512Gb M.2 SATA drive I’ve been using without issue.

I would suggest the 1st link at the top because it comes with thermal material, not sure about the 2nd as someone said the 2nd linked item just relied on drive to housing and getting very hot.
__________________
Gigabyte z390 Designare
I9 990K 4.7 GHz
64 Gb of DDR4 3200
Gigabyte RX580 8 Gb
Win 10 Pro

15" Mid-2015 MBP 2.2 GHz i7 16 Gb RAM
512 Gb Flash Drive - OS X 10.14.6
Reply With Quote
  #6  
Old 08-06-2022, 09:02 PM
Ben Jenssen's Avatar
Ben Jenssen Ben Jenssen is online now
Member
 
Join Date: May 2000
Location: Oslo
Posts: 4,664
Default Re: First experience with NVMe M.2 in enclosure - bad.

Quote:
Originally Posted by Sugarnutz View Post
I have one of these that works well on my 2015 rMBP and even better on my i9 PC with Thunderbolt 3, comes with both cables.

SSK Aluminum M.2 NVME SSD Enclosure

Ordered this on today for my sample libraries on the rMBP that I just got PT 2022.7 on along with a new WD 1TB NVMe drive.

SSK Aluminum USB C to M.2 NVMe SSD Tool-Free Enclosure Reader

I’ve got another one of the SSK enclosures for a 512Gb M.2 SATA drive I’ve been using without issue.

I would suggest the 1st link at the top because it comes with thermal material, not sure about the 2nd as someone said the 2nd linked item just relied on drive to housing and getting very hot.
I'm talking about true Thunderbolt 3 enclosure. Some say they're 'Thunderbolt 3 compatible' but they are limited in speed. Price difference is also very noticeable.
Speed difference is up to 4:1 in my experience, in favour of thunderbolt vs pci-e sata.
__________________
Life-long audio enthusiast and small studio owner. Retired.
Mac Mini M1, 16GB RAM. 512GBinternal(3000MB/s),2TB(1300MB/s),2TB(350MB/s)
MacOS 11.6.8. PT 2020.12.1 (Reinstatement on hold for M3 macs and AS native PT)
Topping D50 DAC, Dynaudio BM6p, Artist Mix, SSL UC1, EuControl on iPad.

Last edited by Ben Jenssen; 08-06-2022 at 09:16 PM.
Reply With Quote
  #7  
Old 08-06-2022, 09:45 PM
Darryl Ramm Darryl Ramm is online now
Member
 
Join Date: Nov 2010
Location: USA
Posts: 16,674
Default Re: First experience with NVMe M.2 in enclosure - bad.

Quote:
Originally Posted by Sugarnutz View Post
I have one of these that works well on my 2015 rMBP and even better on my i9 PC with Thunderbolt 3, comes with both cables.

SSK Aluminum M.2 NVME SSD Enclosure

Ordered this on today for my sample libraries on the rMBP that I just got PT 2022.7 on along with a new WD 1TB NVMe drive.

SSK Aluminum USB C to M.2 NVMe SSD Tool-Free Enclosure Reader

I’ve got another one of the SSK enclosures for a 512Gb M.2 SATA drive I’ve been using without issue.

I would suggest the 1st link at the top because it comes with thermal material, not sure about the 2nd as someone said the 2nd linked item just relied on drive to housing and getting very hot.
As Ben points out these are all USB enclosures and will run slower than a Thunderbolt enclosure.

--

All these small passively cooled enclosures may show thermal throttling effects if you are throwing sustained workloads at them, but then most Pro Tools users don't do that so these may never suffer from that.

OTOH if you are on Mac and want the lowest cost way of getting access to fast SSD performance a single modern M.2 drive in a single slot carrier on a Thunderbolt 3/4 bus is a good choice. I go a different route with multiple M.2 cards in a PCIe expansion chassis, better sustained cooling and have too many M.2 drives and too few Thunderbolt busses.
Reply With Quote
  #8  
Old 08-06-2022, 10:01 PM
Ben Jenssen's Avatar
Ben Jenssen Ben Jenssen is online now
Member
 
Join Date: May 2000
Location: Oslo
Posts: 4,664
Default Re: First experience with NVMe M.2 in enclosure - bad.

Thanks, Darryl.
One question: don't you think that my experience with the drive ejecting and becoming unusable until refomated is due to something else than overheating?
Just thought I'd ask.

Added: I had the drive copying for more than an hour. I did this several times. It became hot for shure, but worked fine. I let it cool a bit, and with the next copy it failed and ejected. I therefore think it is not the temperature but the size of occupied space. Everytime. one third of the drive space, then crash, eject. Unreadable.

I actually tried HFS+ with four 500gb partitions. I filled up the first partition with 400gb, then started to copy data to the 2nd partition; very soon: crash.

Seems to me thhat it's something to do with data more than temperature.
__________________
Life-long audio enthusiast and small studio owner. Retired.
Mac Mini M1, 16GB RAM. 512GBinternal(3000MB/s),2TB(1300MB/s),2TB(350MB/s)
MacOS 11.6.8. PT 2020.12.1 (Reinstatement on hold for M3 macs and AS native PT)
Topping D50 DAC, Dynaudio BM6p, Artist Mix, SSL UC1, EuControl on iPad.

Last edited by Ben Jenssen; 08-06-2022 at 10:19 PM.
Reply With Quote
  #9  
Old 08-07-2022, 12:11 AM
Darryl Ramm Darryl Ramm is online now
Member
 
Join Date: Nov 2010
Location: USA
Posts: 16,674
Default Re: First experience with NVMe M.2 in enclosure - bad.

I don't have experience with your drive (I'm a Samsung Pro M.2 and WD Black M.2 guy). And I avoid any reliance on these small individual enclosures by using Sonnet PCIe expansion chassis (you pay $$$ for Sonnet quality/know how) but with largely dumb PCIe to M.2 adapter cards (just no smarts there at all so a $15 adapter card from low-cost brands like IO Crest or Startech works great, unlike these single slot adapters that have more smarts in them to go Thunderbolt to PCIe and therefore a trusted brand name is likely worth looking for).

I would be surprised if it is overheating. Modern M.2 drives are very good at detecting temperature and throttling performance. But I also can't see if your enclosure has any air vents, the plastic case with no vents even with the heatsink might be a silly design, especially because the controller chips on the M.2 drives get hot, and it's not clear that the heatsink and thermal pad cover that well in this case. Still there are enough single M.2 aluminum enclosures with seemingly good case thermal bonding and some venting. And since the enclosure is suspect I think you are already replacing it.

The way to tell if there are problems is to watch the drive temp, Mac utilities like iStats make it very easy to show/record M.2 drive temps, including those attached via Thunderbolt. My M.2 drives float around a very low 38C much of the time and surprisingly not much more if pushed, they have heatsinks on them and are in a Sonnet Echo Express SE IIIe case with it's very quiet fan. It's spectacular how cool they run. If you start seeing over 70C you likely have issues you want to fix, (separate from any disconnecting).
Reply With Quote
  #10  
Old 08-07-2022, 12:19 AM
Ben Jenssen's Avatar
Ben Jenssen Ben Jenssen is online now
Member
 
Join Date: May 2000
Location: Oslo
Posts: 4,664
Default Re: First experience with NVMe M.2 in enclosure - bad.

Thanks.
__________________
Life-long audio enthusiast and small studio owner. Retired.
Mac Mini M1, 16GB RAM. 512GBinternal(3000MB/s),2TB(1300MB/s),2TB(350MB/s)
MacOS 11.6.8. PT 2020.12.1 (Reinstatement on hold for M3 macs and AS native PT)
Topping D50 DAC, Dynaudio BM6p, Artist Mix, SSL UC1, EuControl on iPad.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
External SSD/NVMe recommendations? reichman Post - Surround - Video 17 05-10-2022 09:17 AM
NVMe upgrade for Mac Pro 4.1/5.1 Mojave mcnichols Pro Tools 2019 238 01-05-2022 06:35 AM
Mac Pro 5,1 Cost effective NVMe SSD drives Howardk Pro Tools HDX & HD Native Systems (Mac) 12 12-23-2020 11:18 PM
New 8th Gen i7 with NVMe m.2 SSD spock999 Pro Tools 2018 26 02-22-2018 11:47 PM
Intel SSD NVME/PCIe Porn Darryl Ramm General Discussion 0 04-03-2015 02:02 PM


All times are GMT -7. The time now is 08:15 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com