Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 12-30-2021, 02:03 AM
LukeT LukeT is offline
Member
 
Join Date: Dec 2021
Location: Serbia
Posts: 4
Default Re: Issues with installing Mbox 1 drivers

USB ASIO driver 2.8.40 works on windows 10.There was a video on youtube explaining it,but it was deleted recently.You dont have link for that driver?
Reply With Quote
  #12  
Old 12-30-2021, 07:58 AM
Ben Jenssen's Avatar
Ben Jenssen Ben Jenssen is online now
Member
 
Join Date: May 2000
Location: Oslo
Posts: 4,669
Default Re: Issues with installing Mbox 1 drivers

Quote:
Originally Posted by Ben Jenssen View Post
I had a original mbox on a Lion OS mac running a few years after its end of support, by using a 3rd party driver from these guys:
Usbaudio

I think they still have it and you can get a demo.

But of course, put a little extra money in and get a modern interface. They sound SO much better these days.
I quote myself from earlier in this thread.
You could try the demo. It's on the downloads page.
This driver isn't free.
__________________
Life-long audio enthusiast and small studio owner. Retired.
Mac Mini M1, 16GB RAM. 512GBinternal(3000MB/s),2TB(1300MB/s),2TB(350MB/s)
MacOS 11.6.8. PT 2020.12.1 (Reinstatement on hold for M3 macs and AS native PT)
Topping D50 DAC, Dynaudio BM6p, Artist Mix, SSL UC1, EuControl on iPad.
Reply With Quote
  #13  
Old 01-02-2022, 08:35 AM
albee1952's Avatar
albee1952 albee1952 is offline
Member
 
Join Date: May 2004
Location: Norwich, CT
Posts: 38,298
Default Re: Issues with installing Mbox 1 drivers

Heh...haven't you guys heard that these old vintage preamps are now back in vogue
__________________
Gigabyte X79/intel i7 3930K, 32GB RAM, HD/Native, 192 IO
https://www.facebook.com/search/top/...0sound%20works


The better I drink, the more I mix

BTW, my name is Dave, but most people call me.........................Dave
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mbox Pro Drivers not installing metameric FireWire & USB Audio Interfaces (Win) 2 07-31-2015 08:20 AM
Pro Tools 10 does not open after installing MBox 2 drivers brady_d79 macOS 2 10-17-2012 08:51 PM
Re-installing MBox Drivers Gabriel_S 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 0 10-05-2010 11:26 PM
MBOX: Install freezes when installing drivers suojuoksija 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 6 01-28-2007 12:06 PM
Installing mbox asio drivers freezes the computer lazymark 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 0 06-05-2005 07:01 AM


All times are GMT -7. The time now is 03:34 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com