Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > ICON & C|24

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 02-04-2004, 06:56 PM
pmklein pmklein is offline
Member
 
Join Date: Jun 2000
Location: NY, NY
Posts: 548
Default C24 Failure

If the C24 was an automoblile it would have been recalled for its faulty power supply. This is a known problem by Digidesign's own admittance. I became a victim of this plague today as my C24 emitted two explosive POP!s and the faders ceased to move. When I called tech support I was informed very matter of factly that this is a known problem and I would have to have the power supply replaced. Since Digidesign is obviously aware of this problem, they should post a warning on the website with clear instructions for a remedy for owners of units with the possibly faulty power supplies. Buyer beware.

Not happy.
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CS3 Failure Wyn 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 13 07-30-2009 10:19 AM
Another c24 failure dsd_studios ICON & C|24 0 05-21-2004 11:53 AM
C24 failure AGAIN!!!! Brimmy ICON & C|24 1 05-06-2003 01:25 PM
Cause for DSP failure? Peter Duemmler General Discussion 1 09-07-2001 06:16 PM
Boot failure- Mac OS ROM checksum failure...SCSI shaggy Pro Tools TDM Systems (Mac) 11 06-23-2000 03:30 PM


All times are GMT -7. The time now is 09:06 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com