Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools 10

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-23-2014, 05:35 PM
tj7's Avatar
tj7 tj7 is offline
Member
 
Join Date: Jun 2006
Posts: 194
Default Avid staff - have some courtesy and advise if pt10 will be supported under os 10.9

Please.

Seriously, Avid staff / mods - it either will or it won't.

All we want is to KNOW EITHER WAY.

One sentence, one post will be all it takes.

A little courtesy is basically zero effort on your behalf but will help MANY of us make important decisions.

Forum members - please don't turn this into yet another discussion thread - I'm requesting Avid to finally TELL us what's happening. The discussion thread is here:
http://duc.avid.com/showthread.php?t=347549&page=10

Last edited by tj7; 03-23-2014 at 09:39 PM. Reason: Forgot to say "please"
Reply With Quote
  #2  
Old 03-24-2014, 12:46 AM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 21,265
Default Re: Avid staff - have some courtesy and advise if pt10 will be supported under os 10.

We the Mods have been pushing the Super-Mods for answering this, and the Super-Mods are keeping this issue alive in every Avid meeting, as far as I know.

My assumption is that there will never be PT10 support for Mavericks, but because Avid hasn't said anything, that is just an assumption.

I'm sorry that you feel bad about this, but there are plenty of others who feel just the same.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #3  
Old 03-24-2014, 08:29 AM
Eric Lambert's Avatar
Eric Lambert Eric Lambert is online now
Member
 
Join Date: Dec 1969
Location: Los Angeles
Posts: 3,025
Default Re: Avid staff - have some courtesy and advise if pt10 will be supported under os 10.

It's not an issue of courtesy, it's an issue of profit. Why would they spend money to support a version of PT you already own and paid for when you can be pushed into upgrading at a cost?
Reply With Quote
  #4  
Old 03-24-2014, 10:12 AM
Logichead Logichead is offline
Member
 
Join Date: Mar 2004
Posts: 433
Default Re: Avid staff - have some courtesy and advise if pt10 will be supported under os 10.

As far as profit goes, I'd suggest Avid take a "long term" approach to dealing with their customers on these matters. It may also be too late - i.e.., not enough resources left to do this sort of thing. If so, not a good sign.

FWIW, I have just set up a Mavericks partition (have a client that sent me a session in Logic X, so I had to move away from Snow Leopard). Even though I couldn't uninstall ProTools, so I just trashed everything I could find and installed the latest version. So far, so good. Color me shocked!

Also, I was extremely surprised by Logic X. Sounds great, easy on system resources, simplified controls, cheap. I abandoned Logic years ago but this new version is very impressive.

Best…H
Reply With Quote
  #5  
Old 03-25-2014, 06:17 PM
joey8989896 joey8989896 is offline
Member
 
Join Date: Jun 2011
Location: United States
Posts: 14
Default Re: Avid staff - have some courtesy and advise if pt10 will be supported under os 10.

Kinda makes me sick to my stomach because they have created a compatibility hole that I am stuck in. I have a new mavericks computer with tons of rtas plugins! every day avid doesn't do something about it I think more and more about going to logic.
Reply With Quote
  #6  
Old 03-25-2014, 06:20 PM
YYR123's Avatar
YYR123 YYR123 is offline
Member
 
Join Date: Dec 2010
Location: Austin TX
Posts: 13,739
Default Re: Avid staff - have some courtesy and advise if pt10 will be supported under os 10.

Adapt overcome survive
__________________
Daniel
HDX - PT12.5.1 - HD I/O 16x8x8
Win10-Pro (v1709)- 6 Core i7-6850k - ASUS X99 Deluxe ii
D-Command Main Unit - 'Ole Blue


http://www.sknoteaudio.com/ plugins rock and are affordable.
Reply With Quote
  #7  
Old 03-25-2014, 06:21 PM
YYR123's Avatar
YYR123 YYR123 is offline
Member
 
Join Date: Dec 2010
Location: Austin TX
Posts: 13,739
Default Re: Avid staff - have some courtesy and advise if pt10 will be supported under os 10.

I'll build you a killa rig with 10.8 on it
__________________
Daniel
HDX - PT12.5.1 - HD I/O 16x8x8
Win10-Pro (v1709)- 6 Core i7-6850k - ASUS X99 Deluxe ii
D-Command Main Unit - 'Ole Blue


http://www.sknoteaudio.com/ plugins rock and are affordable.
Reply With Quote
  #8  
Old 03-26-2014, 05:24 AM
Fidelis Fidelis is offline
Member
 
Join Date: May 2001
Location: Sao Paulo - Brazil
Posts: 988
Default Re: Avid staff - have some courtesy and advise if pt10 will be supported under os 10.

Guys, it won't happen.

If you want co-install of 10 and 11 you must be on 10.8

That's what I did.
__________________
http://www.ricardomosca.com

Intel Mac Pro 12 core 3.33 GHz, 48GB RAM, OSX 10.13.6, PT HDX, PT 2020.9.1, SSL 4040G+, tons of outboard
Mac Book Pro 2019 2.4Ghz i5, 16GB RAM, OSX 10.14.6, PT Vanilla 2020.9.1
Reply With Quote
  #9  
Old 03-26-2014, 05:26 AM
Bill Denton Bill Denton is offline
Member
 
Join Date: Oct 2008
Location: Pittsburgh PA
Posts: 2,644
Default Re: Avid staff - have some courtesy and advise if pt10 will be supported under os 10.

Quote:
Originally Posted by joey8989896 View Post
Kinda makes me sick to my stomach because they have created a compatibility hole that I am stuck in. I have a new mavericks computer with tons of rtas plugins! every day avid doesn't do something about it I think more and more about going to logic.
Yeah...those Avid b*stards...

They all, equipped with the full "24" Invasion Packs, loaded up in black Chevy Suburban's, and snuck down to Cupertino via isolated back roads.

Then, the Avid guys, armed with their Invasion Packs, took over Apple, which the Apple guys were powerless to stop as they were armed only with their trusty iPhones, which are not much good against an AK or a 50 cal.

Then the Avid guys held the Apple guys at gunpoint and made them start installing Mavericks on every Mac leaving the building.

Just to screw up your life...

Now that is a fairy tale to be proud of!

In reality, Apple put out Mavericks on their schedule...all Avid can do is react to what Apple does...Avid probably had little to no input on Apple's schedule.

So, the people you should be pissed off at is Apple, not Avid...It was Apple that changed the OS.
__________________
X
Note that all opinions, observations, whatever, in this post are mine, unless I'm being mean or am wrong, in which case it's somebody else's fault. I do not work for Avid (their loss)...my only relationship with Avid is that of a customer (when I'm not too poor to buy stuff, like now)...and that hot administrative assistant...that's more of a "thing" than a "relationship" (that should keep them guessing for a while...)

Just rockin'...what more is there?

Bill in Pittsburgh
Reply With Quote
  #10  
Old 03-26-2014, 05:41 AM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 21,265
Default Re: Avid staff - have some courtesy and advise if pt10 will be supported under os 10.

Yes it was Apple who changed the OS and yes you cannot for example install Mountain Lion on a current MBP which forces you to either use Mavericks or use old hardware to be able to run Mountain Lion. That is Apple's thing and I'm sure there will never be such a version of Mountain Lion that can be installed on a current MBP, that's just the way it is. Apple sold its last PCI-express Mac Pro late 2013 so with AppleCare those host systems (that are capable of running Mountain Lion) are supported until late 2016. It's just that if you buy something new just for fun or if you really need to, you are FORCED to run Mavericks.

Avid on the other hand touted that PT10/11 co-install is the bridge between the old and the new. And it is, no doubt about it. But what that announcement made me think was "PT10 will be supported with whatever OSX version until there is PT12 and we can all forget about the whole PT10/11 co-install thing".

Now that is where people rightfully think that Avid has failed. Or at least half-failed. I think most of us thought that way and that is the reason for feeling let down.

PT10 works on Mavericks (thank God for it) but its uninstaller doesn't, and because there is no official support, there is no commitment to bugfixes either. So if you have any kind of trouble, you need to clean-install Mavericks, install the latest version of PT10 and PT11 and all your plugins, and it *should* work -- but you're self-supporting and (while that's the thing I've been doing for the last +10 years) it isn't good.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AVID staff please help with this question??? TruestPain Pro Tools 10 16 04-25-2013 05:02 PM
Fades now supported on Elastic tracks in PT10? Farmer Dave Pro Tools 10 3 02-26-2012 09:11 PM
Is 003 Factory not supported in PT9 and PT10? digidesigner 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 7 01-03-2012 08:00 AM
003 quits Pro Tools 9.0.3, please avid staff.. filmsound_no macOS 3 09-10-2011 02:03 AM
Win A Free Music Production Toolkit Courtesy of AVID and the AIR Users Blog sunburst79 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 1 09-03-2009 05:48 PM


All times are GMT -7. The time now is 02:41 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com