Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Virtual Instruments

Reply
 
Thread Tools Search this Thread Display Modes
  #41  
Old 11-30-2021, 07:23 PM
Markrosoft Markrosoft is offline
Member
 
Join Date: Jun 2011
Location: Brooklyn, NY
Posts: 55
Default Re: MIDI notes out of sync caused by Delay Compensation?

Happens with all controllers (I have used 5) and they connect via usb (one connects w midi via a MIO).

It doesn’t happen in other DAWs with any of these controllers. It has nothing to do w my controller.

This is a universal problem w pro tools and doesn’t happen with any other DAW.

None of your thoughts address the issue: when I record, the playing is in time. I have recorded the audio to show that. But the midi notes get moved up - too early. The amount varies randomly but does varies depending on buffer size.

Do you record midi in Pro Tools? If you do, do you experience this issue? If you don’t, I’m not sure why you’re chiming in with thoughts that don’t address the issue but dismiss it as non-existent or some artifact of virtual instruments in general.
Reply With Quote
  #42  
Old 11-30-2021, 07:51 PM
spinsong spinsong is offline
Member
 
Join Date: Jun 2004
Location: NY.NY
Posts: 197
Default MIDI notes out of sync caused by Delay Compensation?

Your midi is coming in through a cheap interface. get a higher end one and see what happens. Some of these problems are hardware based. I’ve had various versions of protools and never had that problem. It’s probably an issue with one of your settings. Also, did you consider checking your delay compensation.
The other problem would be with your workflow. Why would you record midi and audio simultaneously, if not to edit it later.

Sent from my iPad using Tapatalk
__________________
spinsong.com
Reply With Quote
  #43  
Old 11-30-2021, 08:13 PM
Markrosoft Markrosoft is offline
Member
 
Join Date: Jun 2011
Location: Brooklyn, NY
Posts: 55
Default Re: MIDI notes out of sync caused by Delay Compensation?

The midi is coming in via USB directly from high end midi controllers? I have an HD | Omni as an interface.

I've tried one controller that has midi output through a mio, as a test. That doesn't affect the issue -- neither makes it worse or better. All the others are plugged into the computer via USB. It happens with all controllers no matter how I connect them.

And I'll repeat: THIS IS NOT A PROBLEM IN OTHER DAWS. So this has nothing to do with controllers or the nature of virtual instruments. This has nothing to do with a "cheap interface."

I have "checked delay compensation" (as have other people in this thread). I've turned it on and off. I've turned low latency monitoring on and off. I've turned ignore errors on and off. None of that changes it.

THIS IS A BUG WITH PRO TOOLS.

If you want to try to replicate it and see that it's NOT happening at your end, that would be useful. Other people on this thread are experiencing the exact same issue as me and no one, including you, has said they are NOT experiencing the issue.

Is there anyone out there that is NOT experiencing this issue? That would be helpful to know.
Reply With Quote
  #44  
Old 12-01-2021, 03:48 AM
XJENSEN XJENSEN is offline
Member
 
Join Date: Dec 2004
Location: Gent, Belgium, Europe
Posts: 427
Default Re: MIDI notes out of sync caused by Delay Compensation or something else?

These are all known issues and have been reported to AVID ages ago.

I understand your aggravation, but sadly, there's nothing much you'll be able to do about it. I went through all of this a few years back and took my conclusions.

Best advice I can give is to let this go and start using another application to do your work. You may or may not keep Pro Tools to do some mixing work, after the creative process is done.
Reply With Quote
  #45  
Old 12-01-2021, 06:47 AM
Markrosoft Markrosoft is offline
Member
 
Join Date: Jun 2011
Location: Brooklyn, NY
Posts: 55
Default Re: MIDI notes out of sync caused by Delay Compensation?

Thanks for your reply XJENSEN -- I didn't realize this was widely known and acknowledge. Has Avid acknowledged it?

I guess I had intuited the issue for years now but am so frustrated because of the countless hours I wasted playing something and then listening back to it thinking "man, it sounded so much better when I played it... I guess I'll do another take..." OVER AND OVER AND OVER. Such a waste of time and so many good performances lost...

Moving forward, it does seem like it's time to learn Logic. I am shocked that this is known issue within Avid. This feels like a top priority issue to fix and if they know about it, they really should warn people: your midi will get slid up significantly & randomly but affected how big your HW Buffer is after you record. The notes will not land where you played them and where you heard them while recording.

If they had at least acknowledged it, I wouldn't have wasted countless hours and music I created would have sounded much much better. Really frustrating. So frustrating I think I'm done paying for my HD license each year.
Reply With Quote
  #46  
Old 12-06-2021, 03:23 PM
spinsong spinsong is offline
Member
 
Join Date: Jun 2004
Location: NY.NY
Posts: 197
Default MIDI notes out of sync caused by Delay Compensation?

I had to replace a midi cable, but as you can see, no problems.



Sent from my iPad using Tapatalk
__________________
spinsong.com

Last edited by spinsong; 12-06-2021 at 03:35 PM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pro Tools 11 Sync issues, OMF's and delay compensation RedEyeJedi Post - Surround - Video 20 11-06-2016 06:56 PM
Keeping Laybacks in Sync (delay compensation and Video sync offset) edit machine Pro Tools TDM Systems (Mac) 6 11-15-2010 12:33 PM
Delay Compensation and sync io seanob99 Pro Tools TDM Systems (Mac) 1 03-13-2008 07:44 PM
Delay compensation and Sync TLmix Post - Surround - Video 3 01-09-2006 09:31 AM
Lip sync and delay compensation? Erik Olsson Post - Surround - Video 0 09-13-2005 08:20 AM


All times are GMT -7. The time now is 07:32 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com