Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > Pro Tools | Carbon

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-09-2021, 09:24 AM
alhardy alhardy is offline
Member
 
Join Date: Mar 2003
Location: Rome Italy
Posts: 64
Default Hardware insert big issues!! (delay compensation and gain)

Using Carbon with Hardware inserts I ran into 2 issues.

1) If I insert a Hardware on a track I get a 10,4 dB increase
(obviously true bypassing the hardware, or even just patching a cable on carbon line in/out )

2) Delay compensation is not working properly

To test it:

I just duplicated a snare track

-On one track I put a hardware insert
(with -10,4 dB trim to compensate for the gain discrepancy)

-On the duplicate track I just reversed the phase with a trim plugin


They should null but they don't (far from it)


Tweaking with time adjuster I found out that:

1)the track with the hardware I/O insert is 7 samples ahead if in DSP mode

2)The same track is 699 samples ahead if NOT in DSP mode





This was on a Macbook pro 2017 i7 Catalina

Mac mini m1 has identical results, bu the track with the hardware I/O active is 580 samples behind (NOT in DSP mode)



Long time protools 8HD user, I never had any issue with delay compensating parallel hardware inserts.
This is a little disappointing, since the Carbon is marketed as a pro machine, and costs like one.
__________________
Alberto Lombardi
Carbon - Pro Tools
Mac Mini M1
Ferrofish 16 I/O

www.albertolombardi.com

facebook - instagram - youtube

Last edited by alhardy; 03-10-2021 at 07:41 AM.
Reply With Quote
  #2  
Old 03-09-2021, 12:17 PM
albee1952's Avatar
albee1952 albee1952 is offline
Member
 
Join Date: May 2004
Location: Norwich, CT
Posts: 37,850
Default Re: Hardware insert big issues!! (delay compensation and gain)

Hmmm, all I have to offer are my thoughts on this:
1), if the volume is radically different, adjust the output of the hardware. If you want to discuss hardware, discuss the exact hardware you have(in case others have experience with that same hardware).

2), Delay Compensation is not automatic with hardware inserts(there is a setup page in IO setup for entering the proper compensation time for your specific hardware)

3), re the null test, signals will never null in this scenario. Adding a piece of hardware in the chain will never null, and should not be expected to.

Don't get me wrong here, I love hardware as much as anybody! But I recognized the issues and limitations and simply made a decision(years ago) to use my hardware in the recording chain, and mix 100% in the box. This is even after dropping several hundred dollars on a new tt patchbay, another 192 and all the required cabling. Consider your "needs" over your "wants"
__________________
Gigabyte X79/intel i7 3930K, 32GB RAM, HD/Native, 192 IO
https://www.facebook.com/search/top/...0sound%20works


The better I drink, the more I mix

BTW, my name is Dave, but most people call me.........................Dave
Reply With Quote
  #3  
Old 03-09-2021, 12:32 PM
alhardy alhardy is offline
Member
 
Join Date: Mar 2003
Location: Rome Italy
Posts: 64
Default Re: Hardware insert big issues!! (delay compensation and gain)

I'm sorry but you don't understand.

Not running into any hardware, just out of the Carbon and back into it.

Delay compensation IS an automatic process and works like a charm on my HD system.





Quote:
Originally Posted by albee1952 View Post
Hmmm, all I have to offer are my thoughts on this:
1), if the volume is radically different, adjust the output of the hardware. If you want to discuss hardware, discuss the exact hardware you have(in case others have experience with that same hardware).

2), Delay Compensation is not automatic with hardware inserts(there is a setup page in IO setup for entering the proper compensation time for your specific hardware)

3), re the null test, signals will never null in this scenario. Adding a piece of hardware in the chain will never null, and should not be expected to.

Don't get me wrong here, I love hardware as much as anybody! But I recognized the issues and limitations and simply made a decision(years ago) to use my hardware in the recording chain, and mix 100% in the box. This is even after dropping several hundred dollars on a new tt patchbay, another 192 and all the required cabling. Consider your "needs" over your "wants"
__________________
Alberto Lombardi
Carbon - Pro Tools
Mac Mini M1
Ferrofish 16 I/O

www.albertolombardi.com

facebook - instagram - youtube
Reply With Quote
  #4  
Old 03-09-2021, 02:01 PM
Darryl Ramm Darryl Ramm is offline
Member
 
Join Date: Nov 2010
Location: USA
Posts: 15,906
Default Re: Hardware insert big issues!! (delay compensation and gain)

It's a bit hard to follow your description.

You did make it sound like you had hardware, but all your tests are just with cables? And you are inverting the phase on one by using a cross over cable?

I don't know what you mean by "track with I/O active".
Reply With Quote
  #5  
Old 03-09-2021, 03:22 PM
alhardy alhardy is offline
Member
 
Join Date: Mar 2003
Location: Rome Italy
Posts: 64
Default Re: Hardware insert big issues!! (delay compensation and gain)

I'll try to make it clearer

To test if delay compensation is working properly you usually do this:

take a track, duplicate it

On one track do nothing
on the second put a trim plugin and invert the phase.

hit play

If delay compensation works fine you should hear nothing (and this works)

Now take a cable from line output 1 and patch it back to line input 1
On one of the 2 tracks insert H/W line 1
No hardware patched, just a cable in/out

If delay compensation works fine you should hear nothing

This last step works perfectly on my HD system,
it's supposed to be working on the carbon, but doesn't

I do parallel compression and eq so I need tracks with hardware inserts to align perfectly without or phase will kill me.
__________________
Alberto Lombardi
Carbon - Pro Tools
Mac Mini M1
Ferrofish 16 I/O

www.albertolombardi.com

facebook - instagram - youtube
Reply With Quote
  #6  
Old 03-11-2021, 12:05 PM
Kyle Splittgerber's Avatar
Kyle Splittgerber Kyle Splittgerber is offline
Avid
 
Join Date: Nov 2013
Location: CA
Posts: 565
Default Re: Hardware insert big issues!! (delay compensation and gain)

Quote:
Originally Posted by alhardy View Post
I'll try to make it clearer

To test if delay compensation is working properly you usually do this:

take a track, duplicate it

On one track do nothing
on the second put a trim plugin and invert the phase.

hit play

If delay compensation works fine you should hear nothing (and this works)

Now take a cable from line output 1 and patch it back to line input 1
On one of the 2 tracks insert H/W line 1
No hardware patched, just a cable in/out

If delay compensation works fine you should hear nothing

This last step works perfectly on my HD system,
it's supposed to be working on the carbon, but doesn't

I do parallel compression and eq so I need tracks with hardware inserts to align perfectly without or phase will kill me.
Hi Alberto,

Sorry to hear about these delay compensation issues. There were a few bugs that slipped through the cracks in this area which should be resolved with the next Pro Tools release. I can't give an exact release date on that, but it will be soon. So, if you can hold out a bit longer these should be fixed for you.

Thanks,

Kyle
__________________
Kyle Splittgerber
Senior Principal Product Designer
Avid
Berkeley, CA
Reply With Quote
  #7  
Old 03-12-2021, 07:42 AM
alhardy alhardy is offline
Member
 
Join Date: Mar 2003
Location: Rome Italy
Posts: 64
Default Re: Hardware insert big issues!! (delay compensation and gain)

Quote:
Originally Posted by Kyle Splittgerber View Post
Hi Alberto,

Sorry to hear about these delay compensation issues. There were a few bugs that slipped through the cracks in this area which should be resolved with the next Pro Tools release. I can't give an exact release date on that, but it will be soon. So, if you can hold out a bit longer these should be fixed for you.

Thanks,

Kyle

Thanks Kyle, it's a brand new product so it's understandable.
I also filed a case to support, mentioning the behavior changes from DSP enabled to not DSP. Hope that helps.

PS: any clue on Big Sur / M1 support?
__________________
Alberto Lombardi
Carbon - Pro Tools
Mac Mini M1
Ferrofish 16 I/O

www.albertolombardi.com

facebook - instagram - youtube
Reply With Quote
  #8  
Old 03-12-2021, 08:14 AM
Kyle Splittgerber's Avatar
Kyle Splittgerber Kyle Splittgerber is offline
Avid
 
Join Date: Nov 2013
Location: CA
Posts: 565
Default Re: Hardware insert big issues!! (delay compensation and gain)

Quote:
Originally Posted by alhardy View Post
Thanks Kyle, it's a brand new product so it's understandable.
I also filed a case to support, mentioning the behavior changes from DSP enabled to not DSP. Hope that helps.

PS: any clue on Big Sur / M1 support?
Thanks for your patience, Alberto.

Unfortunately, I can't share any dates for Big Sur/M1 support yet. But, I can say work is in progress on it.
__________________
Kyle Splittgerber
Senior Principal Product Designer
Avid
Berkeley, CA
Reply With Quote
  #9  
Old 12-19-2021, 04:40 PM
pi-town pi-town is offline
Member
 
Join Date: Dec 2021
Location: California
Posts: 28
Default Re: Hardware insert big issues!! (delay compensation and gain)

Quote:
Originally Posted by albee1952 View Post
Don't get me wrong here, I love hardware as much as anybody! But I recognized the issues and limitations and simply made a decision(years ago) to use my hardware in the recording chain, and mix 100% in the box. This is even after dropping several hundred dollars on a new tt patchbay, another 192 and all the required cabling. Consider your "needs" over your "wants"
Ooof, thank you for talking some sense into me.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HD Native vs HDX hardware insert delay compensation? MixerGuy Pro Tools HDX & HD Native Systems (Mac) 2 08-14-2018 06:56 PM
delay compensation for H/W insert bbtheking987 Pro Tools 11 5 04-04-2017 07:36 AM
H/W insert delay compensation issues with RME converters katerkarlo Pro Tools 12 18 02-22-2017 02:33 AM
Hardware insert delay compensation fail. winvbass Windows 3 10-27-2014 02:51 PM
Pro Tools 9 Hardware Insert Delay Compensation with Lynx AES16e and Aurora 16 SolutionRoom macOS 0 04-08-2011 10:54 AM


All times are GMT -7. The time now is 05:55 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com