Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Pro Tools

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-15-2021, 10:36 PM
drumbreaker drumbreaker is offline
Member
 
Join Date: Nov 2021
Location: Los Angeles
Posts: 11
Default Avid Complete Plugin Bundle - Monterey Compatibility

Forgive me if there is a thread that has an answer already, but after searching here not finding much info other than confirmation...

Avid Complete Plugin Bundle does not work on Monterey. Is there any discussion anywhere from Avid on when this will be fixed?

Thanks
Reply With Quote
  #2  
Old 11-15-2021, 10:44 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 22,976
Default Re: Avid Complete Plugin Bundle - Monterey Compatibility

Probably at the time when Monterey is supported. Currently it is not.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #3  
Old 11-16-2021, 12:30 AM
drumbreaker drumbreaker is offline
Member
 
Join Date: Nov 2021
Location: Los Angeles
Posts: 11
Default Re: Avid Complete Plugin Bundle - Monterey Compatibility

Thanks for the reply Janne. We will be waiting! Cheers from LA to Finland
Reply With Quote
  #4  
Old 11-16-2021, 12:31 AM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 22,976
Default Re: Avid Complete Plugin Bundle - Monterey Compatibility

Quote:
Originally Posted by drumbreaker View Post
Thanks for the reply Janne. We will be waiting! Cheers from LA to Finland
Thanks. It is fridge temperatures here now
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #5  
Old 12-08-2021, 05:08 PM
drumbreaker drumbreaker is offline
Member
 
Join Date: Nov 2021
Location: Los Angeles
Posts: 11
Default Re: Avid Complete Plugin Bundle - Monterey Compatibility

This seems to be a timely opportunity to chime in here. I imagine I'm not the only one that wants to smash my computer screen after downloading the latest PT and being prompted to remove my incompatible complete bundle to the Unused Plugins folder!

My question now is has anyone seen any further info here on the DUC on what timeline we are looking at to get the complete bundle to work on Monterey? Many of us use Complete Plugin Bundle in every session so we're still stuck on the old machine until they patch this.

Also has anyone discovered any workarounds to get these going temporarily on Monterey?

Cheers!
Reply With Quote
  #6  
Old 12-08-2021, 07:22 PM
BScout BScout is offline
Member
 
Join Date: Mar 2007
Location: Los Angeles, CA
Posts: 3,055
Default Re: Avid Complete Plugin Bundle - Monterey Compatibility

Quote:
Originally Posted by drumbreaker View Post
This seems to be a timely opportunity to chime in here. I imagine I'm not the only one that wants to smash my computer screen after downloading the latest PT and being prompted to remove my incompatible complete bundle to the Unused Plugins folder!

My question now is has anyone seen any further info here on the DUC on what timeline we are looking at to get the complete bundle to work on Monterey? Many of us use Complete Plugin Bundle in every session so we're still stuck on the old machine until they patch this.

Also has anyone discovered any workarounds to get these going temporarily on Monterey?

Cheers!
I did a pull on all the Pace Eden (iLok) versions of current plugin licenses on my system.
All the plugins in the Complete Bundle are on 5.0.0 GM.
All plugins that use 5.2.0 GM or later appear to be working.

Current version is 5.4.1 GM.

This may be the issue -- and there'd be no workaround for that. The plugins will need to be recompiled using a later Pace Eden wrapper.

I'll check again tomorrow on our Monterey test system if I can narrow down what Pace Eden version is the breakpoint. Just know Cargo Cult Spanner (5.2.1 GM) and PhoenixVerbSurround (5.2.0 GM) were working. But Stratus/Symphony do not and they are 5.0.2 GM.
__________________
Pro Tools Ult 2022.6, HDX 3, MTRX/SPQ, HD OmniS1 x 2, FireHD x 2, Dock, iPad Mac Pro 5,1 - 3.06 GHz 12 core - macOS 10.13.6RAM 64GB, SSD 4 x 2TB, GPU GTX 980 4GB
Reply With Quote
  #7  
Old 12-08-2021, 07:36 PM
off the wall's Avatar
off the wall off the wall is offline
Member
 
Join Date: May 2004
Location: NYC-NJ
Posts: 532
Default Re: Avid Complete Plugin Bundle - Monterey Compatibility

Quote:
Originally Posted by BScout View Post
I did a pull on all the Pace Eden (iLok) versions of current plugin licenses on my system.
All the plugins in the Complete Bundle are on 5.0.0 GM.
All plugins that use 5.2.0 GM or later appear to be working.

Current version is 5.4.1 GM.

This may be the issue -- and there'd be no workaround for that. The plugins will need to be recompiled using a later Pace Eden wrapper.

I'll check again tomorrow on our Monterey test system if I can narrow down what Pace Eden version is the breakpoint. Just know Cargo Cult Spanner (5.2.1 GM) and PhoenixVerbSurround (5.2.0 GM) were working. But Stratus/Symphony do not and they are 5.0.2 GM.
Why do the Avid Compete Bundle plugins work fine on PT 2021.12 under Big Sur and lower then? Is there a different version of PACE that is installed under Monterey?
__________________
offthewallproductions
Mac Pro 5,1 3.46 Ghz 12 core, Open Core 0.8.0 EFI, Radeon RX580 GPU, GC-TITAN RIDGE TB3 PCIe card, M.2 NVMe SSD boot drive on PCIe card, 48GB RAM, macOS 11.6.8
Pro Tools Ultimate 2022.7.0 HDX, UA Octo PCIe card in external TB3 chassis, MTRX Studio I/O, C|24 control surface.
Genelec 1031AP/7070A 5.1 monitoring.
Reply With Quote
  #8  
Old 12-08-2021, 08:00 PM
BScout BScout is offline
Member
 
Join Date: Mar 2007
Location: Los Angeles, CA
Posts: 3,055
Default Re: Avid Complete Plugin Bundle - Monterey Compatibility

Quote:
Originally Posted by off the wall View Post
Why do the Avid Compete Bundle plugins work fine on PT 2021.12 under Big Sur and lower then? Is there a different version of PACE that is installed under Monterey?
I believe this might have to do with the "user-mode" version of Pace. In essence, an Apple macOS restriction to prevent drivers from running at a lower level in the system as a security feature. Current iLok software could determine which mode it runs at once installed. So install on Big Sur, iLok runs at kernel-mode. Install on Monterey, kernel-mode fails so it runs as user-mode.

And if a plugin wasn't compiled with the user-mode ability (whenever that was released as part of the PACE Eden toolkit), it fails authourization on user-mode systems.

[This is all conjecture but seems to fit with what is observed. And I know Monterey restricts drivers]
__________________
Pro Tools Ult 2022.6, HDX 3, MTRX/SPQ, HD OmniS1 x 2, FireHD x 2, Dock, iPad Mac Pro 5,1 - 3.06 GHz 12 core - macOS 10.13.6RAM 64GB, SSD 4 x 2TB, GPU GTX 980 4GB
Reply With Quote
  #9  
Old 12-08-2021, 09:15 PM
drumbreaker drumbreaker is offline
Member
 
Join Date: Nov 2021
Location: Los Angeles
Posts: 11
Default Re: Avid Complete Plugin Bundle - Monterey Compatibility

Mods, would you please consider escalating this issue? At least to find out of a simple recompile with latest PACE would fix this? This simple issue is keeping many of us from being able to use our new machines. It would be highly appreciated! Thanks for your time
Reply With Quote
  #10  
Old 12-08-2021, 10:07 PM
Darryl Ramm Darryl Ramm is offline
Member
 
Join Date: Nov 2010
Location: USA
Posts: 16,407
Default Re: Avid Complete Plugin Bundle - Monterey Compatibility

Quote:
Originally Posted by drumbreaker View Post
Mods, would you please consider escalating this issue? At least to find out of a simple recompile with latest PACE would fix this? This simple issue is keeping many of us from being able to use our new machines. It would be highly appreciated! Thanks for your time
You must be new to Pro Tools? Do you not think Avid know that their DAW does not work on a whole new generation of Mac products and that's not kinda an issue for users? Hard even for Avid to miss this. They know, and will be working on it. And Avid being Avid, they will operate how they have for decades and you are very unlikely to hear any estimate of when fixes will happen. Complaining here or asking others to complain for you is not likely to change anything.

The transition to new Apple silicon is going to involve hassles, and this may just be start of some of the pain (wait until some but not all plugins start moving to native code).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Avid Complete Plugin Bundle renewal musicman691 Licensing & Accounts 4 04-23-2021 04:24 AM
Installation Avid complete plugin bundle [Résolue] Msim12 Le Forum en Français 9 07-07-2020 12:08 AM
Avid Complete Plugin Bundle Renewal Issues atticaaudio Licensing & Accounts 8 06-01-2020 03:02 PM
Avid Complete plugin bundle jesele Licensing & Accounts 3 02-06-2020 12:02 AM
Avid Complete Plugin Bundle / Fail to load Zergei AAX Plug-ins 1 03-16-2018 11:54 PM


All times are GMT -7. The time now is 12:22 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com