View Single Post
  #1  
Old 05-15-2021, 07:32 AM
Michael Carnes's Avatar
Michael Carnes Michael Carnes is offline
Development Partner
 
Join Date: Jun 2013
Location: Salt Lake Valley
Posts: 192
Default Old firmware for Sennheiser Ambeo Soundbar?

This seems like a reasonable place to ask this question. I've had an Ambeo SB01 soundbar for the better part of a year. It's done a reasonably decent job of giving me an Atmos experience in a family room where I don't want to hang more speakers. And it passes the spousal test nicely.

But about a month ago, it really started to get odd. The center channel dropped in level and overall balance is a little off. It's hard for me to imagine that it could be hardware-- HDMI is generally going to work or not--but I'm not going to rule in out completely. I'm feeding it from three sources--a DirecTV box, an AppleTV 4K and a Sony 4K Bluray. The problem seems to be worse with the Apple TV--which had performed very well. I'm strongly suspecting firmware. Both the Sennheiser and the Apple device had firmware updates recently, so I suppose it's easy to point fingers on which device is at fault. For now, I've had to turn off the Ambeo process.

Simple enough to rule out firmware if I could only take the Sennheiser back a revision or two. But (this is why I'm asking here) their support page is an absolute disaster. There may be a download page for older firmware, but they've done a good job of hiding it. I suspect their are a few film mixers here who have similar setups for the TV room, so I'm asking if this experience has been shared and if you've managed to find a solution.

I do get a little nervous about the sale of the Sennheiser consumer group to another company with no presence in the market. But it's clear they felt they couldn't support it themselves, so I'll just keep my fingers crossed. In the meantime, thanks!
Reply With Quote