Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Search Forums

Showing results 1 to 4 of 4
Search took 0.00 seconds.
Search: Posts Made By: bdale
Forum: Avid S1, S3, Dock and Control 05-10-2020, 07:42 PM
Replies: 67
Views: 11,272
Posted By bdale
Re: S1 knob always writing

FYI: Page 8 S1 User Guide:

6 Press the power switch on the back of the S1 to the “on” position. The faders jump and the LEDs blink during initialization.



there are no lights on the adapter...
Forum: Avid S1, S3, Dock and Control 05-09-2020, 05:06 PM
Replies: 67
Views: 11,272
Posted By bdale
Re: S1 knob always writing

I was a satisfied customer for a few weeks too before I realized what was going with the thing. I'm skeptical there are thousands of units functioning properly. Every professional I know that has...
Forum: Avid S1, S3, Dock and Control 05-09-2020, 03:59 PM
Replies: 67
Views: 11,272
Posted By bdale
Re: S1 knob always writing

It's completely unacceptable. I will have to make the social media rounds and warn our community not to be scammed by avid on this product since they have taken zero responsibility in letting their...
Forum: Avid S1, S3, Dock and Control 05-09-2020, 03:02 PM
Replies: 67
Views: 11,272
Posted By bdale
Re: S1 knob always writing

My S1 was replaced by AVID for this problem and the automation timeout issue and the replacement unit won't even show up in Eucontrol. A complete boat anchor. How horrible does a company have to be...
Showing results 1 to 4 of 4

 
Forum Jump

All times are GMT -7. The time now is 08:25 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com