Avid Pro Audio Community

Avid Pro Audio Community (https://duc.avid.com/index.php)
-   Avid S1, S3, Dock and Control App (https://duc.avid.com/forumdisplay.php?f=135)
-   -   Soft Keys No Longer Execute Keystrokes (https://duc.avid.com/showthread.php?t=404744)

aadvance 05-15-2019 04:14 PM

Soft Keys No Longer Execute Keystrokes
EDIT: I've found the Eucon commands for moving edit selections, but now when I program the below example as a soft key shortcut (e.g., moving selection up, muting the clip selected after moving up, then moving selection down), it only mutes the clip that was initially selected before initiating the soft key shortcut and completely ignores the command to move up. I had upwards of 20 soft keys programmed, and now only parts of these work. If I'm missing something please do point it out (EUCON is enabled in the Prefs).

After I upgraded EuControl to 19.5 my soft key shortcuts don't work, specifically my keystrokes, but functions that I programmed as EUCON commands still work fine.

Ctrl-P (Move edit selection up) => Cmnd-M (Mute selection) => Ctrl-; (Move edit selection down)

That sequence no longer works. I can use the EUCON command of Mute Clip as a replacement for the Cmnd-M keystroke, but I see no EUCON command for moving edit selection, so the other shortcuts never get done.

I can't go back to 18.3 because I also updated the PT Control app on my iPad, and conveniently the app no longer works with 18.3. I understand that doing the physical keyboard shortcuts still work fine, but I created that shortcut (amongst others that no longer work) so that I only have to press one button to have that entire sequence happen instantaneously. Please help!!

Mac Pro 6,1, OSX 10.14.4 Mojave
PT 2018.12
EuControl 19.5
Avid Artist Mix

aadvance 05-15-2019 05:17 PM

Re: Soft Keys No Longer Execute Keystrokes
Just tried a whole slew of keystrokes as soft keys, none work anymore, I can only program Eucon commands. Way to f*$& something else up Avid...

mattrixx 05-15-2019 06:18 PM

Re: Soft Keys No Longer Execute Keystrokes
Keystrokes are definitely working here.
Is the command focus on the correct window? Just a thought.

aadvance 05-15-2019 06:36 PM

Re: Soft Keys No Longer Execute Keystrokes
Where command focus is really wouldn't matter because entering the full keystroke should work regardless of where command focus is (ex: move edit selection up is just "p" with command focus on timeline, but Ctrl-p does the same thing regardless of where command focus is). All my soft keys had the full-on keystroke entered instead of just where command focus was, and now they don't work.

mattrixx 05-15-2019 06:39 PM

Re: Soft Keys No Longer Execute Keystrokes
Understood.. Mmm, mine are all working as they should. Chains of keystrokes etc.

BScout 05-15-2019 09:33 PM

Re: Soft Keys No Longer Execute Keystrokes
Working here.

Try a complete uninstall (using the installer's option for uninstall) and then reinstall of Eucontrol.

aadvance 05-16-2019 08:29 AM

Re: Soft Keys No Longer Execute Keystrokes
Unfortunately I've done an uninstall and reinstall of Eucontrol, PT Control app, and PT in varying combinations, and nothing is bringing it back to where it was before. Sucks, but I guess I learned the hard way that if it ain't broke don't fix it...

mrtomcat 06-19-2019 01:16 AM

Re: Soft Keys No Longer Execute Keystrokes
I want to add to this.
I just got a new mac mini and reinstalled everything Eucon 2019.5
Now when creating user page controls my macros using keys as part of it won't work anymore...
New Playlist -> Eucon Command new playlist (works)
/n (return) to close the dialog (does not work)
I tried the enter key as well... same results

Funny enough when I hit the softkey twice, the first time the New Playlist dialog comes up and the second time it closes. This should happen with just one softkey press.

Please fix!

Brahamh 11-11-2019 03:43 PM

Re: Soft Keys No Longer Execute Keystrokes
Yup. Same here. I created several workflow edits and they are no longer executed. The main issue is creating anything that has "enter/return" key related. It sucks.

All times are GMT -7. The time now is 10:50 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com