Avid Pro Audio Community

Avid Pro Audio Community (https://duc.avid.com/index.php)
-   Avid S1, S3, Dock and Control App (https://duc.avid.com/forumdisplay.php?f=135)
-   -   S1 Eucontrol soft key command ordering issue (https://duc.avid.com/showthread.php?t=408498)

Finnmaker 02-14-2020 04:19 AM

S1 Eucontrol soft key command ordering issue
 
(Happens also on 20.1, ie not fixed with "Artist Control only: Soft Keys could fail to function correctly (GWSW-13389)")

On S1, all Soft Key commands do not follow the order they are placed in the Eucontrol app.

eg. if I create a soft key with the commands:
EUCON: Split into mono
KEY: ;
KEY: [SHIFT] P

It will sometimes first execute the command SHIFT + P and will not, in every case, split into mono before the key command. In some cases it will split to mono the correct track, but not select the mono track after the split correctly, and other variations.

This happens with other types as well as the KEY and EUCON.

There seems to be a deeper ordering issue with the different types of commands. (eg. KEY and EUCON) EUCON commands alone seem to chain just fine.

A "wait" command could help solve this issue and make even more options possible eg. when Pro Tools needs time to render files etc.


Anyone else experiencing similar issues?

emf1138 04-16-2020 11:52 AM

Re: S1 Eucontrol soft key command ordering issue
 
This could explain the issue I'm having. Soft keys sometimes work and sometimes don't. It's completely random and completely frustrating. Though I'm seeing it with just a chain of Eucon commands. Latest Eucon with S1.


All times are GMT -7. The time now is 12:53 PM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com