Avid Pro Audio Community

Avid Pro Audio Community (https://duc.avid.com/index.php)
-   Pro Tools (https://duc.avid.com/forumdisplay.php?f=162)
-   -   Loss of Playback Engine Mid-Session (https://duc.avid.com/showthread.php?t=416446)

DEliker 08-01-2021 06:13 PM

Loss of Playback Engine Mid-Session
Started running into this a week ago.

ProTools is randomly freezing and then failing to see my Clarett 2 interface.
Upon rebooting the app, the input is missing. Only the Aggregate is seen as a playback engine choice.

Yet all other 3rd party apps and internet work, and the System still sees my Clarett and other devices.

Trashing the Preferences, full shut-down and restarting the system, reinstalling PT, doesn't resolve the problem.

Yet the next day or a couple hours later, I'll fire up the system and everything works again. Completely inexplicable. Happened twice today right in the middle of simply playing back a single voice track. The app freezes, then restarts, and the device is lost.

I've gotten this message when first trying to access the Playback Engine:
Could not complete the Playback Engine command because Assertion in "/Users/autobld/gitlabci/PT/release/2021/r2/ProTools/DFW/Views/UMenu.MacOS.mm", line 1843.

Anyone thoughts? It's really getting in the way.
If it was a device issue, the system shouldn't see it and other apps shouldn't work.
If it was a simple crash, the device should be seen upon reboot.
But the app is refusing to see anything else.

Grateful for any help.

2018 MacBook Pro
macOS Big Sur 11.4
Clarett 2 Pre USB
ProTools standard 2021.6

Obsidian Dragon 08-01-2021 10:54 PM

Re: Loss of Playback Engine Mid-Session
My first instinct says to suspect the cable to your interface. The Clarett 2 is USB or USB-C so I'd start to try replacing that cable. That's where I would start.

DEliker 08-02-2021 07:09 AM

Re: Loss of Playback Engine Mid-Session
Hi Obsidian,

Maayybbeee. But...

That wouldn't explain why the MacBook still sees everything.

Here's the hardware cabling:
Focusright Clarett 2 to Thunderbolt 3 Dock via USB-C.
Thunderbolt 3 via USB-C to the MacBook Pro.
(Also in to the Thunderbolt 3 are Ethernet for Source-Connect, iLok dongle, and Firewire 800 for Glyph external HD)

If it was the cable from the Clarett to the docking station, I'd expect not to see the Clarett recognized by the Mac OS, play audio from other apps, or see it register input on the Focusright Control app. But System Info sees it.

If it was the cable from the Dock to the MacBook, I'd expect neither the Clarett nor the Dock to be seen by the computer. But they are. Just not by Pro Tools.

I'd also expect to not read audio from the external HD. But I can obviously open session folders and play individual audio files directly outside of PT. So data is being sent and read.

JFreak 08-02-2021 07:16 AM

Re: Loss of Playback Engine Mid-Session
Big Sur has has strange connection issues so first thing I would do is update to latest version and try again. Also, if the problem still persists, some have reported that removing external displays helps, only use one. Sounds like sorcery but something in Big Sur is broken and you just need to wiggle everything to find out what works.

Obsidian Dragon 08-02-2021 08:20 AM

Re: Loss of Playback Engine Mid-Session
I would test by simplifying the variables. Try Protools with just the power adapter and a USB-C to USB-Clarett cable (I'm not sure if the Clarett side is USB-C or USB-B). Don't go through a Thunderbolt hub. Don't have multiple external monitors connected. Don't have external hard drive connected if possible. Have your iLok on a USB-C to USB-A dongle. No Bluetooth devices, external keyboard or mouse. Keep it simple and test. Too many devices fighting for your USB/Thunderbolt ports may cause conflicts or provide insufficient power to some devices. At least test to rule out this condition. Again, cables can go bad. Protools may check for the interface's connection more often than the other application or OS.

originalscottyg 08-02-2021 09:10 AM

Re: Loss of Playback Engine Mid-Session

Originally Posted by DEliker (Post 2609408)
Hi Obsidian,

Maayybbeee. But...

That wouldn't explain why the MacBook still sees everything.

If the interface drops out for a moment, macOS can re-connect to it once it comes back online, so you don't see it as being offline when you switch over to system settings, as it has already re-connected. Pro Tools will not reconnect to an interface or playback engine if it drops out without relaunching the app.

DEliker 08-03-2021 06:40 AM

Re: Loss of Playback Engine Mid-Session
Hey thanks, guys. All good suggestions. Think we might have got it, fingers crossed.

Had a support session with Avid last evening and before that, did a little reworking by plugging the Clarett directly into the computer and moving the cable between the OWC Thunderbolt to different ports on both ends. Nothing worked. Flushed the PRAM a couple times, a couple of full shutdowns, same. Thought about updating the OS to 11.5 but didn't want to muddy the waters with that just yet.

Worked with Avid for about 30 minutes on it when everything suddenly reappeared in the Playback Engine options and I was back in action. Still don't know exactly what it was that changed. Can't quite point to cause and effect.

Avid's best guess at the moment is that it might not be cable or port, but rather something internal to the Thunderbolt hub that was being overloaded. So we're going to watch it for the next week and see if the problem manifests itself again with the new wiring config.

The OWC unit was recommended by Sweetwater when I originally set this up. But I suppose it's possible it's just not keeping up any more.

So, I hesitate to call this solved just yet. I'll let you know.

Any replacement suggestions for the hub, I'm open.


Rich Breen 08-03-2021 07:24 AM

Re: Loss of Playback Engine Mid-Session
Yeah, I'm with Scott - just 'cause the OS appears to reconnect doesn't mean the interface isn't momentarily going offline causing ProTools to throw up.

Of course, no one can say with certainty, but it really does smell like hardware to me - I'd be taking a long look at cabling, hubs, all peripherals.

DEliker 08-04-2021 07:36 AM

Re: Loss of Playback Engine Mid-Session
2 Attachment(s)
I'd could see why the OS may reconnect and appear available while Pro Tools wouldn't without a relaunch. But it doesn't explain why relaunching the app won't see anything but the aggregate I/O.

Points to something else, and yes, I'm suspecting the OWC Thunderbolt 3 dock as everything was running through it. Not sure exactly how to test for it though, to be sure.

Usual playback engines seen are:
Attachment 14742

Relaunching after the problem presents produces this:
Attachment 14743

Now, if it's the dock, I get why both the interface and the dock might not show upon relaunch. I can't explain the rest missing as they're software/system options. But there you go.

I've been a little suspicious of the Thunderbolt dock after replacing my Mbox 3 Mini with the Clarett, which requires an external power source. Switching the Clarett on, the light on my iLock dongle plugged in the dock would often go out.

originalscottyg 08-04-2021 12:02 PM

Re: Loss of Playback Engine Mid-Session
I'm currently using an OWC TB3 dock (14-port) on a 2019 MacBook Pro i9 and it's rock solid. But, I'm using an Avid HD Native TB + Omni system, connected to a separate TB bus (other side of the MacBook), and not a USB interface.

Is the Clarett connected via the dock, or directly to the Mac? I would suggest connecting the Clarett to the MacBook Pro directly to the MacBook via a separate bus than the dock, if possible.

originalscottyg 08-04-2021 03:49 PM

Re: Loss of Playback Engine Mid-Session
Looking at your screen shots again, it's weird that all of the other playback engine options disappear, especially the MacBook Pro Speakers and Microphone and Source Nexus. I think it might be a good idea to start a support ticket.

DEliker 08-05-2021 06:37 AM

Re: Loss of Playback Engine Mid-Session
Now I'm thinking Janne was right. It's sorcery!

Evening session last night was a bust when the problem manifested again.

Sat there for over an hour trying different things with no result. Then, I pulled out the USB-C connection for the external display in my booth. Launched Pro Tools...and all playback options were back.

When on the horn with Avid the previous night, they were having trouble seeing my screen by remote. We were messing around with display settings to try and address it and I think I may have pulled out the display cable. But as we were trying a bunch of different things at once, restarting and reconfiguring the Clarett cable, when we fired up Pro Tools and everything had reappeared, I didn't even consider it was the display line at the time. Thought it was a result of taking the load off the Thunderbolt hub.

So, can't quite say cause and effect just yet but...maybe "wiggle it" was the right answer after all.

That's a USB-C to HDMI connection for the external display in the booth. Allows me to keep the fan noise outside. So it's necessary, but maybe if I can find a cable with a display port end, I could take it directly into the hub.

Could it really be that simple?

DEliker 08-24-2021 06:48 AM

Re: Loss of Playback Engine Mid-Session
Just stopping back to put a button on this conversation.

The issue has only occurred one time since my last report and was quickly resolved. It does seem to be an external monitor/display cable issue.

I'd ordered a new cable for the monitor that was HDMI to display port.
While waiting for it to arrive, I had continued the current setup taking the interface direct to the USB-C port on the computer and running the display into the open USB-C port on the Thunderbolt dock.

This didn't stop the issue from presenting again, but all I did was disconnect the external monitor cable, restart the ProTools app. All the devices showed up again immediately, and I reconnected the cable.

I haven't had any further issues.

So, I guess we can simply confirm:
There is something about external display cables/monitors that seems to cause Pro Tools to lose playback engine options.

SOLUTION: Disconnect the display cable, restart ProTools, press "n" on launch to confirm playback engine options, and reconnect the display.

Calling it SOLVED.

Obsidian Dragon 08-24-2021 07:41 AM

Re: Loss of Playback Engine Mid-Session

Originally Posted by Obsidian Dragon (Post 2609422)
Too many devices fighting for your USB/Thunderbolt ports may cause conflicts or provide insufficient power to some devices.

Display monitors do tend to use up quite a lot of thunderbolt bandwidth depending on the resolution (4K or higher especially). I suspect the display monitors also require a significant power draw from the ports that may sage the power to your audio interface, hence the bandwidth or power draw may cause a disconnect of the audio interface from Protools. Even though the audio interface reconnects to MacOS, Protools may not reestablish a connection after a disconnect, thus requiring a restart of Protools.

XStylus 03-15-2022 09:42 AM

Re: Loss of Playback Engine Mid-Session

Originally Posted by DEliker (Post 2611519)
SOLUTION: Disconnect the display cable, restart ProTools, press "n" on launch to confirm playback engine options, and reconnect the display.

Calling it SOLVED.

Just wanted to pop in to say thanks, as you helped point me in the right direction in solving a nearly identical issue we were having with an Assertion Error in "/Users/autobld/gitlabci/PT/release/2021/r2/ProTools/DFW/Views/UMenu.MacOS.mm", line 1843 in Pro Tools. And indeed, a secondary monitor was the problem. We began encountering this problem after an upgrade from Mojave 10.14.6 to Catalina 10.15.7.

We didn't stop there though, as we investigated why the monitor was the problem.

Our secondary monitor is hooked into an HDMI splitter, thus mirroring to four monitors. However, that splitter wasn't configured to provide an EDID. The fix was to configure the splitter it to mimic the EDID of the worst of the four monitors (I.E. if there's three 1440p monitors and one 1080p monitor, use the 1080p monitor's EDID).

Once the splitter was providing an EDID, all was happy.

Also, the way to see if MacOS is even seeing an EDID is to go to "About this Mac" -> "System Report" -> "Graphics/Displays". If the name of the monitor is simply "Display" instead of something specific like the monitor's actual model number, then it didn't read the EDID.

Hope this helps somebody in the future.

All times are GMT -7. The time now is 03:38 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com