Avid Pro Audio Community

Avid Pro Audio Community (https://duc.avid.com/index.php)
-   Pro Tools (https://duc.avid.com/forumdisplay.php?f=162)
-   -   Loss of Playback Engine Mid-Session (https://duc.avid.com/showthread.php?t=416446)

originalscottyg 08-04-2021 03:49 PM

Re: Loss of Playback Engine Mid-Session
Looking at your screen shots again, it's weird that all of the other playback engine options disappear, especially the MacBook Pro Speakers and Microphone and Source Nexus. I think it might be a good idea to start a support ticket.

DEliker 08-05-2021 06:37 AM

Re: Loss of Playback Engine Mid-Session
Now I'm thinking Janne was right. It's sorcery!

Evening session last night was a bust when the problem manifested again.

Sat there for over an hour trying different things with no result. Then, I pulled out the USB-C connection for the external display in my booth. Launched Pro Tools...and all playback options were back.

When on the horn with Avid the previous night, they were having trouble seeing my screen by remote. We were messing around with display settings to try and address it and I think I may have pulled out the display cable. But as we were trying a bunch of different things at once, restarting and reconfiguring the Clarett cable, when we fired up Pro Tools and everything had reappeared, I didn't even consider it was the display line at the time. Thought it was a result of taking the load off the Thunderbolt hub.

So, can't quite say cause and effect just yet but...maybe "wiggle it" was the right answer after all.

That's a USB-C to HDMI connection for the external display in the booth. Allows me to keep the fan noise outside. So it's necessary, but maybe if I can find a cable with a display port end, I could take it directly into the hub.

Could it really be that simple?

DEliker 08-24-2021 06:48 AM

Re: Loss of Playback Engine Mid-Session
Just stopping back to put a button on this conversation.

The issue has only occurred one time since my last report and was quickly resolved. It does seem to be an external monitor/display cable issue.

I'd ordered a new cable for the monitor that was HDMI to display port.
While waiting for it to arrive, I had continued the current setup taking the interface direct to the USB-C port on the computer and running the display into the open USB-C port on the Thunderbolt dock.

This didn't stop the issue from presenting again, but all I did was disconnect the external monitor cable, restart the ProTools app. All the devices showed up again immediately, and I reconnected the cable.

I haven't had any further issues.

So, I guess we can simply confirm:
There is something about external display cables/monitors that seems to cause Pro Tools to lose playback engine options.

SOLUTION: Disconnect the display cable, restart ProTools, press "n" on launch to confirm playback engine options, and reconnect the display.

Calling it SOLVED.

Obsidian Dragon 08-24-2021 07:41 AM

Re: Loss of Playback Engine Mid-Session

Originally Posted by Obsidian Dragon (Post 2609422)
Too many devices fighting for your USB/Thunderbolt ports may cause conflicts or provide insufficient power to some devices.

Display monitors do tend to use up quite a lot of thunderbolt bandwidth depending on the resolution (4K or higher especially). I suspect the display monitors also require a significant power draw from the ports that may sage the power to your audio interface, hence the bandwidth or power draw may cause a disconnect of the audio interface from Protools. Even though the audio interface reconnects to MacOS, Protools may not reestablish a connection after a disconnect, thus requiring a restart of Protools.

XStylus 03-15-2022 09:42 AM

Re: Loss of Playback Engine Mid-Session

Originally Posted by DEliker (Post 2611519)
SOLUTION: Disconnect the display cable, restart ProTools, press "n" on launch to confirm playback engine options, and reconnect the display.

Calling it SOLVED.

Just wanted to pop in to say thanks, as you helped point me in the right direction in solving a nearly identical issue we were having with an Assertion Error in "/Users/autobld/gitlabci/PT/release/2021/r2/ProTools/DFW/Views/UMenu.MacOS.mm", line 1843 in Pro Tools. And indeed, a secondary monitor was the problem. We began encountering this problem after an upgrade from Mojave 10.14.6 to Catalina 10.15.7.

We didn't stop there though, as we investigated why the monitor was the problem.

Our secondary monitor is hooked into an HDMI splitter, thus mirroring to four monitors. However, that splitter wasn't configured to provide an EDID. The fix was to configure the splitter it to mimic the EDID of the worst of the four monitors (I.E. if there's three 1440p monitors and one 1080p monitor, use the 1080p monitor's EDID).

Once the splitter was providing an EDID, all was happy.

Also, the way to see if MacOS is even seeing an EDID is to go to "About this Mac" -> "System Report" -> "Graphics/Displays". If the name of the monitor is simply "Display" instead of something specific like the monitor's actual model number, then it didn't read the EDID.

Hope this helps somebody in the future.

All times are GMT -7. The time now is 04:21 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com