Avid Pro Audio Community

Avid Pro Audio Community (https://duc.avid.com/index.php)
-   Pro Tools (https://duc.avid.com/forumdisplay.php?f=162)
-   -   Erratic behavior CPU usage at lowest buffer since 2022.6 (https://duc.avid.com/showthread.php?t=421286)

bortraws 08-14-2022 08:34 AM

Erratic behavior CPU usage at lowest buffer since 2022.6
 
Since updating to Pro Tools 2022.6 and now also in 2022.7 the cpu meters show erratic behaviour at the lowest buffer setting (32 samples) with regular peaks at 100% in the System Usage window (see link to video below). This is without a session open and all third party plugins removed.

This means constant CPU overloads when trying to record with the lowest latency buffer on my HD Native system. Even at 64 samples I get more CPU overload errors then when I used 2022.5.

The Pro Tools dedicated 2013 Mac Pro 6,1 runs a clean MacOS Monterey 12.4 without any third party utilities except the needed 1Password password manager.

I could fall back to 2022.5 which didn't have this issue for me but then I also have to reinstall the system to be safe as 2022.5 is approved for MacOS Monterey 12.3 only. With no downtime the coming month this is not really an option.

Anyone recognize this behavior or know a fix that I didn't already try? Or is this simply a bug that Avid needs to fix?

Sytem overview
2013 Mac Pro 6,1 with 64Gb RAM
MacOS Monterey 12.4
Pro Tools 2022.7
HD Native system with OMNI HD interface
3rd party Plugins temporarily moved to unused plugins folder
And yes I have deleted the preferences using the PT Prefs utility and no I do not have a Chrome browser installed :-)

https://www.pixonic.nl/voorbeeld/err...ols_2022_7.mov

Darryl Ramm 08-14-2022 12:14 PM

Re: Erratic behavior CPU usage at lowest buffer since 2022.6
 
Good start, but Troubleshoot more. All standard stuff described under "help us help you" on every DUC web page.

Use Pete Gates PT Prefs utility. trash prefs again between trying other things.

Make sure you uncheck ignore errors.

make sure you got all plugins removed. just move every .aaxplugin file out of the plugin folder, trash prefs and restart Pro Tools, it will automagically put back the core plugins.

Test using built in output (or whatever its called on your mac) as the playback engine.

Create a new admin user in macOS and repeat all the tests from that account.

If all that does not help I would rename the current install of Pro Tools and reinstall 2022.5 on your current macOS version and just see how it behaves.

bortraws 08-17-2022 06:14 AM

Re: Erratic behavior CPU usage at lowest buffer since 2022.6
 
Thanks for your reply Daryl.

Sorry, don't want to sound smug but as I mentioned in my original post I have used the PT Prefs utility of Pete Gates and what you see in the linked video is with no session open and after ALL 3rd party plugins were removed and the Mac restarted.

I have done all the standard stuff Avid advises and therefore have tested under a new Admin user and unfortunately the situation is the same.

Ignore errors is always off as I want to know if there's an issue.

I am used to being able to record new tracks using a 32 samples buffer in relatively large sessions of 100+ tracks using lots of plugins on a 12 core Mac Pro 6,1.

Already planned to go back to 2022.5 as soon as I have some downtime. Hopefully this weekend. I tested 64 samples buffer and can get away with it for recordings in the smaller than usual sessions this week.

Just wanted to know if there are others that experience this behavior. I remember reading something about troubles with the lowest buffer setting but can't seem to find the thread.

Thanks

bortraws 08-20-2022 08:43 AM

Re: Erratic behavior CPU usage at lowest buffer since 2022.6
 
The link to the video was a bit buried underneath the system specs which can be seen as a signature. one might not have seen the video.

Here's the video again that shows the strange behavior of the System usage window.

Video that shows the strange behavior of the System Usage window

As said this is without any third party plugin active and no session open. No Chrome browser installed and no third party utilities in the system (see original post for system specs).

Anyone having the same issue?

JoeTools1963 08-21-2022 07:48 AM

Re: Erratic behavior CPU usage at lowest buffer since 2022.6
 
Quote:

Originally Posted by bortraws (Post 2644959)
The link to the video was a bit buried underneath the system specs which can be seen as a signature. one might not have seen the video.

Here's the video again that shows the strange behavior of the System usage window.

Video that shows the strange behavior of the System Usage window

As said this is without any third party plugin active and no session open. No Chrome browser installed and no third party utilities in the system (see original post for system specs).

Anyone having the same issue?


Super odd.


Sent from my iPhone using Tapatalk

its2loud 08-21-2022 08:02 AM

Re: Erratic behavior CPU usage at lowest buffer since 2022.6
 
What happens if you run PT without the HD Native and just use core audio as your playback engine? Disconnect the HD Native if it’s thunderbolt or disconnect the expansion chassis if it’s the Native card.


All times are GMT -7. The time now is 02:53 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com