Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   Pro Tools 12 (http://duc.avid.com/forumdisplay.php?f=142)
-   -   No such file or directory (2) (http://duc.avid.com/showthread.php?t=414329)

IrelandM 03-04-2021 04:18 AM

No such file or directory (2)
To ProTools Users,

I get the following error after I launch ProTools HD 12.8.1 or 12.8.3.

Could not complete your request because No such file or directory (2) while creating "Plug-in Settings" .

Any ideas what would remove this issue and get any of these versions of ProTools up and running.


Mark Ireland

Darryl Ramm 03-04-2021 11:01 AM

Re: No such file or directory (2)
You are not providing any clear info about your system or what basic troubleshooting you have already tried. Start at “help us help you” up the top of each DUC web page. And provide the info asked for there... folks cannot guess if your profile info is up to date or which system this happens on.

What have you changed? When does this happen? Opening an existing session? A new session? Opening Pro Tools without a session? Have you even tried Trashing Prefs? Got removable drives attached? Try ejecting them all. Try testing from a new admin user account.

There are many many past threads on DUC about this error message. Use the site:duc.avid.com qualifier on Google search. And work through stuff there that has solved this for others.

IrelandM 03-05-2021 12:43 PM

Re: No such file or directory (2)
To Darryl,

I tried to find a preferences folder at ~/Library/Preferences /Avid to delete it on the laptop also tried Peter Gates PT Prefs helper to see if this would work but its had no effect.

Having upgraded the software from version 10 HD through to 11 and up to 12.8.1 over time this has probably caused the problem.

I also keep more that one version of PROTools on the 2Tb SSD drive and I lately added a trial version of ProTools Ultimate 20.9.123 but see it was not supported on macOS High Sierra 10.13.4

The Could not complete your request because No such file or directory (2) while creating "Plug-in Settings" comes up after launching PTools and loading plugins but shows the error after clicking ok the software quits.

Not tried a new user admin account the system has already to much data on this SSD drive.


Darryl Ramm 03-05-2021 01:05 PM

Re: No such file or directory (2)
I am not sure I follow all you are saying.

Are you saying you looked for ~/Library/Preferences/Avid and it was not there... ? ~/Preferences is a hidden folder by default. You can get to it via Terminal or in the Finder by using the menu item "Go" and holding down the option key will then show the Library folder. If the whole folder is literally not there that's interesting.

While poking around there you might look at log files from failed startups in ~/Library/Logs/Avid and just see if there is any more clues there.

The 2TB SSD is your boot drive? How have you got multiple versions of Pro Tools installed? ... and that may directly be your problem.

Why does the disk having too much data on a drive stop you creating another admin user.... if it's that full you may have other problems. You don't even need a session to reproduce the problem. And a new user account uses very little space on disk.

Anyhow big picture next steps seem straightforward if things still are not working including removing all the various Pro Tools versions, temp. moving all .aaxplugin files out of the plugin folder and trashing prefs, installing a clean supported Pro Tools version with standard plugins and seeing if it works at all. And if that does not fix it then a new macOS install.

All times are GMT -7. The time now is 12:26 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com