Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools 12

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-10-2017, 12:44 PM
XJENSEN XJENSEN is offline
Member
 
Join Date: Dec 2004
Location: Gent, Belgium, Europe
Posts: 263
Default Instrument Track Commit results in huge audio delay

Is anyone else experiencing this in Protools 12.7 HD?

I'm having problems with the Track Commit feature on instrument tracks. The committed audio is completely out of sync (way too late) when committing external instruments.

It seems ADC (Automatic Delay Compensation) can't deal with this scenario?
Attached Images
File Type: jpg Comitted instrument track audio lag.jpg (58.4 KB, 0 views)
Reply With Quote
  #2  
Old 01-10-2017, 01:12 PM
metalmixer metalmixer is offline
Member
 
Join Date: Mar 2016
Location: San Francisco
Posts: 265
Default Re: Instrument Track Commit results in huge audio delay

It works here no problems I would disable all the session plug-ins and test it again
Reply With Quote
  #3  
Old 01-10-2017, 01:29 PM
john1192 john1192 is offline
Member
 
Join Date: Nov 2001
Location: Woodland Hills
Posts: 5,768
Default Re: Instrument Track Commit results in huge audio delay

do you have any Plugins on your Master Fader ??
__________________
Mac Pro 6-core 3.33ghz (2012) 24gb ram 256gb SSD -OS 10.12.6 for PT 11.3.2 & 2019.6 last version
Logic Pro X latest version
RME BabyFace Pro

Macbook Pro july 2014 2.5ghz 16gb ram 512gb SSD - OS10.14.6 - PT 2019.6 Ended here ..
Logic Pro X latest version
RME BabyFace Pro
Reply With Quote
  #4  
Old 01-10-2017, 01:34 PM
XJENSEN XJENSEN is offline
Member
 
Join Date: Dec 2004
Location: Gent, Belgium, Europe
Posts: 263
Default Re: Instrument Track Commit results in huge audio delay

Quote:
Originally Posted by metalmixer View Post
It works here no problems I would disable all the session plug-ins and test it again
Euhm, first of all, there are no active plugins in this session. Secondly, based on your comment, I don't think you understand the sense of the Commit feature. This feature is exactly meant to commit tracks *having* plugins on them, to free up processing resources or for easier session sharing. Please refer to page 939 of the Protools 12.7 manual if you like to learn more about the commit, freeze and bounce functionality.
Reply With Quote
  #5  
Old 01-10-2017, 01:35 PM
XJENSEN XJENSEN is offline
Member
 
Join Date: Dec 2004
Location: Gent, Belgium, Europe
Posts: 263
Default Re: Instrument Track Commit results in huge audio delay

Quote:
Originally Posted by john1192 View Post
do you have any Plugins on your Master Fader ??
No, there are no active plugins on the master fader (only a few deactivated ones).
Reply With Quote
  #6  
Old 01-10-2017, 02:03 PM
DetroitT's Avatar
DetroitT DetroitT is offline
Member
 
Join Date: Dec 2000
Location: Detroit, Mi, USA
Posts: 2,226
Default Re: Instrument Track Commit results in huge audio delay

Hi just tried the DB-33(+104 samples) and Omnisphere V1 (+192 samples=acceptable Air)) Commit from clip and commit from instrument track. Both aligned well.

PT's HD12.7 Mac OS 10.12.2 DC on @ 44.1KHz 32 bit-float

What Instruments are you using or are there additional plug-ins?
Commit up to...

---------
Further testing seems to indicate DC is indeed working here.
Added Waves XNoise stereo (5120 sample-delay)
No Delay Comp =(5239 samples at tabed peak)
DC On = 192 samples at tabbed peak.
__________________
(Help us Help You)<<<click here

APFS 90% 10% Audio on Both.

Pro Tools U-2020.5 macOS 10.14.6 APFS
Second boot-macOS 10.13.6 (Avid HDX-1 Omni)

(2k10MP 5,1 / 64-Gb)
(Sapphire RX-580 MVC-Edition-dual mini 6 pin. one spliced to add Avid mini 4 pin-hdx)
FW-CoreAudio (for poly-recording)
(SSL-HUI-MIDIoverIP)
----
music-design-creation
Post Music-Sound mixing, Production-Enhancements.

Audio Tuning and System Services
new systems builds / upkeep / +
----
New builds:
12 core nMP HDX 1 Slot 5 stock HDX Mac mini 6pin to 4 pin HDX power like 5,1 mp's used)
16 core nMP rack-test station
28 just because machine
Reply With Quote
  #7  
Old 01-10-2017, 02:37 PM
XJENSEN XJENSEN is offline
Member
 
Join Date: Dec 2004
Location: Gent, Belgium, Europe
Posts: 263
Default Re: Instrument Track Commit results in huge audio delay

Hi DetroitT,

Mind this issue is dealing with external instruments. Internally, it's also working fine here!
Reply With Quote
  #8  
Old 01-10-2017, 03:23 PM
albee1952 albee1952 is offline
Member
 
Join Date: May 2004
Location: Norwich, CT
Posts: 35,615
Default Re: Instrument Track Commit results in huge audio delay

Indeed, with external instruments, all timing bets are off, but your playback buffer size might be adding to the latency. On my rig(at a 64 buffer), all the VI tracks I have committed or frozen(doing a lot of testing for just this reason, I am finding that frozen and committed audio is almost NEVER sample-accurate with the original midi note placement. Having said that, in listening tests the timing has sounded fine with offsets of anywhere from 2 to 100 samples of offset. Whether you can hear/perceive any timing issues will be a personal thing as some folks are more or less bothered by this(I find it to be no different than the same player, playing a part twice. Nobody every hits every note at the exact same sample in the timeline

Since Avid seems to be dragging their feet on fixing this, if the offset shown in the screen capture is consistent, I would measure, write it on a Post-it, stick that to the edge of the screen and nudge things into alignment(after a few times, it will become second nature)
__________________
Gigabyte X79/intel i7 3930K, 32GB RAM, DIGI003 Rack
https://www.facebook.com/search/top/...0sound%20works


The better I drink...the more I mix.....

BTW, my name is Dave, but most people call me.........................Dave
Reply With Quote
  #9  
Old 01-10-2017, 03:32 PM
lesbrunn's Avatar
lesbrunn lesbrunn is offline
Member
 
Join Date: Feb 2002
Location: Accra, Ghana
Posts: 737
Default Re: Instrument Track Commit results in huge audio delay

Quote:
Originally Posted by XJENSEN View Post
Is anyone else experiencing this in Protools 12.7 HD?

I'm having problems with the Track Commit feature on instrument tracks. The committed audio is completely out of sync (way too late) when committing external instruments.

It seems ADC (Automatic Delay Compensation) can't deal with this scenario?
Hi XJENSEN,

PT has never worked well for me with external instruments. I always have to compensate manually with midi offset, sometimes very drastically. ADC doesn't work in scenarios like that.
__________________
X99 | i7 5960x @4.6GHz | 64GB GSkill DDR4 | Nvidia GTX 950 | Samsung 950 Pro NVMe 256GB | Samsung SM961 NVMe 1TB | Samsung 850 EVO 1TB | Samsung MZ7PD256 SSD 256GB | Kingston 120GB SSD | WD Black 1TB x2 | G-Drive 4TB x2 | WD Elements 4TB | Audient ID14 | PT2020.5 | Windows 10 Pro
Reply With Quote
  #10  
Old 01-10-2017, 04:03 PM
john1192 john1192 is offline
Member
 
Join Date: Nov 2001
Location: Woodland Hills
Posts: 5,768
Default Re: Instrument Track Commit results in huge audio delay

do you have your midi offset setup in Pref's ?? just trying to think of things that could cause this with ADC turned on .. please just disregard or ignore this if off base .. you cannot hurt my feelings
__________________
Mac Pro 6-core 3.33ghz (2012) 24gb ram 256gb SSD -OS 10.12.6 for PT 11.3.2 & 2019.6 last version
Logic Pro X latest version
RME BabyFace Pro

Macbook Pro july 2014 2.5ghz 16gb ram 512gb SSD - OS10.14.6 - PT 2019.6 Ended here ..
Logic Pro X latest version
RME BabyFace Pro
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic Delay Compensation - PT 12.4 - Instrument Track bug swfeathers Pro Tools 12 8 09-04-2018 09:27 AM
Pro Tools crashes trying to Commit an instrument track Rewired with Reason mrbenjaminspeed Pro Tools 12 4 04-30-2017 01:21 PM
How to set up delay right in instrument track Natanel Arnson Pro Tools 11 2 12-20-2016 06:54 PM
11.2.1: Instrument Track delay compensation problem rainsong Pro Tools 11 14 08-20-2014 03:43 PM
strange message when trying to commit to an elastic audio track gibsy General Discussion 2 12-19-2013 03:07 AM


All times are GMT -7. The time now is 06:43 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com