Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > ICON & C|24

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-26-2004, 01:17 PM
Drum Drum is offline
Member
 
Join Date: Dec 1969
Location: Devon UK
Posts: 52
Default Disaster! (But I still love my C24) Help!

I love my C24. It has increased my enjoyment and quality of work enormously. But...

...today my main monitors failed at the start of a session. It seemed that the C24 wasn't sending a signal. The Alt Monitor worked though so I switched to my nearfields instead. Ten minutes later they failed too! Definitely the desk this time so I routed the output from the i/o directly to the speakers via the aux send (the desk still sent a cue mix to the live area no prob). The session was eventually finished a couple of hours ago. Client gone, I thought I would prepare a mix for tomorrow and suddenly the faders stopped working. They wouldn't even move for the utility/test. At this point I gave up and thanked the stars that the desk allowed mr to complete the days work (albeit in a bodged kind of way).

Anyway, tale of woe over.

Has anyone had this prob? Will it be expensive and does anyone know someone who can repair a C24 in the south west of the UK?

Thanks all

Drum
Reply With Quote
  #2  
Old 12-06-2004, 04:05 AM
Lucius14 Lucius14 is offline
Member
 
Join Date: Dec 2004
Posts: 1
Default Re: Disaster! (But I still love my C24) Help!

Hy!

have nearly the same Prob, it`s my third C24 in a row, coz the others had the same prob after a Year again and again, so right at the mom. I`m standing in front of my C24, and it`s not working, it seems to me, that it`s a Software prob, but I dunno....
I loved to work with that baby, but for me it`s no sense in challenging the Digidesign Support anymore, coz it`s Sh.., none of the three C24 I had now, had been working correctly for more than a Year, but for Digidesign the Guarantee is over even if none of the Controls had made up to the Guaranteetime of two Years, so my reseller had jumped in the last time, but now I´m in a bad position, coz I dunno what my reseller will do now, I`m hopin to get rid of that thing, coz it`s full of bugs, and it`s a shame, that Digidesign had sold such a crap like that!( the workflow of the C24 is absolutly cool, if it`s working properly)
If you hadnt spent nearly half a million in Digidesign Products, they give a [bleep] about you...thats my experience so far....

Greetz and Good Luck!

Lucius14
Reply With Quote
  #3  
Old 12-06-2004, 02:29 PM
PTLance PTLance is offline
Member
 
Join Date: Apr 2001
Location: Port Melbourne, Victoria, Australia
Posts: 468
Default Re: Disaster! (But I still love my C24) Help!

I would say it sounds like the power supply. They are pretty easy to swap. Call Digi and they will send you one. Good luck!!
Reply With Quote
  #4  
Old 01-22-2005, 10:11 AM
Liv Liv is offline
Member
 
Join Date: Aug 2004
Location: Berlin, Germany
Posts: 4
Default Re: Disaster! (But I still love my C24) Help!

Hi, I am having the same problem right now. What did you finally do? I really do need help quickly.

Liv
Transaudio GmbH
Berlin, Germany
__________________
....................................
Transaudio GmbH
Berlin, Germany
Reply With Quote
  #5  
Old 01-22-2005, 12:11 PM
Jan Folkson Jan Folkson is offline
Member
 
Join Date: Dec 1998
Location: New York City
Posts: 379
Default Re: Disaster! (But I still love my C24) Help!

It almost certainly a power supply issue. Contact Digi tech support and they'll send you out a new one.
__________________
- Jan Folkson
www.janfolkson.com
Reply With Quote
  #6  
Old 01-22-2005, 12:19 PM
Drum Drum is offline
Member
 
Join Date: Dec 1969
Location: Devon UK
Posts: 52
Default Re: Disaster! (But I still love my C24) Help!

Mine was indeed a power issue. The PSUs on these are causing Digi some real headaches (I think they are on about revision J at the moment!) so they have been replacing them free of charge (irrespective of age by the looks of it) I sent the unit off (at my own expense) and the reepair centre did the rest and sent it back free of charge. Took 4 days.

Hope this helps.

You will need to contact Digi support to get the returns number and confirmation that the PSU will be replaced free of charge.

Good luck

Drum
Reply With Quote
  #7  
Old 01-30-2005, 01:04 PM
Liv Liv is offline
Member
 
Join Date: Aug 2004
Location: Berlin, Germany
Posts: 4
Default Re: Disaster! (But I still love my C24) Help!

Thank you, guys!

Mine was the power supply as well. Cost me about 500 Euros. Digi did not repair it free of charge as they said they did not find my serial number. I will contact them again, refering to your experiences.

Best wishes,
Liv
Transaudio GmbH
Berlin
__________________
....................................
Transaudio GmbH
Berlin, Germany
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New ADK i7 DAW...so far a disaster please help. dangerdog 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 19 08-11-2009 12:28 PM
Disaster Crash-need some help PhilBuckle Pro Tools TDM Systems (Mac) 14 06-13-2009 08:59 PM
C24 Disaster! banana boy ICON & C|24 13 02-14-2008 03:38 PM
DISASTER. erikcline75 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 12-10-2007 08:47 PM
Studio 5 Disaster Dennis Scott MIDI 1 07-04-2001 02:46 AM


All times are GMT -7. The time now is 07:11 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com