Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Additional Resources


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Win)

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 08-01-2015, 01:50 AM
fifan fifan is offline
Member
 
Join Date: Aug 2015
Location: Denmark
Posts: 2
Default Re: Mbox Pro Driver Updates

When will the drivers for Windows be updated for Windows 10? my system is freezing.
Reply With Quote
  #12  
Old 08-04-2015, 01:27 PM
shagia shagia is offline
Member
 
Join Date: Aug 2015
Location: Oakland, California
Posts: 1
Default Re: Mbox Pro Driver Updates

Quote:
Originally Posted by fifan View Post
When will the drivers for Windows be updated for Windows 10? my system is freezing.
Currently wondering the same, I do feel that it's my fault for upgrading to Windows 10 and not looking at any Mbox Pro updates especially since Windows 10 just recently came out, but the issues are quite insane. Audio drops out a lot when not using ASIO, disabling the device and enabling it again sometimes doesn't work so you'd have to restart your computer, and BSOD's get linked directly to the outdated Mbox Pro driver.

I might stay on Windows 7 for the time being, but I'm hoping AVID can jump on a Windows 10 update soon.
Reply With Quote
  #13  
Old 08-21-2015, 09:15 PM
jimed jimed is offline
Member
 
Join Date: Aug 2015
Location: sydney
Posts: 1
Default Re: Mbox Pro Driver Updates

Hi,

Is anyone else having problem downloading the latest Mbox Pro drivers for Mac? The page just doesn't load. I've now tried it on an excellent connection with three different browsers. Nothing.
Reply With Quote
  #14  
Old 05-22-2016, 10:19 AM
risey's Avatar
risey risey is offline
Member
 
Join Date: Jul 2009
Location: United Kingdom
Posts: 154
Default Re: Mbox Pro Driver Updates

Quote:
Originally Posted by shagia View Post
Currently wondering the same, I do feel that it's my fault for upgrading to Windows 10 and not looking at any Mbox Pro updates especially since Windows 10 just recently came out, but the issues are quite insane. Audio drops out a lot when not using ASIO, disabling the device and enabling it again sometimes doesn't work so you'd have to restart your computer, and BSOD's get linked directly to the outdated Mbox Pro driver.

I might stay on Windows 7 for the time being, but I'm hoping AVID can jump on a Windows 10 update soon.
I emailed AVID to ask if they ended support for MBOX 3 they would not confirm or deny... but since the last driver was 2014... I think its safe to assume its a NO...
__________________
http://www.PhatMonkey.me
Windows 10 64bit | Asus Rog Maximus X Formula Z370 | Intel i7-8700K CPU @3.70GHz, 3696 Mhz 6 Core(s) 12 Logical Processor(s) | Corsair LPX Vengeance 64g DDR4 RAM | Avid Mbox Pro 3 | Focusrite 18i20 2nd Gen | MSI GTX 1080TI Gaming X Trio | Acer Z35 Predator Monitor
Reply With Quote
  #15  
Old 11-25-2016, 02:57 AM
reyiboy123 reyiboy123 is offline
Member
 
Join Date: Nov 2016
Location: california
Posts: 3
Default Re: Mbox Pro Driver Updates

hi people i am tryin to connect my mbox 3 pro to my macpro 08 why is not working?? some body help me
Reply With Quote
  #16  
Old 01-10-2018, 05:29 AM
Gomf Gomf is offline
Member
 
Join Date: Jan 2018
Location: Germany
Posts: 1
Default Re: Mbox Pro Driver Updates

I think there is no newer Updates to solve die Driver Issues?
The Problems are easy to reproduce... why avid don't fix them?
Good drivers are so important... You can't use the Device stable so why i should i bought any Avid Products in future... I went back to my Rme Hdsp PCI ... Imagine the Card is from 2001 and so long out of stock... and they stil take care about the drivers... i have one pci slot on the new maschine... put the pci in start win 10... device no recognized... start the rme setup... the setup says "hello, please wait... a ok... finished... have fun" ... and everything works stable like a tank... only thing is the rme has no preamps why i want to use the mbox... so i use the mbox as standalone preamp... i think avid should fix this to show they take care about customers and that they can handle there systems... I also have used a Focusrite Pro 24 DSP on the Firewire and Fireface 400 and 800 without any Problems on the Texas Instrument Firewire Card... so it must be the buggy driver also the older driver run more stable but sometimes i have to restart the mbox because i have no sound or a blue screen apears... Avid offers a driver for Win 10 so please make it stable :/
Reply With Quote
  #17  
Old 03-19-2018, 01:19 AM
torgar torgar is offline
Member
 
Join Date: Apr 2016
Location: Athens / Greece
Posts: 1
Default Re: Mbox Pro Driver Updates

Has anyone experienced this issue?
While the Mbox pro seems to work great when playing back from headphones in Windows 10 64bit I experience a massive spike of noise when trying to playback through my Adam P22a monitors even when the volume in the Mbox has been set to 0!! I haven't found a workaround this problem.

However this doesn't occur when using Windows 7 with the exact same setup.

Any ideas?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates Bruce Paine FireWire and USB Audio Interfaces (Mac) 12 08-22-2017 08:25 AM
Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates Bruce Paine Technical Alerts 0 09-27-2013 12:33 AM
Would you pay for driver updates? Dale-c FireWire and USB Audio Interfaces (Mac) 4 05-07-2013 06:02 PM
mbox 2 factory driver updates Felix777 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 4 12-01-2012 03:09 PM
ASIO DRIVER UPDATES Lord EGGzz 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 12 11-19-2003 06:39 PM


All times are GMT -7. The time now is 02:00 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com