Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-31-2017, 01:01 PM
tgt13 tgt13 is offline
Member
 
Join Date: Jan 2017
Location: Stockholm, Sweden
Posts: 2
Default M-Audio - Fast Track Ultra driver - not working / MACOS SIERRA

Hello,

A friend recently upgraded to MACOS SIERRA. The does not seem to be any drivers to M-audio Fast Track Ultra. Despite this a friend tried to install the latest drivers to M-Audio Fast Track Ultra, version 2.3.3, provided at http://avid.force.com/pkb/articles/e...-Ultra-Drivers.

The drivers are installed successfully and the external sound card interface can after the install of the drivers be selected as the main audio output from System Preferences -> Sound -> Output. The problem is that there is no sound, and when he tries to play a Youtube video, the video freezes - I guess that this depends on the fact the drivers are not working.

I was wondering if there are any plans for releasing drivers for the M-Audio Fast Track Ultra that is supported in MACOS Sierra? It would be sad if the support for such a great soundcard would vanish in the latest releases of OSX.

Thanks in advance!
Reply With Quote
  #2  
Old 06-23-2017, 03:42 PM
jive01 jive01 is offline
Member
 
Join Date: Jun 2017
Location: Simpsonville
Posts: 1
Default Re: M-Audio - Fast Track Ultra driver - not working / MACOS SIERRA

Probably Not. Last drivers provided were in 2014. Kind of a shame and honestly poor business practice. Leaving customers out in the cold like this is really bad. Probably won't be getting any more Avid / M-Audio products now...
Reply With Quote
  #3  
Old 08-19-2017, 04:41 PM
mike.porter mike.porter is offline
Member
 
Join Date: Jan 2015
Location: Denver, CO
Posts: 9
Default Re: M-Audio - Fast Track Ultra driver - not working / MACOS SIERRA

I'm having the same issue (just so you know it's not you). Definitely too bad.
Reply With Quote
  #4  
Old 08-22-2017, 09:31 AM
Sanobabits's Avatar
Sanobabits Sanobabits is offline
Member
 
Join Date: Apr 2015
Location: Pinas
Posts: 29
Default Re: M-Audio - Fast Track Ultra driver - not working / MACOS SIERRA

It is written on the driver's page:
Quote:
Note that Mac OS X 10.11 El Capitan (or later) is not compatible and will not be qualified
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
next driver update for Fast Track C400, Mac OS 10.12 Sierra Quecox666 FireWire and USB Audio Interfaces (Mac) 1 10-24-2016 09:15 AM
M-Audio Fast Track Ultra 8R Headphone Out Not Working Properlly jefftranchina Third Party Interfaces 3 04-24-2016 09:19 PM
New Mac Driver for Fast Track Ultra deodorant FireWire and USB Audio Interfaces (Mac) 1 12-03-2014 05:17 PM
Fast Track Ultra 8R Driver Beto Chaves macOS 1 10-13-2013 03:53 AM
is there a driver yet for m-audio fast track ultra? montelee Pro Tools M-Powered (Mac) 2 08-11-2008 11:55 AM


All times are GMT -7. The time now is 12:59 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com