Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Pro Tools 2019

Reply
 
Thread Tools Search this Thread Display Modes
  #51  
Old 09-29-2019, 01:56 PM
Darryl Ramm Darryl Ramm is offline
Member
 
Join Date: Nov 2010
Location: USA
Posts: 13,427
Default Re: Not you again, Mr. -9173

Quote:
Originally Posted by VisionsMusicGroup View Post
FYI, just tried the KB article fix, and while promising, it did not solve the issue. It was hopeful, though! I will need to wait until I have time to unravel my entire empire to test clean OS/PT installations. But you've given me a lot to think about, and dabble with in the future. Thanks again!
This might be talking a too deep/a complex view of this, the way I presented the whole debug tree (and this post with more steps written out!) in one go likely makes it look much worse than it is. I just want to keep repeating this: the goal should be to as quickly as possible debug stuff. One way to take far too long in troubleshooting problem is to take small steps, taking big (but smart) key steps can be fast... if only to get you to the point quickly where you know it's then going to be a slog to go further... at which point you fight or run (e.g. recover from backup).

This looks worse to write out, but the key stuff that may fix things or work out which directions to head can be quick (~10 minutes, not counting download times for the AIR installer if you end up needing that).

Trash Prefs - Use Pete Gate's PT Prefs app, click two buttons, takes < tens seconds.

Test with Built-In Output as the playback engine, takes minutes.

Test plugins: Move all plugins out of the plugin folder. Takes tens of seconds. Without Pro Tools running, in Terminal type.

$ cd /Library/Application\ Support/Avid/Audio
$ sudo mv Plug-Ins/* 'Plug-Ins (Unused)'
(enter your password when asked)
(the single quotes around names are used to remove the special meaning to the command shell of some characters in those names, like space and parenthesis)
Then trash prefs again with PT Prefs.

That assumes nothing is already in the Plugin-Ins (Unused) folder. Now all the plugins are gone.

When Pro Tools restarts it will automatically put back the default plugins. But that's just the base Plugins, not say the Complete Plugin Collection or the Air Instruments package that actually contains MiniGrand. And since you seem to have a weird specific problem with MiniGrand I would probably next just copy that plugin back by itself. So with Pro Tools not running...

$ cd /Library/Application\ Support/Avid/Audio
$ sudo mv 'Plug-Ins (Unused)/MiniGrand.aaxplugin' Plug-Ins
(enter your password if asked)

Then trash prefs again with PT Prefs.

Then start Pro Tools. Does your MiniGrand test work now? Is so it was likely one of your other plugins ... your choice if you work without them installed for a while, reinstall a few key critical plugins you need, test them all etc. Now this path may take a long time... rolling back to a backups for now may be a better idea.

If Pro Tools still fails your MiniGrand test, maybe your MiniGrand plugin was totally broken. I'd delete that plugin and reinstall from a fresh installer.

$ cd /Library/Application\ Support/Avid/Audio/Plug-Ins
$ sudo rm -rf MiniGrand.aaxplugin
(be careful with that command, follow stuff exactly).

Then download the First_AIR_Instuments_2018_3_Mac_....dmg installer from your Avid Account and run that to install a full new clean MiniGrand and other plugins. Trash prefs again, and test. Sure you could try using Avid Link to reinstall MiniGrand/Air... but I don't actually trust that.

If stuff has not worked by now then something is totally hosed, thats were a full new Pro Tools Install or full new macOS install may be needed... or sure roll back to a backup. If you did an insitu macOS upgrade before and if you have to roll back to a backup, I sure would not repeat an insitu upgrade, and when there is time I'd be doing a full clean new install of MacOS, Pro Tools and your plugins etc. onto a separate disk partition and test it there before committing. But by then you are also confident that something is so badly trashed that doing all that extra work is worthwhile.

Diving into messy/complex/slow stuff like testing plugins one by one, or reinstalling everything, without the much quicker sanity tests would not be a good idea.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
9173, 9173, 9173... Hellooooo Rectifried Pro Tools 12 2 04-19-2018 12:50 AM
Dae 9173 danyg Pro Tools 2018 6 04-17-2018 04:04 PM
12.6.1 / aae-9173 anyone? lesbrunn Pro Tools 12 9 12-09-2016 03:43 AM
PT 12 - When 9173 is not actually 9173? taft_mashburn Pro Tools 12 2 10-06-2015 09:28 PM


All times are GMT -7. The time now is 12:24 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com