Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > macOS

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 02-17-2020, 12:52 PM
pherzfeld pherzfeld is offline
Member
 
Join Date: Mar 2006
Location: Austin, TX
Posts: 26
Default Re: Gui Lag in 2019.10 on OS 10.13.6

Any other ideas? I have yet to try running without plugins as the issue appears at random and sometimes not for a while so Im gonna have to have some serious downtime to try that.
Reply With Quote
  #12  
Old 02-17-2020, 12:59 PM
Meads Meads is offline
Member
 
Join Date: Jul 2010
Location: Germany
Posts: 2,903
Default Re: Gui Lag in 2019.10 on OS 10.13.6

I've had these GUI lags on all kinds of computers and I have never been able to pinpoint it 100%. But it was never a CPU or other performance issue.
My recent Hackintosh - for whatever reason - is the first and only machine I've used where I didn't experience this lag. I wish I knew why, but unfortunately I don't. Nothing changed periphery or software wise.

However what I've noticed when those lags occured was the following:

There's a process running in the background of MacOS called "WindowServer". It handles all kinds of display activities. If you force quit it from activity monitor you're being kicked out of MacOS back to the login screen. BUT - it consistently solved the lag for a while. Just logged back in again and everything was snappy.
It's feels like some kind of graphical memory leak (don't quote me on that).
Give it a try, sure won't hurt anything.
__________________

iMac Pro
- MacOS 10.14.6
---
- Pro Tools U HDN 2019.6
- Avid HD Omni + HD I/O 8x8x8
- C|24 | S3 | Dock
Reply With Quote
  #13  
Old 02-17-2020, 01:46 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 19,682
Default Re: Gui Lag in 2019.10 on OS 10.13.6

Quote:
Originally Posted by Meads View Post
There's a process running in the background of MacOS called "WindowServer"
Sure. Killing the display manager reverts you to command line interface. Lucky that OSX has automatic restart of dislpay manager so you don't (normally) have to do anything to get GUI login.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #14  
Old 02-17-2020, 01:50 PM
Meads Meads is offline
Member
 
Join Date: Jul 2010
Location: Germany
Posts: 2,903
Default Re: Gui Lag in 2019.10 on OS 10.13.6

Quote:
Originally Posted by JFreak View Post
Sure. Killing the display manager reverts you to command line interface. Lucky that OSX has automatic restart of dislpay manager so you don't (normally) have to do anything to get GUI login.
You don't, and whatever helps, right?
Obviously you shouldn't mess with processes required by the system, and this shouldn't be the solution for the problem. But in this case it is, and I prefer a re-login to a painfully stuttery PT GUI.
__________________

iMac Pro
- MacOS 10.14.6
---
- Pro Tools U HDN 2019.6
- Avid HD Omni + HD I/O 8x8x8
- C|24 | S3 | Dock
Reply With Quote
  #15  
Old 02-17-2020, 02:03 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 19,682
Default Re: Gui Lag in 2019.10 on OS 10.13.6

Right. Slightly faster than cold reboot which UNIX should never have to do, except when you update kernel.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #16  
Old 02-17-2020, 02:06 PM
Meads Meads is offline
Member
 
Join Date: Jul 2010
Location: Germany
Posts: 2,903
Default Re: Gui Lag in 2019.10 on OS 10.13.6

Quite a lot faster. It's instant.
Still, it shouldn't be necessary at all and I wish I knew what causes this behavior in the first place. I sank hours into that, and I'm really glad I found this "dirty fix".
If anybody has a cure I'd gladly take it. I'm just fighting a symptom.
__________________

iMac Pro
- MacOS 10.14.6
---
- Pro Tools U HDN 2019.6
- Avid HD Omni + HD I/O 8x8x8
- C|24 | S3 | Dock
Reply With Quote
  #17  
Old 02-17-2020, 02:10 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 19,682
Default Re: Gui Lag in 2019.10 on OS 10.13.6

If it's a memory leak, nothing cures it except OS update (that fixes window server or graphics driver)
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #18  
Old 02-17-2020, 02:14 PM
Meads Meads is offline
Member
 
Join Date: Jul 2010
Location: Germany
Posts: 2,903
Default Re: Gui Lag in 2019.10 on OS 10.13.6

I don't know, I've posted this back in Feb 2018 for the first time and had experienced it long before that post:

http://duc.avid.com/showthread.php?t=397516

I've seen lots of OS updates, none of which fixed the issue.
And with my current system at home I'm using the same OS (10.14.6) as on my iMac Pro at the studio. The iMac Pro does have the issue, my Hackintosh doesn't.
__________________

iMac Pro
- MacOS 10.14.6
---
- Pro Tools U HDN 2019.6
- Avid HD Omni + HD I/O 8x8x8
- C|24 | S3 | Dock
Reply With Quote
  #19  
Old 02-17-2020, 02:20 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 19,682
Default Re: Gui Lag in 2019.10 on OS 10.13.6

And which GPU (graphics drivers) are we talking about? Hackintosh itself does not explain the (lack of) issue, only software does.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #20  
Old 02-17-2020, 02:30 PM
Meads Meads is offline
Member
 
Join Date: Jul 2010
Location: Germany
Posts: 2,903
Default Re: Gui Lag in 2019.10 on OS 10.13.6



But I've had the same issue with NVidia GPUs on10.13 and below.
__________________

iMac Pro
- MacOS 10.14.6
---
- Pro Tools U HDN 2019.6
- Avid HD Omni + HD I/O 8x8x8
- C|24 | S3 | Dock
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Workspace Borked 2019.10 and 2019.12 KMcK Pro Tools 2019 0 01-17-2020 02:09 PM
2019 iMac vs 2019 Mac Pro Peterjk Pro Tools HDX & HD Native Systems (Mac) 7 01-14-2020 12:23 AM
Install pro tools 2019.10 over 2019.6? Clarkston Guy Pro Tools 2019 6 11-01-2019 08:12 AM
Updating from 2019 .5 to 2019.6? ihate100bees Pro Tools 2019 13 07-04-2019 08:30 AM


All times are GMT -7. The time now is 09:21 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com