Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Pro Tools 2019

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-17-2019, 05:08 AM
XJENSEN XJENSEN is offline
Member
 
Join Date: Dec 2004
Location: Gent, Europe, Belgium
Posts: 83
Default Confusing waveform display for 32 bit float audio files

Today, while optimising my session exchange workflow between Logic Pro X and Pro Tools Ultimate, I stumbled on the inability of Pro Tools to properly render waveform display for 32 bit float audio files.

What I noticed is that, after importing a 32 bit float audio file that goes above 0DBFS, at unity gain, the audio file shows as clipped in the track waveform display. While this is not strictly correct, I can in a way understand this.
However, when I apply clip gain to turn down the gain to get it to proper '24 bit' levels (to not blow the output converters when using hardware inserts on those tracks), the waveform keeps showing as clipped. Therefore, it is impossible to judge whether/where any exaggerate peaks are located in the 32 bit float file and what the safe '24 bit' level should be set at.

Is this how an 'Industry Standard' DAW is supposed to work? Can't even properly display a waveform?

Anyone can chime in on how to deal with this problem? Any workarounds? Greatly appreciate.
Reply With Quote
  #2  
Old 11-17-2019, 09:48 AM
TVPostSound's Avatar
TVPostSound TVPostSound is offline
Member
 
Join Date: Aug 2002
Posts: 3,241
Default Re: Confusing waveform display for 32 bit float audio files

Known issue.
__________________
IMDB
Reply With Quote
  #3  
Old 11-17-2019, 09:50 AM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 17,191
Default Re: Confusing waveform display for 32 bit float audio files

teaches you for proper gain staging
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #4  
Old 11-17-2019, 11:58 AM
XJENSEN XJENSEN is offline
Member
 
Join Date: Dec 2004
Location: Gent, Europe, Belgium
Posts: 83
Default Re: Confusing waveform display for 32 bit float audio files

I thought I found a workaround, but instead I think I may have found yet another bug. Unbelievable.

Workaround: Use AudioSuite Normalize using PEAK setting. This should make sure nothing goes out over 0DBFS. An extra step, but fine for me. Indeed, seems to work and proper waveform is recovered and displayed!

Now, accidentally, I tried to normalise again to 0dB PEAK, but strangely enough, Pro Tools shrunk the audio even further! This should not happen, PEAK should stay PEAK! I'll try to attach a screenshot.

Another bug, right?
Attached Images
File Type: jpg Screen Shot 2019-11-17 at 19.51.29 (2).jpg (65.1 KB, 0 views)
Reply With Quote
  #5  
Old 11-19-2019, 09:32 AM
XJENSEN XJENSEN is offline
Member
 
Join Date: Dec 2004
Location: Gent, Europe, Belgium
Posts: 83
Default Re: Confusing waveform display for 32 bit float audio files

Update:

After about 5 hours on the phone with support, they acknowledge it 'might' be a bug and my two tickets are now forwarded to engineering 'for evaluation'.

Cases:

03827599 Confusing waveform display for 32 bit float audio files
03827668 When iteratively applying AudioSuite Normalize in PEAK mode, Pro Tools keeps shrinking the audio file
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pro Tools 11 Fade Files 32 bit Float bug Matze1985 Pro Tools 11 0 07-31-2014 12:39 PM
Waveform Display drummer9 Pro Tools 9 2 11-27-2010 11:44 AM
PT6 to PT8 waveform display bug? mhuang Post - Surround - Video 4 03-04-2010 01:13 PM
waveform display riozen 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 1 08-05-2005 01:34 PM
Audio files don't display after closing and openin King David Pro Tools TDM Systems (Win) 2 11-23-2004 06:54 AM


All times are GMT -7. The time now is 02:03 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com