Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > Artist Series

Reply
 
Thread Tools Search this Thread Display Modes
  #31  
Old 07-27-2012, 05:59 AM
black_coffee black_coffee is offline
Member
 
Join Date: Jun 2012
Location: London
Posts: 35
Default Re: Avid artist control disconnect

Try this...
1. make sure EuControl is running and your device is connected
2. Go to System Preferences>Security and open the Firewall tab
3. Enable the Firewall... You should get about 3 messages in a row asking if you want to allow certain processes to happen. They have names like MC Client, EUCON... fairly obvious that it has to do with EUCON communication. Say Yes (or OK or Allow... whatever) to all of them.
4. Disable the Firewall

Don't know if that will work for you... I think it's a bug with Bonjour but it seems to work for most people.

D
Reply With Quote
  #32  
Old 08-30-2012, 09:48 AM
Trazan Trazan is offline
Member
 
Join Date: Jan 2009
Posts: 101
Default Re: Avid artist control disconnect

Quote:
Originally Posted by black_coffee View Post
Try this...
1. make sure EuControl is running and your device is connected
2. Go to System Preferences>Security and open the Firewall tab
3. Enable the Firewall... You should get about 3 messages in a row asking if you want to allow certain processes to happen. They have names like MC Client, EUCON... fairly obvious that it has to do with EUCON communication. Say Yes (or OK or Allow... whatever) to all of them.
4. Disable the Firewall

Don't know if that will work for you... I think it's a bug with Bonjour but it seems to work for most people.

D
I'm not using the Control much at the moment so I have to do some more testing before I can really confirm, but for now it seems that this might have done the trick!
Reply With Quote
  #33  
Old 08-31-2012, 06:10 PM
Xill Xill is offline
Member
 
Join Date: May 2011
Location: Planet Earth, Milky Way Galaxy, Observable Universe
Posts: 296
Default Re: Avid artist control disconnect

If I restart my modem/router and restart Eucon I get this :

Quote:
Process: EuControl [18585]
Path: /Applications/Euphonix/EuControl.app/Contents/MacOS/EuControl
Identifier: com.Euphonix.EuControl
Version: 2.6.2 (78202)
Code Type: X86 (Native)
Parent Process: launchd [144]

Date/Time: 2012-08-31 20:07:25.407 -0400
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 499650 sec
Crashes Since Last Report: 7
Per-App Interval Since Last Report: 189814 sec
Per-App Crashes Since Last Report: 1
Anonymous UUID: 5EFCCE41-96D9-4999-90CA-48AEE677AA8E

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000024
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 libEuCon2.dylib 0x00aad725 EuMutex::Lock(unsigned int) + 23
1 com.Euphonix.EuControl 0x00025607 EuObjList<SurfaceInfo>::Count() const + 53
2 com.apple.AppKit 0x9a1bcd59 -[NSTableView numberOfRows] + 142
3 com.Euphonix.EuControl 0x000aa4ff boost::slot<boost::function<void ()(int, int, int, int), std::allocator<void> > >::slot<boost::_bi::bind_t<void, void (*)(objc_object*, int, int, int, int), boost::_bi::list5<boost::_bi::value<GeneralTabView *>, boost::arg<1> (*)(), boost::arg<2> (*)(), boost::arg<3> (*)(), boost::arg<4> (*)()> > >(boost::_bi::bind_t<void, void (*)(objc_object*, int, int, int, int), boost::_bi::list5<boost::_bi::value<GeneralTabView *>, boost::arg<1> (*)(), boost::arg<2> (*)(), boost::arg<3> (*)(), boost::arg<4> (*)()> > const&) + 4325
4 com.Euphonix.EuControl 0x000a9b62 boost::slot<boost::function<void ()(int, int, int, int), std::allocator<void> > >::slot<boost::_bi::bind_t<void, void (*)(objc_object*, int, int, int, int), boost::_bi::list5<boost::_bi::value<GeneralTabView *>, boost::arg<1> (*)(), boost::arg<2> (*)(), boost::arg<3> (*)(), boost::arg<4> (*)()> > >(boost::_bi::bind_t<void, void (*)(objc_object*, int, int, int, int), boost::_bi::list5<boost::_bi::value<GeneralTabView *>, boost::arg<1> (*)(), boost::arg<2> (*)(), boost::arg<3> (*)(), boost::arg<4> (*)()> > const&) + 1864
5 com.apple.CoreFoundation 0x97f6c9b4 -[NSSet makeObjectsPerformSelector:] + 196
6 com.apple.AppKit 0x9a03a1cc -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1566
7 com.apple.AppKit 0x9a0381a4 loadNib + 257
8 com.apple.AppKit 0x9a0377f7 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZonewnerBundle:] + 831
9 com.apple.AppKit 0x9a0374ad +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 158
10 com.apple.AppKit 0x9a0373f8 +[NSBundle(NSNibLoading) loadNibNamedwner:] + 383
11 com.Euphonix.EuControl 0x0009faa0 std::vector<SubViewController*, std::allocator<SubViewController*> >:ush_back(SubViewController* const&) + 148
12 com.Euphonix.EuControl 0x0009e8e0 EuObjList<EuConNodeInfo>::Find(EuConNodeInfo const&) + 402
13 com.Euphonix.EuControl 0x0009f19a EuObjList<EuConNodeInfo>::Find(EuConNodeInfo const&) + 2636
14 com.Euphonix.EuControl 0x0009f589 EuObjList<EuConNodeInfo>::Find(EuConNodeInfo const&) + 3643
15 com.apple.AppKit 0x9a03a21c -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1646
16 com.apple.AppKit 0x9a0381a4 loadNib + 257
17 com.apple.AppKit 0x9a0377f7 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZonewnerBundle:] + 831
18 com.apple.AppKit 0x9a0374ad +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 158
19 com.apple.AppKit 0x9a0c6fcb -[NSWindowController loadWindow] + 223
20 com.apple.AppKit 0x9a05df22 -[NSWindowController window] + 89
21 com.Euphonix.EuControl 0x0002316c HSL::HSLog(HSL::CCat const&, char const*) + 5740
22 com.Euphonix.EuControl 0x00023100 HSL::HSLog(HSL::CCat const&, char const*) + 5632
23 com.apple.AppKit 0x9a0b8a26 -[NSApplication sendAction:to:from:] + 112
24 com.apple.AppKit 0x9a0b88d9 -[NSMenuItem _corePerformAction] + 435
25 com.apple.AppKit 0x9a0b85ca -[NSCarbonMenuImpl performActionWithHighlightingForItemAtIndex:] + 174
26 com.apple.AppKit 0x9a0b84b6 -[NSMenu performActionForItemAtIndex:] + 65
27 com.apple.AppKit 0x9a0b8469 -[NSMenu _internalPerformActionForItemAtIndex:] + 50
28 com.apple.AppKit 0x9a0b83cf -[NSMenuItem _internalPerformActionThroughMenuIfPossible] + 97
29 com.apple.AppKit 0x9a0b8313 -[NSCarbonMenuImpl _carbonCommandProcessEvent:handlerCallRef:] + 336
30 com.apple.AppKit 0x9a0aca55 NSSLMMenuEventHandler + 404
31 com.apple.HIToolbox 0x980c4c2f DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1567
32 com.apple.HIToolbox 0x980c3ef6 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 411
33 com.apple.HIToolbox 0x980e67f3 SendEventToEventTarget + 52
34 com.apple.HIToolbox 0x98112e87 SendHICommandEvent(unsigned long, HICommand const*, unsigned long, unsigned long, unsigned char, void const*, OpaqueEventTargetRef*, OpaqueEventTargetRef*, OpaqueEventRef**) + 448
35 com.apple.HIToolbox 0x98137b90 SendMenuCommandWithContextAndModifiers + 66
36 com.apple.HIToolbox 0x98137b47 SendMenuItemSelectedEvent + 121
37 com.apple.HIToolbox 0x98137a5d FinishMenuSelection(SelectionData*, MenuResult*, MenuResult*) + 152
38 com.apple.HIToolbox 0x982b9364 PopUpMenuSelectCore(MenuData*, Point, double, Point, unsigned short, unsigned int, Rect const*, unsigned short, unsigned long, Rect const*, Rect const*, __CFString const*, OpaqueMenuRef**, unsigned short*) + 1857
39 com.apple.HIToolbox 0x982b96bb _HandlePopUpMenuSelection7 + 678
40 com.apple.AppKit 0x9a3446e6 _NSSLMPopUpCarbonMenu3 + 3937
41 com.apple.AppKit 0x9a5ce596 +[NSStatusBarButtonCell popupStatusBarMenu:inRectfView:withEvent:] + 962
42 com.apple.AppKit 0x9a5d0128 -[NSStatusItem popUpStatusItemMenu:] + 175
43 com.apple.AppKit 0x9a18fa58 -[NSWindow sendEvent:] + 5549
44 com.apple.AppKit 0x9a5cebb3 -[NSStatusBarWindow sendEvent:] + 82
45 com.apple.AppKit 0x9a0a860b -[NSApplication sendEvent:] + 6431
46 com.apple.AppKit 0x9a03c253 -[NSApplication run] + 917
47 com.apple.AppKit 0x9a034289 NSApplicationMain + 574
48 com.Euphonix.EuControl 0x00021a5f POA_EuMC::_repository_id_WSWorkstation_Upcall_Comm and::_repository_id_WSWorkstation_Upcall_Command(P OA_EuMC::WSWorkstation*, TAO_SCOPE::TAO_Operation_Details const*, TAO_SCOPE::TAO::Argument* const*) + 527
49 com.Euphonix.EuControl 0x00002e1a 0x1000 + 7706
Reply With Quote
  #34  
Old 08-31-2012, 06:52 PM
Xill Xill is offline
Member
 
Join Date: May 2011
Location: Planet Earth, Milky Way Galaxy, Observable Universe
Posts: 296
Default Re: Avid artist control disconnect

I've been using my console every day lately, the only way to get it running after a modem restart is to restart Os X. But even then when Eucon initialize after a reboot the consoles freeze and I have to unplug the power from them to restart (power button doesnt turn them off). Very annoying.
Reply With Quote
  #35  
Old 12-21-2013, 02:07 PM
rone2him rone2him is offline
Member
 
Join Date: Dec 2013
Location: Escondido Ca
Posts: 1
Default Re: Avid artist control disconnect

Been having consistent problems with 'Artist Control unit' losing connection since installing EuControl v3.1 tried all corrective measures mentioned here no improvements...

what has worked for me (no disconnection) so far, is to de-install v3.1 and re-install v2.7.1

this isn't my first issue with Avid drivers, for my 'Artist Control unit' in installing v2.7.1, a while back, the unit was (somehow ) damaged, but Avid sent me a new unit (at their choosing & a nominal $ on my part), and everything was fine after it all

So, I will continue to watch this thread, and wait, till there's some indications of a remedy, for disconnects, while using v3.1... would like to have the most recent driver, if it works! ty all 4 your inputs on this issue.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Avid Artist Control + Logic problems. matthihat Artist Series 4 02-03-2019 01:37 AM
How to bypass plug-ins on Avid Artist Control? ryanstewartguitar Artist Series 2 12-18-2013 02:41 PM
Controlling plug-ins with Avid Artist Mix + Control ryanstewartguitar Artist Series 2 11-07-2013 02:07 AM
Avid Artist Control vs Euphonix MC Control? DAWgEAR Artist Series 3 10-22-2012 08:10 AM
Control Surface For Protools 10 Mackie Pro Control or Avid Artist Control lberrios1962 Pro Tools 10 18 05-26-2012 01:51 AM


All times are GMT -7. The time now is 10:32 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com