Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Additional Resources


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools 10 Discussion

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-26-2017, 07:46 PM
springthing springthing is offline
Member
 
Join Date: May 2011
Location: Australia
Posts: 19
Default Help needed with upgrade versions compatibility

I have happily been using PT v9 on OSX 10.6 for many years, and my iMAC hardware system isn't new, but the overall performance has been rock solid so I've resisted upgrading both the software and hardware. I'm not a power user so I haven't been motivated to stay up with the latest and greatest

I recently purchased Izotope's Music Production Bundle 2, and failed to check compatibility, only to find it needs a newer OSX and PT.

I'm keen to try and only upgrade as high as PT10, to still have the option of RTAS plugins, and plus also that's all I think I need. But I'm finding it difficult to confirm which is the ideal OSX to ensure I can use PT10 with RTAS support, along with IZotope's bundle.

Izotope's specs say for Neutron Advanced to work you must have OS X 10.9–10.12, and Pro Tools 10-12
https://www.izotope.com/en/products/...dle/specs.html

However Avid's compatibility chart, shows that PTs 10 is not supported after OSX 10.8.5
http://avid.force.com/pkb/articles/c...tibility-Chart

So from user experience here, can anyone recommend, which version of OSX/PT combination I should aim to upgrade to solve my situation???

I know the 'simple' option is to just do away with RTAS support, and go with the latest supported version of OSX and PT, but I'm also worried how that is going to affect my aging machine's performance...

Any suggestions would be most appreciated.

Mike
Reply With Quote
  #2  
Old 07-08-2017, 09:42 AM
springthing springthing is offline
Member
 
Join Date: May 2011
Location: Australia
Posts: 19
Default Re: Help needed with upgrade versions compatibility

...Bump

...Any advice would be appreciated
Reply With Quote
  #3  
Old 07-08-2017, 12:29 PM
Manu101 Manu101 is offline
Member
 
Join Date: Sep 2012
Location: Greater Montreal, Quebec, Canada
Posts: 109
Default Re: Help needed with upgrade versions compatibility

PT10 works with OSX 10.9 (see this post:)
Quote:
Originally Posted by JFreak View Post
PT10 and Mavericks is a *WORKING* configuration. It is not officially supported due to known issues, but it works. Most notable issue is with the uninstaller so that makes updates a little harder to do, but for most part, PT10 WORKS with 10.9

Now if you want to stay clean and update PT10 to new version whenever one comes out, here's what you should do:
- Backup everything and make a super fresh clean install of Mavericks
- Install every software you need to use, EXCEPT PT10
- Clone that system drive to some disk image

And once new PT10 update is out, just clone back from your super fresh system drive disk image and install PT10.
From experience, PT10 will not run well on Yosemite (10.10)
__________________
Manu

i7 7800X - Win10 - PT12HD - TC Electronic Studio Konnekt 48 - Euphonix MC Mix (2) & Transport - Equator D8 5.1 system - Tannoy TS10 Sub
Reply With Quote
  #4  
Old 07-08-2017, 07:03 PM
Ben Jenssen's Avatar
Ben Jenssen Ben Jenssen is offline
Member
 
Join Date: May 2000
Location: Oslo
Posts: 2,788
Default Re: Help needed with upgrade versions compatibility

I would stick with what you got. You know it's working. Find another way to acheive wat you wanted with izotope, and sell the bundle. I really don't think there's a wy to make it worK, what you're wanting; a incremental upgrade of old both OS and PT.
Reply With Quote
  #5  
Old 07-09-2017, 05:39 AM
springthing springthing is offline
Member
 
Join Date: May 2011
Location: Australia
Posts: 19
Default Re: Help needed with upgrade versions compatibility

@ Manu101

Thanks for raising that existing information. I had also seen something on the Avid site (under compatibility) stating the same thing, where 'PT10 WORKS with 10.9' albeit without the uninstall feature. Which I don't see as a big deal. I just need a working version! It certainly seems worth trying to install version 10.3 to see how it runs.

@ Ben

That's more or less what I've been doing since version 9, just sticking with what I've got, and it has been rock solid. But I'd like to start incorporating the iZotope software (I'm a big fan of their products), which they have confirmed doesn't run on Pro Tools 9

My best bet, seems to be trying to get a set up running OSX Maverick 10.9, and hopefully seeing if I can get a stable version of PT10 to run on this OSX, which should run my old RTAS plug ins and the latest iZotope Production Bundle...?
Reply With Quote
  #6  
Old 07-09-2017, 05:50 AM
Ben Jenssen's Avatar
Ben Jenssen Ben Jenssen is offline
Member
 
Join Date: May 2000
Location: Oslo
Posts: 2,788
Default Re: Help needed with upgrade versions compatibility

Not shure if it's even possible to buy 9-10 upgrade anymore.
Reply With Quote
  #7  
Old 07-10-2017, 02:51 AM
springthing springthing is offline
Member
 
Join Date: May 2011
Location: Australia
Posts: 19
Default Re: Help needed with upgrade versions compatibility

If I read it correctly here - http://shop.avid.com/ccrz__ProductDetails?sku=DYNA20008

It comes with licenses for 10/11/12.
Reply With Quote
  #8  
Old 07-11-2017, 10:14 AM
panamajack's Avatar
panamajack panamajack is offline
Member
 
Join Date: Jan 2011
Location: Miniappleapolis
Posts: 605
Default Re: Help needed with upgrade versions compatibility

I have PT10.3.10 HD3 running under Mavericks. I also used the manual "uninstall" to remove PT10HD, on a system which had been upgraded to El Capitan, and the uninstall worked without hitch from an MP tower. The graphics pull-down windows got weird when I ran PT10 on Yosemite, but PT11 runs okay on Yosemite.

I have two 4K monitors running under Mavericks with a Radeon HD5870. Not a great card, but with Mountain Lion I could only get one 4K monitor and one 2K monitor to work. The video drivers in Mavericks are upgraded and some of the plug-ins require Mavericks.
__________________
PT10.3.10HD(Tyan s2932 [8core Shanghai 2.7GHZ] 32GB,Win7 SP1); PT10HD(Tyan s2892 w/10GB, Win7 SP1);PT8HD(Dell 690 quad Xeon 3.0, 8GB, Win7,192 I/O, 96 I/O);MacBook Pro: 11R, Apogee Element 46, Focusrite 8PreX PT HD 11.3.2; Mac Pro Neh 2.66 Quad 8GB, OSX 10.11.6/L10.3.1;L9.1.8, 2.64TB; G5 D2.3 4GB, 10.4.11/L8; 12c MP 2.66/32GB PT12.4; Structure, GigaGS3, Kontakt 5, Garratin, Sibelius 8.5.1, Finale25,EMU,Vegas Pro 12/11/10/; RME HDSP9652,MOTU 2408 MKIII/1224/308, FX,Kurz,L5s,Strat,ASAT,JB,Zon
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mac Versions compatibility dedalus 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 07-29-2011 07:06 AM
PT 8 HD/PT9 Compatibility, 10.6.5 compatibility, OMF Logic9/PT9, iLok upgrade benosullivan Pro Tools 9 Discussion 2 11-17-2010 12:05 PM
McDSP: Compatibility across PT versions RenderBot Post - Surround - Video 7 07-19-2006 10:41 AM
session compatibility between versions AND platforms Craig5024 Tips & Tricks 1 07-22-2003 01:12 PM
PT versions compatibility blanos112 Pro Tools TDM Systems (Mac) 3 04-09-2002 06:50 AM


All times are GMT -7. The time now is 11:14 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com