Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-09-2013, 03:35 PM
darkgoob darkgoob is offline
Member
 
Join Date: Aug 2007
Posts: 48
Default 002 Rack w/LE 8.. upgrade options?

I have an 002 Rack which came with PT LE 6 that I later upgraded to version 8.

Version 8.0.5 works fine on my Mountain Lion 10.8.4 installation except I can't use the 002 Rack's MIDI ports, and evidently I can't install a working CoreAudio driver.

So... what are my options today if I want to use Pro Tools on my Mac, and also be able to use the MIDI ports of the 002 Rack, and be able to use the 002 Rack via CoreAudio applications like Logic and DP?

I saw that Pro Tools 10.3 is qualified for my system... I would consider upgrading if it was under $200, but since I don't really need any of the new features of PT 10, and I am perfectly happy with the features of Pro Tools 8, there is no way I am going to drop $400.

At this point I just want the drivers to work correctly. Can someone explain to me why that is too much to ask, please?

All the other hardware manufacturers like MOTU, Metric Halo, Apogee, etc. have no problem keeping their CoreAudio and MIDI drivers up to date within a couple of weeks of the release of a new version of OS X. Can someone please explain to me what is wrong with Avid that they are somehow unable to do this?

Personally, I was really hoping when Avid bought Digidesign, they would fire all the incompetent driver programmers, hire some competent ones, and we owners of Digidesign hardware audio interfaces would no longer be forced to suffer like third-world-citizens, forced to use ancient versions of the OS because of the inadequacy of programmers who get paid very high wages and yet fail to actually do their job, which is to support their customers.

Yet here it is, September 2013, and 10.9 is almost out... yet still my Pro Tools 8.0.5 cannot use the MIDI on my 002 Rack and I'm expected to cough up $400 as a result of this. Well look, Avid, you know better than that. If you treat people like me the right way, then perhaps we will be willing to upgrade to the next version for the right reasons (i.e. because we want the features of that new version). However if you treat people like me the wrong way, we will not remain as your customers, because why would we invest more money into a "solution" that is likely to become obsolete within a matter of weeks? Even if PT 10.3 works with Mountain Lion, as soon as I update my Mac to Mavericks and it's broken again, will you then charge me another $400 for the privilege of being able to use the hardware interface that I purchased for $1300 only a few years ago?

Because if I am going to have to spend money to use my interface, then what motivation would I have to even use Pro Tools anymore, when I could get Logic Pro X for $200 and it will work better with my old interface on the latest system than your own software would? What I don't understand is, why can't Avid offer a competitive price for cross-grades? And why can't you issue driver updates within a reasonable timeframe?

Or is there something I'm missing here? Is there an easy way to get PT 8.0.5 to work on Mountain Lion with the latest drivers that I've somehow missed?
Reply With Quote
  #2  
Old 09-16-2013, 01:14 PM
darkgoob darkgoob is offline
Member
 
Join Date: Aug 2007
Posts: 48
Default Re: 002 Rack w/LE 8.. upgrade options?

I found that I can install the version 11 drivers and use 002 with the CoreAudio apps. Then if I go to terminal and use launchctl to remove com.Avid.* then power cycle the 002, I can open PT 8.0.5 with no issues. But MIDI port on 002 won't work, no problem, I just use another MIDI interface.
Reply With Quote
  #3  
Old 09-16-2013, 03:59 PM
albee1952 albee1952 is online now
Member
 
Join Date: May 2004
Location: Norwich, CT
Posts: 35,391
Default Re: 002 Rack w/LE 8.. upgrade options?

The midi issue is likely not drivers, maybe the circuit board has an issue(but as you said, its easy to use another midi interface). Midi always worked fine for me on the 002, and on my current 003, but I also use a MOTU Fastlane USB 2x2. As for upgrade options, PT10 works great and has several nice features over the old LE version. Plus, if you can find it, 10HD software will also work, and give you all features of the CPTK2(running 10HD with my 003 now). Can't make any promises with PT11, but since 9 and up allow you to use almost any interface(from any company) including the onboard audio of your Mac, upgrading seems a no-brainer
__________________
Gigabyte X79/intel i7 3930K, 32GB RAM, DIGI003 Rack
https://www.facebook.com/search/top/...0sound%20works


The better I drink...the more I mix.....

BTW, my name is Dave, but most people call me.........................Dave
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mac Pro/G5 Rack Alternatives/Options gsilbers Pro Tools TDM Systems (Mac) 19 06-06-2011 06:54 PM
VI Rack options? nikki-k Pro Tools 9 2 11-12-2010 06:26 AM
FOH Rack Options james tebb VENUE Live Sound Systems 2 02-28-2010 01:56 PM
Monitoring Options With 003 Rack Blank Frank 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 2 05-11-2008 08:23 PM
Sync I/O options with 002 Rack audiobob 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 3 01-10-2007 12:56 AM


All times are GMT -7. The time now is 11:42 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com