Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > macOS

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-19-2015, 02:06 PM
citysoundman citysoundman is offline
Member
 
Join Date: Aug 2002
Location: New York City
Posts: 546
Default PT 10 HD crashes on launch - please help!

My system:
PT 10 HD Accel2, v10.3.8 on OSX 10.7.5 MacPro (2009) w/ 24GB RAM

A couple of days ago, after installing & uninstalling a Source Connect plug-in, PT now always crashes when launching. It goes through the launch process and gets to the end - to the 'Open Session' dialog - but then the spinning ball starts, and then I get the error "PT Quit Unexpectedly".

Here's what I did, but nothing has helped
Trashed all the prefs
I did a clean uninstall and reinstall of PT
Removed all third party plug-ins
Reset PRAM
Repaired permissions
Repaired startup drive
*I did discover a couple of hard drive errors, and I was able to fix them with Disk Utility. There were a few bad blocks. But now the drive checks out fine.

Fortunately I have a cloned startup drive, which was cloned a few weeks ago. When I boot from this clone PT launches fine. I'd like to see if I can fix my main startup drive since this clone is a few weeks old.

The error log is too long to paste the whole thing so I've attached it as a PDF. But here's the beginning of it in case it helps:

Unexpected Quit Report.pdf

Identifier: com.digidesign.ProTools
Version: 10.3.8.378 (10.3.8f378)
Build Info: Unknown-10380378~378
Code Type: X86 (Native)
Parent Process: launchd [166]

Date/Time: 2015-01-19 16:47:26.828 -0500
OS Version: Mac OS X 10.7.5 (11G63b)
Report Version: 9

Interval Since Last Report: 10542037 sec
Crashes Since Last Report: 413
Per-App Interval Since Last Report: 4466676 sec
Per-App Crashes Since Last Report: 44
Anonymous UUID: 07686538-54A9-4B06-B8CC-ACC0635B0C79

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000020000000

VM Regions Near 0x20000000:
MALLOC_LARGE 0000000016800000-000000001683e000 [ 248K] rw-/rwx SM=PRV
-->
__TEXT 000000008fe9e000-000000008fed1000 [ 204K] r-x/rwx SM=COW /usr/lib/dyld

Application Specific Information:
objc_msgSend() selector name: applicationDidBecomeActive:
objc[357]: garbage collection is OFF

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libobjc.A.dylib 0x91671d4b objc_msgSend + 27
1 com.apple.Foundation 0x9345ddf1 __-[NSNotificationCenter addObserver:selector:namebject:]_block_invoke_1 + 49
2 com.apple.CoreFoundation 0x9c8c7903 ___CFXNotificationPost_block_invoke_1 + 275
3 com.apple.CoreFoundation 0x9c892688 _CFXNotificationPost + 2776
4 com.apple.Foundation 0x93448fde -[NSNotificationCenter postNotificationNamebject:userInfo:] + 92
5 com.apple.Foundation 0x9345e272 -[NSNotificationCenter postNotificationNamebject:] + 55
6 com.apple.AppKit 0x91b4a883 -[NSApplication sendEvent:] + 3008
7 com.apple.AppKit 0x9225bdf5 _appActivationHandler + 547
8 com.apple.AppKit 0x9225b5cc carbonAppApplicationHandler + 108
9 com.apple.HIToolbox 0x928e8c0c _InvokeEventHandlerUPP(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*, long (*)(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*)) + 36
10 com.apple.HIToolbox 0x92764313 _ZL23DispatchEventToHandlersP14EventTargetRecP14Op aqueEventRefP14HandlerCallRec + 1602
11 com.apple.HIToolbox 0x92763790 _ZL30SendEventToEventTargetInternalP14OpaqueEventR efP20OpaqueEventTargetRefP14HandlerCallRec + 482
12 com.apple.HIToolbox 0x927635a8 SendEventToEventTargetWithOptions + 75
13 com.apple.HIToolbox 0x927791c6 _ZL29ToolboxEventDispatcherHandlerP25OpaqueEventHa ndlerCallRefP14OpaqueEventRefPv + 3152
14 com.apple.HIToolbox 0x927647ce _ZL23DispatchEventToHandlersP14EventTargetRecP14Op aqueEventRefP14HandlerCallRec + 2813
15 com.apple.HIToolbox 0x92763790 _ZL30SendEventToEventTargetInternalP14OpaqueEventR efP20OpaqueEventTargetRefP14HandlerCallRec + 482
16 com.apple.HIToolbox 0x92778571 SendEventToEventTarget + 76
17 com.apple.HIToolbox 0x928e8a58 ToolboxEventDispatcher + 82
18 com.apple.HIToolbox 0x928e8a8e HLTBEventDispatcher + 17
19 com.apple.HIToolbox 0x928e9700 _RunAppModalLoop + 150
20 com.apple.HIToolbox 0x928e9c0e RunAppModalLoopForWindow + 136
21 com.digidesign.framework.DFW 0x00700cc1 DFW_EventLoop::WaitModalState(TWindow*) + 113
22 com.digidesign.framework.DFW 0x005a2bf1 TDocument::PoseSaveDialog() + 2001
23 com.digidesign.framework.DFW 0x0055d7f9 TWindow::PoseModally() + 169
24 com.digidesign.framework.ProTools 0x0ce2ef23 LaunchProTools + 482771
25 com.digidesign.framework.ProTools 0x0c28b763 MFortressHWBPEntryPoint_exit_mfort6317_ + 15845817
26 com.digidesign.framework.ProTools 0x0c289a93 MFortressHWBPEntryPoint_exit_mfort6317_ + 15838441
27 com.digidesign.framework.DFW 0x005cc56a TNewDocumentCommand:oIt() + 42
28 com.digidesign.framework.DFW 0x0059a78b TCommandHandler::PerformCommand(TCommand*) + 187
29 com.digidesign.framework.DFW 0x0059b0df TCommand::Process() + 31
30 com.digidesign.framework.DFW 0x00590b8a TApplication::ProcessEvent(TEvent*) + 26
31 com.digidesign.framework.DFW 0x005914a0 TApplication::WakeUp() + 64
32 com.digidesign.framework.DFW 0x006f751b TApplication::CreateNewOSApplication(void*, void*, void*) + 667
33 com.apple.HIToolbox 0x928e8c0c _InvokeEventHandlerUPP(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*, long (*)(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*)) + 36
34 com.apple.HIToolbox 0x92764313 _ZL23DispatchEventToHandlersP14EventTargetRecP14Op aqueEventRefP14HandlerCallRec + 1602
35 com.apple.HIToolbox 0x92763790 _ZL30SendEventToEventTargetInternalP14OpaqueEventR efP20OpaqueEventTargetRefP14HandlerCallRec + 482
36 com.apple.HIToolbox 0x927635a8 SendEventToEventTargetWithOptions + 75
37 com.apple.HIToolbox 0x927791c6 _ZL29ToolboxEventDispatcherHandlerP25OpaqueEventHa ndlerCallRefP14OpaqueEventRefPv + 3152
38 com.apple.HIToolbox 0x927647ce _ZL23DispatchEventToHandlersP14EventTargetRecP14Op aqueEventRefP14HandlerCallRec + 2813
39 com.apple.HIToolbox 0x92763790 _ZL30SendEventToEventTargetInternalP14OpaqueEventR efP20OpaqueEventTargetRefP14HandlerCallRec + 482
40 com.apple.HIToolbox 0x92778571 SendEventToEventTarget + 76
41 com.apple.HIToolbox 0x928e8a58 ToolboxEventDispatcher + 82
42 com.apple.HIToolbox 0x928e8b87 RunApplicationEventLoop + 236
43 com.digidesign.framework.DFW 0x00700a5b DFW_EventLoop::RunApplicationEventLoop() + 11
44 com.digidesign.framework.DFW 0x00590c5d TApplication::Run() + 45
45 com.digidesign.framework.ProTools 0x0cdb81b1 MFortressHWBPEntryPoint_exit_mfort6317_ + 27563015
46 com.digidesign.framework.ProTools 0x0cdb96d4 LaunchProTools + 1412
47 com.digidesign.ProTools 0x0000f277 0x1000 + 57975
48 com.digidesign.ProTools 0x0001037a 0x1000 + 62330
49 com.digidesign.ProTools 0x0000effd 0x1000 + 57341
__________________
Bob Kirschner
Chief Engineer
Creative Media Design, NYC
http://cmdnyc.com
bob@cmdnyc.com
Reply With Quote
  #2  
Old 01-20-2015, 08:24 AM
albee1952 albee1952 is offline
Member
 
Join Date: May 2004
Location: nashville
Posts: 34,631
Default Re: PT 10 HD crashes on launch - please help!

If all else fails, you could clone in the other direction Meanwhile, I would look thru all the plugins folders for any remnants of that Source Connect plugin that may have been left behind.
__________________
Gigabyte X79/intel i7 3930K, 32GB RAM, DIGI003 Rack
https://www.facebook.com/search/top/...0sound%20works


The better I drink...the more I mix.....

BTW, my name is Dave, but most people call me.........................Dave
Reply With Quote
  #3  
Old 01-20-2015, 09:51 AM
citysoundman citysoundman is offline
Member
 
Join Date: Aug 2002
Location: New York City
Posts: 546
Default Re: PT 10 HD crashes on launch - please help!

Hi Albee,

I was careful to remove all 3rd party plug-ins when testing, but thanks for the suggestion. This problem has really got me confused.

Now I'm suspicious of the drive itself. The bad blocks, even though now corrected, worries me. Am I wrong to be worried about this? It's not a super old drive.

Can anyone look at the log and tell me if it is a software problem, vs. as hardware problem??

Thanks.
__________________
Bob Kirschner
Chief Engineer
Creative Media Design, NYC
http://cmdnyc.com
bob@cmdnyc.com
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PT 9 crashes on launch!! robotboy Pro Tools 9 7 08-02-2014 07:40 AM
10.3.3 crashes on launch gtomassetti macOS 14 12-23-2012 03:49 PM
Crashes at launch Vepse 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 4 06-11-2011 01:44 AM
PT8 Crashes on launch sonicapg 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 4 03-12-2009 08:06 AM
G5 crashes on launch oi41 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 05-11-2004 12:36 PM


All times are GMT -7. The time now is 02:16 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com