Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools 12

Reply
 
Thread Tools Search this Thread Display Modes
  #151  
Old 11-11-2017, 03:31 PM
Tweakhead Tweakhead is offline
Member
 
Join Date: Aug 2000
Posts: 1,547
Default Re: Gui lag 12.8.2

Quote:
Originally Posted by Eric Lambert View Post
I'm not sure if people remember the discussions happening when the subscription plan was first rumored but this is essentially what was predicted. It's not unlike Pharma: there's no money in the cure. Go soft on repairing bugs and customers will *need* the subscription plan.

Think about the reasons we spend ~$400/year on the plan. New features, yes, although those have been INCREDIBLY slow to materialize. It's to stay current. To receive the bug fixes. To allow new OS updates and ensure PT compatibility.

Anyone who's been following this topic will notice how frequently the app takes a step backwards since the Plan began. No, I doubt bugs are *introduced* intentionally, but it's equally incompetent and devious, yes, to intentionally ignore those repairs. If anyone thinks this process isn't discussed in closed board meetings or, more likely, while playing 18 holes you're just being naive or overly loyal.
This ^^ is perhaps the most important post I've ever read on this forum.
Reply With Quote
  #152  
Old 11-11-2017, 10:37 PM
southxbrandon southxbrandon is offline
Member
 
Join Date: Jul 2015
Location: NASHVILLE
Posts: 1
Default Re: Gui lag 12.8.2

I have GUI lag on my system like many others on this thread.

macos 10.12.6, mac pro 6,1 (trash can) w 64gb ram and 12 core processor, pro tools hd native (thunderbolt) 12.8.2 R2.

i'm using a 4k led tv as my main monitor and i have a dell 27" as a secondary monitor. lag tends to be way worse on the main display. as an experiment, i just turned my resolution down to 1080p. the picture looks awful, but the lag is nearly gone. thought i'd share as it may be worth it for others to experiment with resolution settings.
Reply With Quote
  #153  
Old 11-12-2017, 12:05 AM
Blues Bird Blues Bird is offline
Member
 
Join Date: Apr 2010
Posts: 72
Default Re: Gui lag 12.8.2

Quote:
Originally Posted by Eric Lambert View Post
I'm not sure if people remember the discussions happening when the subscription plan was first rumored but this is essentially what was predicted. It's not unlike Pharma: there's no money in the cure. Go soft on repairing bugs and customers will *need* the subscription plan.

Think about the reasons we spend ~$400/year on the plan. New features, yes, although those have been INCREDIBLY slow to materialize. It's to stay current. To receive the bug fixes. To allow new OS updates and ensure PT compatibility.

Anyone who's been following this topic will notice how frequently the app takes a step backwards since the Plan began. No, I doubt bugs are *introduced* intentionally, but it's equally incompetent and devious, yes, to intentionally ignore those repairs. If anyone thinks this process isn't discussed in closed board meetings or, more likely, while playing 18 holes you're just being naive or overly loyal.
Ever heard of Hanlon‘s Razor?

It says:“Never attribute to malice that which is adequately explained by stupidity"
Reply With Quote
  #154  
Old 11-12-2017, 06:00 AM
Fidelis Fidelis is offline
Member
 
Join Date: May 2001
Location: Sao Paulo - Brazil
Posts: 978
Default Re: Gui lag 12.8.2

Quote:
Originally Posted by Eric Lambert View Post
I'm not sure if people remember the discussions happening when the subscription plan was first rumored but this is essentially what was predicted. It's not unlike Pharma: there's no money in the cure. Go soft on repairing bugs and customers will *need* the subscription plan.

Think about the reasons we spend ~$400/year on the plan. New features, yes, although those have been INCREDIBLY slow to materialize. It's to stay current. To receive the bug fixes. To allow new OS updates and ensure PT compatibility.

Anyone who's been following this topic will notice how frequently the app takes a step backwards since the Plan began. No, I doubt bugs are *introduced* intentionally, but it's equally incompetent and devious, yes, to intentionally ignore those repairs. If anyone thinks this process isn't discussed in closed board meetings or, more likely, while playing 18 holes you're just being naive or overly loyal.
+1000 on this. Best post ever! Also a 20+ user and not happy at all.
__________________
http://www.ricardomosca.com

Intel Mac Pro 12 core 3.33 GHz, 20GB RAM, OSX 10.10.5, PT HDX, PT 12.8, SSL 4040G+, tons of outboard
Mac Book Pro 2.4Ghz Duo, 4GB RAM, OSX 10.10.5, PT Vanilla 12.8
Reply With Quote
  #155  
Old 11-12-2017, 06:33 AM
RyanC RyanC is offline
Member
 
Join Date: Apr 2003
Posts: 638
Default Re: Gui lag 12.8.2

Same sort of problems here, not all the time, but when it's bad it's nearly unusable.

Also a lot of times the smart tool isn't changing icons based on mouse position over clips. The functions still change, but the on screen icon doesn't.

Hopefully the roll out a fix for this one asap.
Reply With Quote
  #156  
Old 11-12-2017, 12:46 PM
lesbrunn lesbrunn is offline
Member
 
Join Date: Feb 2002
Location: Accra, Ghana
Posts: 576
Default Re: Gui lag 12.8.2

Quote:
Originally Posted by RyanC View Post
Same sort of problems here, not all the time, but when it's bad it's nearly unusable.

Also a lot of times the smart tool isn't changing icons based on mouse position over clips. The functions still change, but the on screen icon doesn't.

Hopefully the roll out a fix for this one asap.
Yes, hopefully, but then something else would definitely be broken...
__________________
X99 | i7 5820 | 64GB GSkill DDR4 | Nvidia GTX 950 | Samsung 950 Pro 256GB | Kingston 120GB SSD | Samsung 850 EVO 1TB | Samsung MZ7PD256HAFV-000H7 SSD 256GB | WD Black 1TB x2 | G-Drive 4TB | Audient ID14 | PT12.8.1 | Windows 10 Pro
Reply With Quote
  #157  
Old 11-12-2017, 01:23 PM
marsian marsian is offline
Member
 
Join Date: Aug 2008
Location: Germany
Posts: 126
Default Re: Gui lag 12.8.2

AVID Support told me, that this bug is logged and that they are working on it. They said, that it should be solved in one oft the next releases (not very promising). It was introduced by the changes in OSX graphics (Metal) with El Capitan and couldn't be solved till today.
It doesn't create confidence in AVIDs software development, that things like that need such a long time.

Cheers
Maik
__________________
PT HDN 2018.12, OMNI, SYNC HD, S3, PT Control, MacPro 5,1 12core 24GB, OSX 10.12.6, BM Decklink Extreme 3D v.10.9.10
------------
mars13.de
Reply With Quote
  #158  
Old 11-12-2017, 02:48 PM
Cacov's Avatar
Cacov Cacov is offline
Member
 
Join Date: Nov 2016
Location: Worldwide
Posts: 143
Default Re: Gui lag 12.8.2

Quote:
Originally Posted by marsian View Post
AVID Support told me, that this bug is logged and that they are working on it. They said, that it should be solved in one oft the next releases (not very promising). It was introduced by the changes in OSX graphics (Metal) with El Capitan and couldn't be solved till today.
It doesn't create confidence in AVIDs software development, that things like that need such a long time.

Cheers
Maik
Good to hear they are aware and "working on it", but the explanation from the support guy sounds like total BS, because PT 12.8.1 GUI works perfectly fine on macOS Sierra and on unsupported mac OS High Sierra. And even worse: if it was true, and they are "trying" to fix it since the release of El Capitan, they are completely off track with the solution.
__________________
macOS High Sierra | Apogee Groove & Symphony I/O | Pro Tools 2018

Non-Avid Employee | Sound Engineer

Last edited by Cacov; 11-12-2017 at 06:16 PM.
Reply With Quote
  #159  
Old 11-12-2017, 03:23 PM
KV626's Avatar
KV626 KV626 is offline
Member
 
Join Date: Mar 2014
Location: Paris/Montreal
Posts: 450
Default Re: Gui lag 12.8.2

Quote:
Originally Posted by marsian View Post
AVID Support told me, that this bug is logged and that they are working on it. They said, that it should be solved in one oft the next releases (not very promising). It was introduced by the changes in OSX graphics (Metal) with El Capitan and couldn't be solved till today.
It doesn't create confidence in AVIDs software development, that things like that need such a long time.
El Capitan came 2 years ago, and after 2 years they still haven't found a way to fix this bug? tssssss.... Oh and of course PT doesn't use Metal so there you go. So the fact that 12.7.x or 12.8.1 have no lag is what, just "luck"? If that's all "support" can come up with to justify 12.8.2's poor UI performance well that's just sad.
__________________
Mac Pro 5,1 (Mid-2012) 12-core 2 x 3.3 GHz / MSI RX 560 / 40GB ram / macOS 10.14.5 / Pro Tools 2019.5 / Logic Pro X 10.4.4
Arturia Keylab 88 Presonus Faderport 8 MOTU 896 iPad Air 2 w/ PT Control
NI Komplete Ultimate 11 • Albion One • Soundiron Choirs • Pianoteq • Analog Lab • VSL SE/Chamber Strings • etc
Reply With Quote
  #160  
Old 11-12-2017, 09:28 PM
Anibal Anibal is offline
Member
 
Join Date: Dec 1969
Location: L.A. CA. USA
Posts: 545
Default Re: Gui lag 12.8.2

Agreeing 100% with Eric Lambert... I have the same problem, it slows me down and frustrates me... why do we have to deal with this kind of incompetence?
__________________
PT 2018 HDX 1
Mac Pro Westmere 12 core 3.46 OSX 10.12.5
64 gig ram
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:19 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com