Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > Pro Tools HDX & HD Native Systems (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-14-2020, 03:26 PM
smokeydan smokeydan is offline
Member
 
Join Date: May 2010
Location: Manchester UK
Posts: 53
Default CPU spike and errors on PT Ultimate/HDX system

Hi All,

We finally finished a couple of long-standing projects, so I thought now would be a great time to update ProTools to the latest version (2019.10 or .12) I was hoping that the updates to the AAE and firmware update to the HDX cards (that came with 2019.5?) would resolve some of the CPU issues we have had ever since we bought the HDX set up and the then new Mac Pro 6,1 two years ago. But so far it appears not.

We’re on High Sierra, with 2 x HDX cards in a Sonnet TB2 PCI chassis. I cannot run most sessions at a low buffer setting due to CPU spikes and 9093, 9171 errors etc. Since doing the update today, CPU usage generally (according to PT’s CPU usage meters!) appears to have dropped significantly, but on lower buffer settings (even on 512 in some instances) there are regular CPU spikes and errors which halt playback. Recording audio isn’t too much of an issue at the higher buffer setting, we can just route directly to the stereo bus and there's next to no latency whilst recording. But for tracking midi on VIs, the latency is a big issue at higher buffers.

I have established that certain plug ins are causing more issues than others. Altiverb is one (but not the only one) for example. I have a session with just 2 audio channels, 2 aux channels and two instances of Altiverb which will not run at the lowest buffer setting on PT HDX without regular CPU spikes and error messages, even spikes occasionally at 256 (but is fine on any native system I have tried it on)

What I would like to establish, is whether it just our PT HDX system, or whether this issue can be replicated on other PT HDX systems? I’d be particularly interested to know whether the issue is the same with a PT HDX system running the HDX card in a Mac Pro 5,1 rather than in a TB / PCI expansion chassis on a newer Mac.

If anyone (who has HDX cards and also Altiverb) cares to take a look and report back, it would be much appreciated. Try running the session in loop playback at the lowest buffer setting.

Also - since updating today, I have noticed that PT kind of freezes for a minute or so (spinning beach ball) after changing the buffer setting - something that wasn’t happening before.

Anybody else getting this after the firmware update that came with (I think) PT 2019.5?

Download link
https://we.tl/t-JECgUL2hJv


Many thanks

Dan
__________________
Mac Pro 5,1, 2 x 3.46Ghz six core Xeon, 64GB RAM, High Sierra, PT Ultimate 2019.12, H/D Native PCie, Omni interface.
Mac Pro 6,1 12 core, 64GB RAM, High Sierra, PT Ultimate 2019.12, 2xHDX cards in Sonnet TB Chassis, 2 x Lynx Aurora 16 interfaces.
MacBook Pro 32GB RAM Catalina, PT 2020.3, non-functioning MBox 3 Pro
Reply With Quote
  #2  
Old 03-14-2020, 03:43 PM
YYR123's Avatar
YYR123 YYR123 is offline
Member
 
Join Date: Dec 2010
Location: Austin TX
Posts: 13,737
Default Re: CPU spike and errors on PT Ultimate/HDX system

Quote:
Originally Posted by smokeydan View Post
Recording audio isn’t too much of an issue at the higher buffer setting, we can just route directly to the stereo bus and there's next to no latency whilst recording. But for tracking midi on VIs, the latency is a big issue at higher buffers.
This is my only gripe with HDX, I wish I could get low latency vi’s as well as my audio streams
__________________
Daniel
HDX - PT12.5.1 - HD I/O 16x8x8
Win10-Pro (v1709)- 6 Core i7-6850k - ASUS X99 Deluxe ii
D-Command Main Unit - 'Ole Blue


http://www.sknoteaudio.com/ plugins rock and are affordable.
Reply With Quote
  #3  
Old 03-14-2020, 07:43 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 19,364
Default Re: CPU spike and errors on PT Ultimate/HDX system

PT 2020.x is right around the corner. I recommend you wait for it.
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #4  
Old 03-15-2020, 10:19 AM
smokeydan smokeydan is offline
Member
 
Join Date: May 2010
Location: Manchester UK
Posts: 53
Default Re: CPU spike and errors on PT Ultimate/HDX system

Quote:
Originally Posted by JFreak View Post
PT 2020.x is right around the corner. I recommend you wait for it.
I'd like to think so. But PT12 didn't cure it. nor did various versions of 2018 or 2019. So I'm not going to hold my breath!!
__________________
Mac Pro 5,1, 2 x 3.46Ghz six core Xeon, 64GB RAM, High Sierra, PT Ultimate 2019.12, H/D Native PCie, Omni interface.
Mac Pro 6,1 12 core, 64GB RAM, High Sierra, PT Ultimate 2019.12, 2xHDX cards in Sonnet TB Chassis, 2 x Lynx Aurora 16 interfaces.
MacBook Pro 32GB RAM Catalina, PT 2020.3, non-functioning MBox 3 Pro
Reply With Quote
  #5  
Old 03-15-2020, 09:29 PM
clivvy clivvy is offline
Member
 
Join Date: Jan 2016
Location: philadelphia
Posts: 80
Default Re: CPU spike and errors on PT Ultimate/HDX system

its a moon shot won't hold my breath on the cpu spikes fix!
Reply With Quote
  #6  
Old 03-15-2020, 09:30 PM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 19,364
Default Re: CPU spike and errors on PT Ultimate/HDX system

Quote:
Originally Posted by clivvy View Post
its a moon shot won't hold my breath on the cpu spikes fix!
Sure. Most often the cpu spikes problem goes away once you move all 3rd party plugins to unused folder tedious job to find out which plugin needs update but 99.99% sure it is not one of Avid's
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #7  
Old 03-16-2020, 02:41 AM
the.engineer the.engineer is offline
Member
 
Join Date: Nov 2009
Location: Guildford, Surrey, UK
Posts: 274
Default Re: CPU spike and errors on PT Ultimate/HDX system

I’m currently in the middle of this process myself
__________________
James Welch
Recording Engineer | Producer
Masterlink Productions

Mac Pro 5,1 (Mid 2010) | 3.46GHz Six-Core Intel Xeon | 32GB Ram | AMD Radeon RX 580 8GB | Apple 27" LED Cinema | 500GB Samsung 960 EVO M.2 SSD System Drive | 1TB WDC Sample Drive | 512GB Samsung SSD Audio Drive (temporary) | UAD-2 Quad PCIe
Mojave 10.14.6 | Pro Tools Ultimate 2019.12 | HDX | Avid Omni | Avid 16x16 HD I/O x2 | Digidesign 192 | Digidesign C24
Reply With Quote
  #8  
Old 03-16-2020, 07:40 AM
smokeydan smokeydan is offline
Member
 
Join Date: May 2010
Location: Manchester UK
Posts: 53
Default Re: CPU spike and errors on PT Ultimate/HDX system

Success!
I've just been through the plug in folder, updating this and that. I discovered that certain Waves v9 plug ins do not play well with ProTools 2019.12, especially Abbey Rd Plates and Kramer Tape. These were both causing spikes in the CPU meter and then a variety of errors. I updated all waves to v11 and got rid of the v9 and v10 waveshells, and now it can happily run all of our multi track sessions at the minimum buffer setting with stable CPU usage showing (far lower than on PT2018) with just one exception - if an instance of Altiverb is active on an audio track, it will not allow uninterrupted playback on the minimum buffer setting. In this instance, to play back without errors the buffer size must be raised to the highest setting to allow reliable playback. Multiple altiverbs on multiple aux channels is not an issue.

So, apart from everything else that's going on right now, I'm delighted. I've been wrestling with these issues for two years! I might have a drink to celebrate.
__________________
Mac Pro 5,1, 2 x 3.46Ghz six core Xeon, 64GB RAM, High Sierra, PT Ultimate 2019.12, H/D Native PCie, Omni interface.
Mac Pro 6,1 12 core, 64GB RAM, High Sierra, PT Ultimate 2019.12, 2xHDX cards in Sonnet TB Chassis, 2 x Lynx Aurora 16 interfaces.
MacBook Pro 32GB RAM Catalina, PT 2020.3, non-functioning MBox 3 Pro
Reply With Quote
  #9  
Old 03-16-2020, 07:42 AM
JFreak's Avatar
JFreak JFreak is offline
Moderator
 
Join Date: Jan 2003
Location: Tampere, Finland
Posts: 19,364
Default Re: CPU spike and errors on PT Ultimate/HDX system

Quote:
Originally Posted by smokeydan View Post
I might have a drink to celebrate.
I'll join you.

I have been so much happier once I ditched the WavesHell altogether. It was good with TDM but the latest versions are nothing but headache
__________________
Janne
What we do in life, echoes in eternity.
Reply With Quote
  #10  
Old 03-16-2020, 08:11 AM
the.engineer the.engineer is offline
Member
 
Join Date: Nov 2009
Location: Guildford, Surrey, UK
Posts: 274
Default Re: CPU spike and errors on PT Ultimate/HDX system

Do any of you guys have Melodyne installed?

I’ve been pulling my plugins around over the past few days and since putting melodyne back in I’ve been getting 9093’s again.
__________________
James Welch
Recording Engineer | Producer
Masterlink Productions

Mac Pro 5,1 (Mid 2010) | 3.46GHz Six-Core Intel Xeon | 32GB Ram | AMD Radeon RX 580 8GB | Apple 27" LED Cinema | 500GB Samsung 960 EVO M.2 SSD System Drive | 1TB WDC Sample Drive | 512GB Samsung SSD Audio Drive (temporary) | UAD-2 Quad PCIe
Mojave 10.14.6 | Pro Tools Ultimate 2019.12 | HDX | Avid Omni | Avid 16x16 HD I/O x2 | Digidesign 192 | Digidesign C24
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A TON of spike and errors with 12.8 9093/72 pqlior@mac.com Pro Tools 12 38 06-29-2017 02:54 PM
Buffer Errors (6086 and 9128) using Komplete 9 Ultimate Instruments dunnaj Virtual Instruments 0 05-29-2013 12:14 PM
Windows 7 Ultimate Freezing and BSOD Errors! terrencej31 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 0 04-13-2012 05:05 AM
Processor spike & system freeze-up is sessions psalmeister 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 9 04-25-2010 04:40 AM
Multiple blue screen errors when trying to install/run PT 8.03 in Windows 7 Ultimate WorshiperDj 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 5 01-14-2010 02:50 PM


All times are GMT -7. The time now is 11:05 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com