Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Win)

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-03-2019, 05:54 PM
bscism bscism is offline
Member
 
Join Date: Sep 2004
Posts: 17
Default firewire connection to USB? Or Other?

I need help, or recommendations and your responses are appreciated, thanks in advance.


I have the MBox Pro Gen 3 interface which is a firewire connectivity. I now have to get a new computer (mine is 12 years old) and firewire is no longer included on computers. Is there a connector of some kind that will allow my firewire to connect to a USB port on the new computer?



Or what other solutions are possible?


Thanks.
Bruce
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PT 12.7.1 would not see my Firewire connection! Chopper Pro Tools 12 1 04-30-2017 09:29 AM
firewire connection ? bscism 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 2 09-18-2011 06:16 PM
PT 6.9 & 002 Firewire connection HELP!!! narnia040 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 4 10-18-2005 08:02 PM
firewire connection breaks down Hans Friedrich 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 08-10-2003 11:05 AM
002 firewire connection ok? doubleyouel 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 11-23-2002 01:58 PM


All times are GMT -7. The time now is 10:52 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com