Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Win)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-27-2014, 08:26 PM
AoyamaJPN AoyamaJPN is offline
Member
 
Join Date: Sep 2014
Location: Pacific NorthWest
Posts: 9
Default Fast Track Pro, No Sound, Windows 8.1 w/ latest drivers

Hello everyone,

I've been searching for many hours on how to get my Fast Track Pro to work with my new PC (Windows 8.1). I've just built this new PC and am migrating from using the FTP on an older MacBook (worked fine).

Basically, I went to the Avid site and downloaded the latest drivers (which indicates Windows 8 compatibility). Then, I connected the FTP via USB. Nothing happened.

In Windows, when I look at the "manage audio devices" screen, the FTP is not listed. The default audio is the built-in one and I cannot change to the FTP. However, under "pc devices and settings" I can see the FTP when it's connected, the only action I have there is "remove", which doesn't help.

My assumption is that with the device connected, I would have the option to select it as the output device (perhaps listed when the sound icon is clicked from the taskbar).

I quickly downloaded Reaper to see if I could see the FTP listed as a device, but it's not. I used Logic on my macbook, and was eventually going to move to Pro Tools.

Any help getting this setup would be greatly appreciated.

Thank you!
Reply With Quote
  #2  
Old 09-28-2014, 08:16 PM
AoyamaJPN AoyamaJPN is offline
Member
 
Join Date: Sep 2014
Location: Pacific NorthWest
Posts: 9
Default Re: Fast Track Pro, No Sound, Windows 8.1 w/ latest drivers

in case anyone looks at this later, i backdated the driver and it worked. i still can't get the latest 6.1.12 to work correctly with windows 8.1. but, 6.06 worked. other early versions did not work, just 6.06. available here: http://avid.force.com/pkb/articles/e...-Track-Drivers

hope this helps someone later.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fast Track Pro 6.1.10 drivers won't install on Windows 8.1 64bit Leg@cyGuy FireWire and USB Audio Interfaces (Win) 15 07-23-2014 07:12 PM
Fast Track USB latest driver causes BSOD mli FireWire and USB Audio Interfaces (Win) 0 02-05-2014 12:51 PM
Fast Track Ultra - Sound glitch at 96Khz in Windows 8 Readysound FireWire and USB Audio Interfaces (Win) 9 12-28-2013 01:07 PM


All times are GMT -7. The time now is 10:24 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com