Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Additional Resources


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-24-2015, 09:35 AM
thegame15 thegame15 is offline
Member
 
Join Date: Jul 2014
Location: Canada
Posts: 12
Default El Capitan and Mbox 2 Drivers.

If you were considering upgrading you Mac OS X to El Capitan 10.11 I would deeply reconsider that if you are using an Mbox 2 related devices.

Over the last couple of days I've installed OS X El Capitan 10.11 GM Candidate and any updates that were available up to September 23, 2015 on a spare hard drive as I'm apart of the public beta program for El Capitan, and the results are not good if you plan on using your Mbox 2 or related drivers.

My tests were conducted with 10.11 GM Candidate and then updated to 10.11.1 Public Beta 1.

10.3.3 Drivers - Installed fine, all green lights on Mbox 2 device are bright green as if everything is working fine, Both directly connected to USB port and via Hub. The preference pane for the Mbox 2 says it's not connected, and under sound (System Preference) it doesn't show up at all. So there is some sort of connection but it does not register at all and it basically useless at the moment, but maybe Avid can do some investigating and work with Apple to find a resolution to the problem.

10.3.9 Drivers - Installs fine, lights are all dim with really no signs of life. Both directly connected to USB port and via Hub, The preference pane for the Mbox 2 says it's not connected, and under sound (System Preference) it doesn't show up at all. So just like Yosemite this driver is DOA.

So these are the results of testing both drivers, as it stands El Capitan 10.11 is your Mbox 2 Killer, unless someone finds a possible solution.
__________________
Macbook Pro 13 inch Mid 2010, 2.4 GHz Intel Core 2 Duo, 8 GB 1067 MHz DDR3, Yosemite OS X 10.10.3, Mbox 2
Reply With Quote
  #2  
Old 09-30-2015, 07:24 AM
MarcelMendesFilho MarcelMendesFilho is offline
Member
 
Join Date: Sep 2015
Location: Curitiba - BR
Posts: 3
Default Re: El Capitan and Mbox 2 Drivers.

I own Mbox 3 and it didn't work with Mac OS El Capitan golden version. I installed the latest version drivers. I don't recommend the upgrade to El Capitan until AVID provides a new version of drivers for Mbox 3.
Reply With Quote
  #3  
Old 10-13-2015, 02:24 PM
nordlig nordlig is offline
Member
 
Join Date: Nov 2009
Posts: 20
Default Re: El Capitan and Mbox 2 Drivers.

I wonder if this software from focusrite will get the mbox going? Anyone tried?

There is tho a user who has the Mbox2 going on elcapitan in a newr topic here in this forum. he has not done any testing yet he says.
Reply With Quote
  #4  
Old 10-14-2015, 10:45 AM
JoelG's Avatar
JoelG JoelG is offline
Moderator
 
Join Date: Mar 2010
Location: Canada
Posts: 1,850
Default Re: El Capitan and Mbox 2 Drivers.

I don't think the Mbox is class compliant, basically that would mean if you plug it in, it will work without drivers.

Good article here:http://www.sweetwater.com/insync/class-compliant/

Joel
__________________
Jame Space:
HP Elite 6300 / Core i5 3570 / 12GB RAM / Win 10 Pro
Pro Tools 12 HD / Focusrite 18i20 + M-Audio ProFire 2626

Home:
Intel S5000PSL / 2 x Xeon E5450 / 32GB RAM / Win 10 Pro
Pro Tools 12 HD / M-Audio Project Mix IO

Rig:
Eleven Rack / ART SLA1 / Fender Mustang V 412 / FCB1010 w/ EurekaPROM
Reply With Quote
  #5  
Old 10-31-2015, 02:09 PM
nielsd's Avatar
nielsd nielsd is offline
Member
 
Join Date: Mar 2013
Location: Göttingen
Posts: 8
Default Re: El Capitan and Mbox 2 Drivers.

Hi Guys,

i run the Mbox3 pro which is working without the Mbox3 Panel (usable only in DAW Host control). The Mbox3 Pro Panel crashes when tried to start.

The Mbox Panel (which has the same code case as the one for Mbox Pro 3rd, except that it has different channel amounts) is starting correctly, crazy...

If AVID isn't coming with an update i will switch over to a Apollo 8 from UAD, which was on my list for the next half year. All of my (complex) DAW workstation and external hardware stuff is still working, except these AVID Mbox software). Hey, these boxes are not cheap - at least a working beta should be there and the fact that the Mbox Panel and the Mbox Pro 3rd driver is working under 10.11 should let assume that it just takes some minutes to an hour to fix the bugs for 10.11.


good luck so far,


Niels.
__________________
---
dettenbach audio
http://dettenbach.de
Reply With Quote
  #6  
Old 11-02-2015, 08:06 AM
AlfG AlfG is offline
Member
 
Join Date: Nov 2015
Location: USA
Posts: 1
Default Re: El Capitan and Mbox 2 Drivers.

Quote:
Originally Posted by thegame15 View Post
If you were considering upgrading you Mac OS X to El Capitan 10.11 I would deeply reconsider that if you are using an Mbox 2 related devices.

Over the last couple of days I've installed OS X El Capitan 10.11 GM Candidate and any updates that were available up to September 23, 2015 on a spare hard drive as I'm apart of the public beta program for El Capitan, and the results are not good if you plan on using your Mbox 2 or related drivers.

My tests were conducted with 10.11 GM Candidate and then updated to 10.11.1 Public Beta 1.

10.3.3 Drivers - Installed fine, all green lights on Mbox 2 device are bright green as if everything is working fine, Both directly connected to USB port and via Hub. The preference pane for the Mbox 2 says it's not connected, and under sound (System Preference) it doesn't show up at all. So there is some sort of connection but it does not register at all and it basically useless at the moment, but maybe Avid can do some investigating and work with Apple to find a resolution to the problem.

10.3.9 Drivers - Installs fine, lights are all dim with really no signs of life. Both directly connected to USB port and via Hub, The preference pane for the Mbox 2 says it's not connected, and under sound (System Preference) it doesn't show up at all. So just like Yosemite this driver is DOA.

So these are the results of testing both drivers, as it stands El Capitan 10.11 is your Mbox 2 Killer, unless someone finds a possible solution.
Hello,

Is there any news on the solution to make Mbox2 work with OS X El Captain?
Any info is greatly appreciated!

Thanks!
-A
Reply With Quote
  #7  
Old 11-11-2015, 04:43 PM
tone matrix tone matrix is offline
Member
 
Join Date: Apr 2006
Posts: 5
Default Re: El Capitan and Mbox 2 Drivers.

Should I give up hope on there ever being a fix for the Mbox2/El Crapitan?
I managed to get the mbox2 lit up but of course it's not recognized in system preferences etc.

I had to get my imac repaired and of course didn't get the choice of an older OS, so I'm stuck now with El Capitan and a brain dead mbox2.

Cmon Avid please don't let this stay dead!
There has to be some sort of workaround to get this functioning again.
Please? Anybody? Class?

I really am trying not to buy a new interface (for financial reasons) but the way it's looking I will have to make the jump sometime soon.
Any one have a contact for avid support directly?
Don't let this thread die yet!
*crosses fingers*
Reply With Quote
  #8  
Old 11-11-2015, 04:59 PM
JoelG's Avatar
JoelG JoelG is offline
Moderator
 
Join Date: Mar 2010
Location: Canada
Posts: 1,850
Default Re: El Capitan and Mbox 2 Drivers.

Looks like the Mbox 2 won't be getting further driver updates:http://duc.avid.com/showthread.php?t=374091

Joel
__________________
Jame Space:
HP Elite 6300 / Core i5 3570 / 12GB RAM / Win 10 Pro
Pro Tools 12 HD / Focusrite 18i20 + M-Audio ProFire 2626

Home:
Intel S5000PSL / 2 x Xeon E5450 / 32GB RAM / Win 10 Pro
Pro Tools 12 HD / M-Audio Project Mix IO

Rig:
Eleven Rack / ART SLA1 / Fender Mustang V 412 / FCB1010 w/ EurekaPROM
Reply With Quote
  #9  
Old 11-11-2015, 10:32 PM
tone matrix tone matrix is offline
Member
 
Join Date: Apr 2006
Posts: 5
Default Re: El Capitan and Mbox 2 Drivers.

What a bummer, I've had this since 2005.
Nice to know products I buy eventually just get unsupported.
Oh well I guess it's time to do some research on a new not_avid_interface.
Thank you :)
Reply With Quote
  #10  
Old 11-21-2015, 05:45 AM
nordlig nordlig is offline
Member
 
Join Date: Nov 2009
Posts: 20
Default Re: El Capitan and Mbox 2 Drivers.

I found no other option than selling my Mbox2 if I am still to use latest OSX and applications editing Audio.

Of course one could use Linux, as the drivers/support for Mbox 2 is said to be compliant out of the box with the new Linux kernel, but that is not for me.

For the money I got I bought a OSX class compliant Focusrite Scarlet 2i2 and it works fine with El Capitan, without any drivers.

What i think and what i hope Avid would consider is that thees audio devices Avid and other vendors do should be class compliant to some degree out of the box - at least for playback. There could always be latency issues and features solved with drivers but not totally a dead device without.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
S3 and El Capitan - no go Cliffy_Boy Pro Tools | S3 9 11-16-2015 07:27 AM
Problem With 11R, PT 12 & El Capitan donebylee Eleven Rack 18 10-30-2015 02:04 PM
PT12 and El Capitan Cliffy_Boy Pro Tools 12 64 10-26-2015 07:12 AM
El Capitan mastertstudio Pro Tools HDX & HD Native Systems (Mac) 21 10-25-2015 03:55 PM
C400 with OSX El Capitan GM jesush1234 FireWire and USB Audio Interfaces (Mac) 1 09-11-2015 02:40 PM


All times are GMT -7. The time now is 03:36 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com