Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > Pro Tools | Control

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-18-2017, 08:56 AM
moranibus moranibus is offline
Member
 
Join Date: May 2017
Location: Vienna
Posts: 23
Default EuControl 3.7 crashes immediately with PT

Says it all. PT updated to 12.8.2
__________________
PT Ultimate, Avid S3, Avid Artist Transport, Pro Tools Control
Reply With Quote
  #2  
Old 10-18-2017, 10:18 AM
The Mixing Factory The Mixing Factory is offline
Member
 
Join Date: Oct 2017
Location: London (UK)
Posts: 5
Default Re: EuControl 3.7 crashes immediately with PT

Same here, and same issue with other DAWs...
Reply With Quote
  #3  
Old 10-18-2017, 10:59 AM
The Mixing Factory The Mixing Factory is offline
Member
 
Join Date: Oct 2017
Location: London (UK)
Posts: 5
Default Re: EuControl 3.7 crashes immediately with PT

Actually moranibus, try uninstalling v3.7 and trashing the folder "Euphonix" left in your applications folder (assuming you are on MacOS), install again v3.7 with all other apps closed but peripherals switched on. Open EUC and tick EUcontrol under the "Auto-launch Apps" sub menu, restart the computer (EUC should now open on boot up) and open PT.
This worked for me, I didn't uninstall the old version before installing v3.7, I asume that was the issue and probably provoked a preferences issue...
Reply With Quote
  #4  
Old 10-18-2017, 11:30 AM
moranibus moranibus is offline
Member
 
Join Date: May 2017
Location: Vienna
Posts: 23
Default Re: EuControl 3.7 crashes immediately with PT

Quote:
Originally Posted by The Mixing Factory View Post
Actually moranibus, try uninstalling v3.7 and trashing the folder "Euphonix" left in your applications folder (assuming you are on MacOS), install again v3.7 with all other apps closed but peripherals switched on. Open EUC and tick EUcontrol under the "Auto-launch Apps" sub menu, restart the computer (EUC should now open on boot up) and open PT.
This worked for me, I didn't uninstall the old version before installing v3.7, I asume that was the issue and probably provoked a preferences issue...
Thanks, man. No success. Did everything as requested.
__________________
PT Ultimate, Avid S3, Avid Artist Transport, Pro Tools Control
Reply With Quote
  #5  
Old 10-18-2017, 11:36 AM
Sandborg Sandborg is offline
Member
 
Join Date: Nov 2012
Location: Copenhagen, Denmark
Posts: 8
Default Re: EuControl 3.7 crashes immediately with PT

Thanks The Mixing Factory!
This worked for me, so you saved my day, didn't have to delete the folder from applications, that happened automatically when uninstalling Eucontrol.
Reply With Quote
  #6  
Old 10-18-2017, 11:39 AM
hugoleitao hugoleitao is offline
Member
 
Join Date: Aug 2010
Location: Lisbon
Posts: 36
Default Re: EuControl 3.7 crashes immediately with PT

Quote:
Originally Posted by moranibus View Post
Says it all. PT updated to 12.8.2
same here...
Reply With Quote
  #7  
Old 10-18-2017, 12:21 PM
The Mixing Factory The Mixing Factory is offline
Member
 
Join Date: Oct 2017
Location: London (UK)
Posts: 5
Default Re: EuControl 3.7 crashes immediately with PT

hmm... all I can suggest then is to trash PT's preferences but that ain't exactly fun... good luck!
Reply With Quote
  #8  
Old 10-18-2017, 12:22 PM
The Mixing Factory The Mixing Factory is offline
Member
 
Join Date: Oct 2017
Location: London (UK)
Posts: 5
Default Re: EuControl 3.7 crashes immediately with PT

Quote:
Originally Posted by Sandborg View Post
Thanks The Mixing Factory!
This worked for me, so you saved my day, didn't have to delete the folder from applications, that happened automatically when uninstalling Eucontrol.
cool! glad it worked...
Reply With Quote
  #9  
Old 10-18-2017, 02:23 PM
EddieJones's Avatar
EddieJones EddieJones is offline
Avid
 
Join Date: Dec 2014
Location: Santa Cruz
Posts: 1,974
Default Re: EuControl 3.7 crashes immediately with PT

We found the issue and it's not to do with the software but the installer. The workaround until we generate a new installer is to simply uninstall 3.7(or3.6) and reinstall it. No need for the Clean EUCON script. If this doesn't work you can manually delete the offending files after uninstalling:

You can do this in the Finder by going to the Go menu and choosing Go To Folder… and type in /usr/local/lib

You should not see libEuCon2.dylib or libEuConDLL.dylib
If you do, delete them, then reinstall.

We are working on the new installer......
Reply With Quote
  #10  
Old 10-18-2017, 07:38 PM
Ed Douglas's Avatar
Ed Douglas Ed Douglas is offline
Member
 
Join Date: Dec 1969
Location: Toronto Ont, Canada
Posts: 241
Default Re: EuControl 3.7 crashes immediately with PT

Thanks for this... it was driving me nuts. Turning off "Enable EUCON" in the peripherals dialog prevents the crash but defeats the purpose. Will try clean reinstalling as per your instructions.

Cheers!

E>

Update - All is well now! Thanks again!!

Quote:
Originally Posted by EddieJones View Post
We found the issue and it's not to do with the software but the installer. The workaround until we generate a new installer is to simply uninstall 3.7(or3.6) and reinstall it. No need for the Clean EUCON script. If this doesn't work you can manually delete the offending files after uninstalling:

You can do this in the Finder by going to the Go menu and choosing Go To Folder… and type in /usr/local/lib

You should not see libEuCon2.dylib or libEuConDLL.dylib
If you do, delete them, then reinstall.

We are working on the new installer......
__________________
Neotech Concepts
http://www.imdb.com/name/nm0235036/
! sonic gymnastics for the illusionary arts !

Portable - 2019 i9 MacBook Pro (15,3), macOS X 10.14.5, PT Ultimate 2019.5, Rx7 Advanced, Ozone 8 Advanced, Kontakt 6.1.0, Soundminer v4.5Pro, Spanner 3.0.3, SoundHack 0.896, EuControl 19.5, PT|Control 19.7.x, iPad Pro 12.9" gen 1, iPad Pro 12.9" gen 3, Apollo 8 Duo tb2, UAD-2 Satellite Quad tb2, x2 Glyph 2TB SSDs, OWC tb3 Dock, OWC Thunderbay 4 28TB

Last edited by Ed Douglas; 10-18-2017 at 07:47 PM. Reason: update
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pro Tools crashes immediately Rich Crescenti 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 09-21-2010 03:44 PM
PT8 M-Powered Crashes Immediately chrisconover Pro Tools M-Powered (Mac) 10 05-31-2009 10:19 PM
ProTools crashes the system immediately amfm 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 3 03-23-2008 01:48 PM
LE 6.4 crashes immediately with 002R j20056 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 1 03-27-2005 06:37 AM
Mac G4 Crashes Immediately...I'm really new to this luapfitz Pro Tools TDM Systems (Mac) 2 09-04-2000 05:40 AM


All times are GMT -7. The time now is 07:23 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com