Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Pro Tools 2020

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 11-15-2020, 02:41 AM
weezul weezul is offline
Member
 
Join Date: May 2007
Location: Newcastle, UK
Posts: 402
Default Re: Low Buffer CPU Optimization

Quote:
Originally Posted by Darryl Ramm View Post
Ugh Weezul, my apologies
It's all good, I feel your frustration if everyone with a 2i2 and a laptop comes in complaining about realtime performance, but I do know my machine well and I think RME PCIe is a good platform for testing in terms of eliminating badly written drivers. And yes this is completely different to what I've experienced in the past. Even at 128 buffer the CPU usage is just so high. Another oddity is when I was at 32 or 64, with the screenshot posted, the session playback head jerks, pro tools is 'playing' but the audio is choppy, with no error messages on playback. It just struggles on. I've ran PT on Windows on an i7 5th gen laptop with middling latency results and X-AIR18 interface, it was much better behaved than this. I'd try 2020.9 on my Windows partition as well but I don't have the installer file. I think the last version I tried on my windows partition was probably some version of 2019, which behaved as expected.

I also have a Steinberg UR824 I use in standalone with the RayDAT. I'll try installing the drivers for it and using that in the playback engine to see what happens. If you think I can grab anything else from the machine to help people then let me know and I'll grab whatever is needed next time I'm in Windows.
__________________
http://www.liamgaughan.com
Reply With Quote
  #12  
Old 11-15-2020, 02:53 AM
Emi's Avatar
Emi Emi is offline
Member
 
Join Date: Dec 2017
Location: Madrid. Spain
Posts: 462
Default Re: Low Buffer CPU Optimization

Quote:
Originally Posted by JingleDjango View Post
I would expect to see similar low buffer optimization on Windows if and when Carbon is qualified for that OS.
And that’s sad. It’s all about the money and interest.
__________________
Mac Mini M1 | Mac OS Big Sur 11.2 | Motu 16A | Motu 828ES | Motu 1248 | Pro Tools 2020.12 Native
Reply With Quote
  #13  
Old 11-15-2020, 06:45 AM
Ru_C Ru_C is offline
Member
 
Join Date: Oct 2004
Location: London + Bedford, UK
Posts: 940
Default Re: Low Buffer CPU Optimization

Quote:
Originally Posted by weezul View Post
It's all good, I feel your frustration if everyone with a 2i2 and a laptop comes in complaining about realtime performance..
..I actually have a 2i2 on my home rig (which is an an ancient 5.1 Mac Pro). I just tested the new Mac Low buffer optimisations & it works great. Hallelujah! I can finally track guitars at home on sessions at 96k/64buffer that would have been impossible before.

Can't wait to try this on my main Native PCI-e rig in the next few weeks.
__________________
A Rig: OSX 10.15.6, PT Ultimate2020.11.1, Native PCI-e Card, AVID I/O16 Analog i/o x2, 40 fader D-Command ES

B Rig: OSX 10.9.5, PT HD 10.3.10, HD3 Accel, AVID192D+ 2xPresonus FS8 for I/o, 32 fader Pro Control

C Rig: (Home/Office). OSX 10.14.6, PT Ultimate2020.11.0, Focusrite 2i2 (2nd Gen), Faderport
Reply With Quote
  #14  
Old 11-17-2020, 08:22 PM
arche3's Avatar
arche3 arche3 is offline
Member
 
Join Date: Jan 2001
Location: New York, NY
Posts: 1,031
Default Re: Low Buffer CPU Optimization

OMG. it is actually working at low buffer.... I cannot believe it.
Reply With Quote
  #15  
Old 11-17-2020, 09:48 PM
Daveporter33765 Daveporter33765 is offline
Member
 
Join Date: Jul 2019
Location: Clearwater
Posts: 4
Default Re: Low Buffer CPU Optimization

Very low CPU usage at 32 Samples here! Finally the audio engine has been fixed!
__________________
Luna 1.1.1, Logic Pro 10.6, Cubase Pro 11, Studio One 5.1.1, Pro Tools 2020.11, UAD-2 software 9.13, PreSonus Quantum 2, UA Apollo 8, UA Apollo 8P, UA Apollo Twin Mk 2 (2), UAD-2 Thunderbolt Satellite Quad (2), Studio A: Apple iMac 2020, i7 3.8 GHz, 64 GB RAM, 1 TB SSD, RP5700XT GPU, 10 Gb/s Ethernet, MacOS Catalina 10.15.7; Studio B: Apple iMac 2015, i7 4 GHz, 64 GB RAM, 1 TB SSD, RP 395X GPU, 1 Gb/s Ethernet, MacOS Catalina 10.15.7.
Reply With Quote
  #16  
Old 11-18-2020, 07:58 AM
lesbrunn's Avatar
lesbrunn lesbrunn is offline
Member
 
Join Date: Feb 2002
Location: Accra, Ghana
Posts: 808
Default Re: Low Buffer CPU Optimization

Quote:
Originally Posted by arche3 View Post
OMG. it is actually working at low buffer.... I cannot believe it.
Happy for you! But it should work equally well on both major platforms. We pay the same $, don't we? So some people are being short-changed.
__________________
X99 | i7 5960x @4.6GHz | 64GB GSkill DDR4 | Nvidia GTX 950 | Samsung 950 Pro NVMe 256GB | Samsung SM961 NVMe 1TB | Samsung 850 EVO 1TB | Samsung MZ7PD256 SSD 256GB | Kingston 120GB SSD | WD Black 1TB x2 | G-Drive 4TB x2 | WD Elements 4TB | Audient ID14 | PT2020.12 | Windows 10 Pro
Reply With Quote
  #17  
Old 11-18-2020, 08:08 AM
Emi's Avatar
Emi Emi is offline
Member
 
Join Date: Dec 2017
Location: Madrid. Spain
Posts: 462
Default Re: Low Buffer CPU Optimization

Quote:
Originally Posted by lesbrunn View Post
Happy for you! But it should work equally well on both major platforms. We pay the same $, don't we? So some people are being short-changed.
Yes, but Carbon is not Windows ready yet. I’m pretty sure you’ll have low buffer optimization once Carbon is

They have proven they could have had a very stable Pro tools Native. But they were scared hardware sells would have dropped. Anyway the market goes towards a more native approach because you have more and more powerful computers.

Anyway ����*♂️
__________________
Mac Mini M1 | Mac OS Big Sur 11.2 | Motu 16A | Motu 828ES | Motu 1248 | Pro Tools 2020.12 Native
Reply With Quote
  #18  
Old 11-18-2020, 09:22 AM
arche3's Avatar
arche3 arche3 is offline
Member
 
Join Date: Jan 2001
Location: New York, NY
Posts: 1,031
Default Re: Low Buffer CPU Optimization

Quote:
Originally Posted by lesbrunn View Post
Happy for you! But it should work equally well on both major platforms. We pay the same $, don't we? So some people are being short-changed.
I thought windows machines always worked better anyways for low buffers. Mac osX has been horrible for I don't know.... 7 years? It's been that long I can't remember.

Sent from my SM-G986U using Tapatalk
Reply With Quote
  #19  
Old 11-18-2020, 11:49 AM
ZEUSS ZEUSS is offline
Member
 
Join Date: Aug 2002
Posts: 618
Default Re: Low Buffer CPU Optimization

It doesn't seem to be doing anything for my system. Maybe because I am still on Mohave? I arm a few amplitubes or load up 1 Kontakt and its still spike city. Even with the plugins current..
__________________
10.15.7 (19H15) Mac Pro 2013 (Trashcan) 6 Core 64 gigs Ram, Red Line 16, Native Thunderbolt, ProTools Ultimate 2020.11

Macbook Pro, 2019 (15,1) 32 Gigs Ram,2.3 GHz I9 8 Core ProTools Ultimate 2020.5, Apollo 8 Silver,TwinX.
Reply With Quote
  #20  
Old 11-18-2020, 12:06 PM
Daveporter33765 Daveporter33765 is offline
Member
 
Join Date: Jul 2019
Location: Clearwater
Posts: 4
Default Re: Low Buffer CPU Optimization

Quote:
Originally Posted by arche3 View Post
I thought windows machines always worked better anyways for low buffers. Mac osX has been horrible for I don't know.... 7 years? It's been that long I can't remember.

Sent from my SM-G986U using Tapatalk
In my experience Macs were capable of very low latency and very efficient performance with every DAW but Pro Tools for a very long time. Now that Pro Tools audio engine has been optimized, it’s the same as all the other DAWs. So it wasn’t a Mac problem, but a Pro Tools problem.
__________________
Luna 1.1.1, Logic Pro 10.6, Cubase Pro 11, Studio One 5.1.1, Pro Tools 2020.11, UAD-2 software 9.13, PreSonus Quantum 2, UA Apollo 8, UA Apollo 8P, UA Apollo Twin Mk 2 (2), UAD-2 Thunderbolt Satellite Quad (2), Studio A: Apple iMac 2020, i7 3.8 GHz, 64 GB RAM, 1 TB SSD, RP5700XT GPU, 10 Gb/s Ethernet, MacOS Catalina 10.15.7; Studio B: Apple iMac 2015, i7 4 GHz, 64 GB RAM, 1 TB SSD, RP 395X GPU, 1 Gb/s Ethernet, MacOS Catalina 10.15.7.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mac OS optimization for PT madcow 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 02-04-2007 10:19 AM
Buffer errors even with optimization andre67 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 5 04-15-2006 01:17 PM
Optimization for XP rems 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 2 01-31-2004 08:20 AM
OSX optimization audioeric 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 4 07-09-2003 10:10 PM
PT Optimization DarkShade 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 7 01-15-2002 04:11 PM


All times are GMT -7. The time now is 05:35 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com